- new upstream version
- drop upstreamed patches; ./autogen nut needed anymore - pack the xbrlapi server; move its man page to brlapi package
This commit is contained in:
parent
ba73242126
commit
243c6e3250
@ -1 +1 @@
|
|||||||
brltty-3.10.tar.gz
|
brltty-4.0.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
2008-09-12 Stepan Kasal <skasal@redhat.com>
|
|
||||||
|
|
||||||
* aclocal.m4 (BRLTTY_HELP_STRING, BRLTTY_TEXT_TABLE,
|
|
||||||
BRLTTY_ATTRIBUTES_TABLE): Expand parameters to AC_HELP_STRING
|
|
||||||
and m4_text_wrap, to be compatible with Autoconf 2.62+.
|
|
||||||
|
|
||||||
--- brltty-3.9.orig/aclocal.m4.orig 2007-10-17 17:19:31.000000000 +0200
|
|
||||||
+++ brltty-3.9.orig/aclocal.m4 2008-09-12 18:05:21.000000000 +0200
|
|
||||||
@@ -144,7 +144,7 @@
|
|
||||||
|
|
||||||
AC_DEFUN([BRLTTY_HELP_STRING], [dnl
|
|
||||||
AC_HELP_STRING([$1], patsubst([$2], [
|
|
||||||
-.*$]), [brltty_help_prefix])dnl
|
|
||||||
+.*$]), m4_defn([brltty_help_prefix]))dnl
|
|
||||||
patsubst(patsubst([$2], [\`[^
|
|
||||||
]*]), [
|
|
||||||
], [\&brltty_help_prefix])[]dnl
|
|
||||||
@@ -384,11 +384,11 @@
|
|
||||||
|
|
||||||
AC_DEFUN([BRLTTY_TEXT_TABLE], [dnl
|
|
||||||
define([brltty_tables_text], ifdef([brltty_tables_text], [brltty_tables_text])[
|
|
||||||
-m4_text_wrap([$2], [ ], [- m4_format([%-8s ], [$1])], brltty_help_width)])])
|
|
||||||
+m4_text_wrap([$2], [ ], [- ]m4_format([%-8s ], [$1]), brltty_help_width)])])
|
|
||||||
|
|
||||||
AC_DEFUN([BRLTTY_ATTRIBUTES_TABLE], [dnl
|
|
||||||
define([brltty_tables_attributes], ifdef([brltty_tables_attributes], [brltty_tables_attributes])[
|
|
||||||
-m4_text_wrap([$2], [ ], [- m4_format([%-10s ], [$1])], brltty_help_width)])])
|
|
||||||
+m4_text_wrap([$2], [ ], [- ]m4_format([%-10s ], [$1]), brltty_help_width)])])
|
|
||||||
|
|
||||||
AC_DEFUN([BRLTTY_SUMMARY_BEGIN], [dnl
|
|
||||||
brltty_summary_lines="Options Summary:"
|
|
@ -1,17 +0,0 @@
|
|||||||
2008-09-17 Stepan Kasal <skasal@redhat.com>
|
|
||||||
|
|
||||||
* configure.ac: Add -D_GNU_SOURCE to get struct ucred from
|
|
||||||
socket.h.
|
|
||||||
|
|
||||||
diff -up brltty-3.10/configure.ac.gnusource brltty-3.10/configure.ac
|
|
||||||
--- brltty-3.10/configure.ac.gnusource 2008-07-17 00:19:54.000000000 +0200
|
|
||||||
+++ brltty-3.10/configure.ac 2008-09-17 12:44:28.000000000 +0200
|
|
||||||
@@ -779,7 +779,7 @@ AC_CACHE_CHECK([for system-dependent com
|
|
||||||
case "${host_os}"
|
|
||||||
in
|
|
||||||
linux*|gnu*|kfreebsd*)
|
|
||||||
- brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_XOPEN_SOURCE_EXTENDED"
|
|
||||||
+ brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_XOPEN_SOURCE_EXTENDED -D_GNU_SOURCE"
|
|
||||||
;;
|
|
||||||
solaris*)
|
|
||||||
brltty_cv_prog_cc_sysflags="-D_XOPEN_SOURCE=500 -D__EXTENSIONS__"
|
|
@ -5,16 +5,14 @@
|
|||||||
"make brlapi" when parallel make is used. Recursive make is
|
"make brlapi" when parallel make is used. Recursive make is
|
||||||
harmful.
|
harmful.
|
||||||
|
|
||||||
diff -up brltty-3.10/Makefile.in.parallel brltty-3.10/Makefile.in
|
--- brltty-4.0/Programs/Makefile.in.parallel 2009-10-07 20:48:57.000000000 +0200
|
||||||
diff -up brltty-3.10/Programs/Makefile.in.parallel brltty-3.10/Programs/Makefile.in
|
+++ brltty-4.0/Programs/Makefile.in 2009-10-07 20:50:03.000000000 +0200
|
||||||
--- brltty-3.10/Programs/Makefile.in.parallel 2008-07-17 00:19:08.000000000 +0200
|
@@ -428,7 +428,7 @@
|
||||||
+++ brltty-3.10/Programs/Makefile.in 2008-09-17 11:24:35.000000000 +0200
|
|
||||||
@@ -399,7 +399,7 @@ apitest.$O:
|
|
||||||
|
|
||||||
###############################################################################
|
###############################################################################
|
||||||
|
|
||||||
-braille-drivers: txt2hlp
|
-braille-drivers: txt2hlp$X
|
||||||
+braille-drivers: txt2hlp api
|
+braille-drivers: txt2hlp$X api
|
||||||
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
||||||
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-all) || exit 1; \
|
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-all) || exit 1; \
|
||||||
done
|
done
|
||||||
|
39
brltty.spec
39
brltty.spec
@ -1,5 +1,5 @@
|
|||||||
%define pkg_version 3.10
|
%define pkg_version 4.0
|
||||||
%define api_version 0.5.2
|
%define api_version 0.5.3
|
||||||
|
|
||||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
|
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
|
||||||
@ -9,13 +9,11 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
||||||
Patch2: brltty-gnusource.patch
|
|
||||||
Patch3: brltty-3.9-autoconf.patch
|
|
||||||
Patch4: brltty-cppflags.patch
|
Patch4: brltty-cppflags.patch
|
||||||
Patch5: brltty-parallel.patch
|
Patch5: brltty-parallel.patch
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
@ -44,7 +42,8 @@ This package provides the XWindow driver for BRLTTY.
|
|||||||
Requires: %{name}
|
Requires: %{name}
|
||||||
Summary: AtSpi driver for BRLTTY
|
Summary: AtSpi driver for BRLTTY
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2+
|
# The data files are licensed under LGPLv2+, see the README file.
|
||||||
|
License: GPLv2+ and LGPLv2+
|
||||||
BuildRequires: at-spi-devel
|
BuildRequires: at-spi-devel
|
||||||
%description at-spi
|
%description at-spi
|
||||||
This package provides the AtSpi driver for BRLTTY.
|
This package provides the AtSpi driver for BRLTTY.
|
||||||
@ -116,22 +115,18 @@ This package provides the Java binding for BrlAPI.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .gnusource
|
|
||||||
%patch3 -p1 -b .autoconf
|
|
||||||
%patch4 -p1 -b .cppflags
|
%patch4 -p1 -b .cppflags
|
||||||
%patch5 -p1 -b .parallel
|
%patch5 -p1 -b .parallel
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen
|
|
||||||
for i in -I/usr/lib/jvm/java/include{,/linux}; do
|
for i in -I/usr/lib/jvm/java/include{,/linux}; do
|
||||||
java_inc="$java_inc $i"
|
java_inc="$java_inc $i"
|
||||||
done
|
done
|
||||||
# there is no curses packages in BuildRequires, so the package builds
|
# there is no curses packages in BuildRequires, so the package builds
|
||||||
# without them in mock; let's express this decision explicitly
|
# without them in mock; let's express this decision explicitly
|
||||||
%configure CPPFLAGS="$java_inc" --without-curses \
|
%configure CPPFLAGS="$java_inc" --without-curses \
|
||||||
|
--with-data-directory='${datadir}/${PACKAGE_NAME}' \
|
||||||
--with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
--with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
||||||
cat config.log
|
|
||||||
#exit 1
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
for file in $(find . \( -path ./doc -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o -name \*.patch -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print)
|
for file in $(find . \( -path ./doc -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o -name \*.patch -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print)
|
||||||
@ -143,8 +138,9 @@ done
|
|||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make INSTALL_PROGRAM='$(INSTALL_SCRIPT)' install #install-programs install-help install-tables install-drivers install-manpage
|
make INSTALL_PROGRAM='$(INSTALL_SCRIPT)' install #install-programs install-help install-tables install-drivers install-manpage
|
||||||
|
install -d -m 755 "${RPM_BUILD_ROOT}%{_sysconfdir}" "$RPM_BUILD_ROOT%{_mandir}/man5"
|
||||||
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
|
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
|
||||||
rm -f ${RPM_BUILD_ROOT}/usr/bin/xbrlapi # whatever this is, we exclude it for now
|
echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
|
||||||
|
|
||||||
ls ${RPM_BUILD_ROOT}/%{_libdir}/brltty/*.so | \
|
ls ${RPM_BUILD_ROOT}/%{_libdir}/brltty/*.so | \
|
||||||
grep -v 'libbrlttybxw.so\|libbrlttyxas.so' | \
|
grep -v 'libbrlttybxw.so\|libbrlttyxas.so' | \
|
||||||
@ -181,12 +177,14 @@ exit 0
|
|||||||
%{_bindir}/brltty-*
|
%{_bindir}/brltty-*
|
||||||
%{_bindir}/vstp
|
%{_bindir}/vstp
|
||||||
%dir %{_libdir}/brltty
|
%dir %{_libdir}/brltty
|
||||||
/etc/brltty
|
%{_datadir}/brltty
|
||||||
%doc COPYING
|
%doc LICENSE-GPL LICENSE-LGPL
|
||||||
%doc Documents/ChangeLog Documents/TODO
|
%doc Documents/ChangeLog Documents/TODO
|
||||||
|
%doc Documents/Manual-BRLTTY
|
||||||
%doc Bootdisks/rhmkboot Bootdisks/rhmkroot
|
%doc Bootdisks/rhmkboot Bootdisks/rhmkroot
|
||||||
%doc doc/*
|
%doc doc/*
|
||||||
%doc /usr/share/man/man1/*
|
%doc %{_mandir}/man[15]/brltty.*
|
||||||
|
%doc %{_mandir}/man1/vstp.*
|
||||||
|
|
||||||
%files xw
|
%files xw
|
||||||
%{_libdir}/brltty/libbrlttybxw.so
|
%{_libdir}/brltty/libbrlttybxw.so
|
||||||
@ -196,10 +194,12 @@ exit 0
|
|||||||
|
|
||||||
%files -n brlapi
|
%files -n brlapi
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/xbrlapi
|
||||||
%{_libdir}/libbrlapi.so.*
|
%{_libdir}/libbrlapi.so.*
|
||||||
%doc Documents/Manual-BrlAPI/English/BrlAPI.sgml Documents/Manual-BrlAPI/English/BrlAPI.txt
|
%doc Documents/Manual-BrlAPI/English/BrlAPI.sgml Documents/Manual-BrlAPI/English/BrlAPI.txt
|
||||||
%doc Documents/Manual-BrlAPI/English/BrlAPI*.html
|
%doc Documents/Manual-BrlAPI/English/BrlAPI*.html
|
||||||
%doc Documents/README.Gnopernicus
|
%doc Documents/README.Seika
|
||||||
|
%doc %{_mandir}/man1/xbrlapi.*
|
||||||
|
|
||||||
%files -n brlapi-devel
|
%files -n brlapi-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -207,7 +207,7 @@ exit 0
|
|||||||
%{_libdir}/libbrlapi.so
|
%{_libdir}/libbrlapi.so
|
||||||
%{_includedir}/brltty
|
%{_includedir}/brltty
|
||||||
%{_includedir}/brlapi*.h
|
%{_includedir}/brlapi*.h
|
||||||
%doc %{_mandir}/man3/*
|
%doc %{_mandir}/man3/brlapi_*.3*
|
||||||
%doc Documents/BrlAPIref/html
|
%doc Documents/BrlAPIref/html
|
||||||
|
|
||||||
%files -n tcl-brlapi
|
%files -n tcl-brlapi
|
||||||
@ -226,6 +226,11 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 4.0-1
|
||||||
|
- new upstream version
|
||||||
|
- drop upstreamed patches; ./autogen nut needed anymore
|
||||||
|
- pack the xbrlapi server; move its man page to brlapi package
|
||||||
|
|
||||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user