update to 4.2, drop static lib

This commit is contained in:
Tom Callaway 2010-05-21 13:17:15 +00:00
parent 110bba7c69
commit 1015788bf6
4 changed files with 30 additions and 15 deletions

View File

@ -1 +1 @@
brltty-4.1.tar.gz brltty-4.2.tar.gz

11
brltty-4.2-S_ISCHR.patch Normal file
View File

@ -0,0 +1,11 @@
diff -up brltty-4.2/Programs/sys_linux.c.BAD brltty-4.2/Programs/sys_linux.c
--- brltty-4.2/Programs/sys_linux.c.BAD 2010-05-21 09:04:10.003122084 -0400
+++ brltty-4.2/Programs/sys_linux.c 2010-05-21 09:04:19.376198268 -0400
@@ -23,6 +23,7 @@
#include <errno.h>
#include <fcntl.h>
#include <sys/ioctl.h>
+#include <sys/stat.h>
#include <linux/kd.h>
#ifdef HAVE_LINUX_INPUT_H

View File

@ -1,5 +1,5 @@
%define pkg_version 4.1 %define pkg_version 4.2
%define api_version 0.5.4 %define api_version 0.5.5
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")} %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")} %{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
@ -15,14 +15,14 @@
Name: brltty Name: brltty
Version: %{pkg_version} Version: %{pkg_version}
Release: 5%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Daemons Group: System Environment/Daemons
URL: http://mielke.cc/brltty/ URL: http://mielke.cc/brltty/
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
Patch4: brltty-cppflags.patch Patch0: brltty-cppflags.patch
Patch5: brltty-parallel.patch Patch1: brltty-autoconf-quote.patch
Patch6: brltty-autoconf-quote.patch Patch2: brltty-4.2-S_ISCHR.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX) BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
Summary: Braille display driver for Linux/Unix Summary: Braille display driver for Linux/Unix
BuildRequires: byacc glibc-kernheaders BuildRequires: byacc glibc-kernheaders
@ -137,9 +137,9 @@ This package provides the Java binding for BrlAPI.
%prep %prep
%setup -q %setup -q
%patch4 -p1 -b .cppflags %patch0 -p1 -b .cppflags
%patch5 -p1 -b .parallel %patch1 -p1 -b .quote
%patch6 -p1 -b .quote %patch2 -p1 -b .S_ISCHR
%build %build
# Patch6 changes aclocal.m4: # Patch6 changes aclocal.m4:
@ -168,11 +168,8 @@ done
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
# does not seem to be parallel safe # does not seem to be parallel safe
make install make install
mv "$RPM_BUILD_ROOT%{_libdir}/libbrlapi.a" "$RPM_BUILD_ROOT%{_prefix}/%{_lib}/"
rm "$RPM_BUILD_ROOT%{_libdir}/libbrlapi.so" rm "$RPM_BUILD_ROOT%{_libdir}/libbrlapi.so"
ln -s ../../%{_lib}/libbrlapi.so "$RPM_BUILD_ROOT%{_prefix}/%{_lib}/" ln -s ../../%{_lib}/libbrlapi.so "$RPM_BUILD_ROOT%{_prefix}/%{_lib}/"
mv "$RPM_BUILD_ROOT%{_sysconfdir}/brltty/brltty-pm.conf" \
doc/Drivers/Braille/Papenmeier/
install -d -m 755 "${RPM_BUILD_ROOT}%{_sysconfdir}" "$RPM_BUILD_ROOT%{_mandir}/man5" install -d -m 755 "${RPM_BUILD_ROOT}%{_sysconfdir}" "$RPM_BUILD_ROOT%{_mandir}/man5"
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}" install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5 echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
@ -181,6 +178,9 @@ echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
rm Documents/Manual-*/*/{*.mk,*.made,Makefile*} rm Documents/Manual-*/*/{*.mk,*.made,Makefile*}
mv Documents/BrlAPIref/{html,BrlAPIref} mv Documents/BrlAPIref/{html,BrlAPIref}
# Don't want static lib
rm -rf $RPM_BUILD_ROOT/%{_lib}/libbrlapi.a
%clean %clean
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -253,7 +253,6 @@ exit 0
%files -n brlapi-devel %files -n brlapi-devel
%defattr(-,root,root) %defattr(-,root,root)
%{_prefix}/%{_lib}/libbrlapi.a
%{_prefix}/%{_lib}/libbrlapi.so %{_prefix}/%{_lib}/libbrlapi.so
%{_includedir}/brltty %{_includedir}/brltty
%{_includedir}/brlapi*.h %{_includedir}/brlapi*.h
@ -276,6 +275,11 @@ exit 0
%changelog %changelog
* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-1
- update to 4.2
- drop static lib (bz 556041)
- fix undefined S_ISCHR call
* Wed Jan 20 2010 Stepan Kasal <skasal@redhat.com> - 4.1-5 * Wed Jan 20 2010 Stepan Kasal <skasal@redhat.com> - 4.1-5
- requires(post): coreutils to work around an installator bug - requires(post): coreutils to work around an installator bug
- Resolves: #540437 - Resolves: #540437

View File

@ -1 +1 @@
b3b492240ba33fd3af45a181f5b89e7a brltty-4.1.tar.gz 192af5e634210616928496645e392097 brltty-4.2.tar.gz