6.1
This commit is contained in:
parent
2d1c7a6155
commit
0ffa6042f8
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ brltty-4.2.tar.gz
|
||||
/brltty-5.5.tar.xz
|
||||
/brltty-5.6.tar.xz
|
||||
/brltty-6.0.tar.xz
|
||||
/brltty-6.1.tar.xz
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff --git a/Programs/midi_alsa.c b/Programs/midi_alsa.c
|
||||
index 10a6afc..c52ee30 100644
|
||||
--- a/Programs/midi_alsa.c
|
||||
+++ b/Programs/midi_alsa.c
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
#include "prologue.h"
|
||||
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#include "log.h"
|
||||
#include "parse.h"
|
||||
diff --git a/Programs/pcm_alsa.c b/Programs/pcm_alsa.c
|
||||
index e04b1ea..82e12f1 100644
|
||||
--- a/Programs/pcm_alsa.c
|
||||
+++ b/Programs/pcm_alsa.c
|
||||
@@ -19,7 +19,7 @@
|
||||
#include "prologue.h"
|
||||
|
||||
#define ALSA_PCM_NEW_HW_PARAMS_API
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#include "log.h"
|
||||
#include "timing.h"
|
15
brltty.spec
15
brltty.spec
@ -1,5 +1,5 @@
|
||||
%define pkg_version 6.0
|
||||
%define api_version 0.7.0
|
||||
%define pkg_version 6.1
|
||||
%define api_version 0.8.0
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
# disable python3 by default
|
||||
@ -33,7 +33,7 @@
|
||||
|
||||
Name: brltty
|
||||
Version: %{pkg_version}
|
||||
Release: 14%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: http://brltty.app/
|
||||
Source0: http://brltty.app/archive/%{name}-%{version}.tar.xz
|
||||
@ -41,7 +41,6 @@ Source1: brltty.service
|
||||
Patch1: brltty-6.0-loadLibrary.patch
|
||||
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
||||
Patch2: brltty-5.0-libspeechd.patch
|
||||
Patch3: brltty-6.0-alsa-1.1.9-fix.patch
|
||||
Summary: Braille display driver for Linux/Unix
|
||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||
BuildRequires: gettext, at-spi2-core-devel, alsa-lib-devel
|
||||
@ -50,7 +49,7 @@ BuildRequires: espeak-devel
|
||||
%endif
|
||||
BuildRequires: espeak-ng-devel
|
||||
BuildRequires: /usr/bin/2to3
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: autoconf automake
|
||||
|
||||
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||
# work around a bug in the install process:
|
||||
@ -230,7 +229,6 @@ mv %{name}-%{version} python2
|
||||
pushd python2
|
||||
%patch1 -p1 -b .loadLibrary
|
||||
%patch2 -p1 -b .libspeechd
|
||||
%patch3 -p1 -b .alsa-1.1.9-fix
|
||||
|
||||
# remove packaged binary file
|
||||
rm -f Programs/brltty-ktb
|
||||
@ -445,7 +443,7 @@ fi
|
||||
%endif
|
||||
%license LICENSE-LGPL
|
||||
%doc %{_mandir}/man[15]/brltty.*
|
||||
%{_sysconfdir}/X11/Xsession.d/60xbrlapi
|
||||
%{_sysconfdir}/X11/Xsession.d/90xbrlapi
|
||||
#%%{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
|
||||
%{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
|
||||
|
||||
@ -528,6 +526,9 @@ fi
|
||||
%config(noreplace) %verify(not size md5 mtime) %{_sysconfdir}/brltty/Initramfs/cmdline
|
||||
|
||||
%changelog
|
||||
* Mon Apr 06 2020 Gwyn Ciesla <gwync@protonmail.com> - 6.1-1
|
||||
- 6.1
|
||||
|
||||
* Thu Apr 02 2020 Richard W.M. Jones <rjones@redhat.com> - 6.0-14
|
||||
- Update all OCaml dependencies for RPM 4.16.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (brltty-6.0.tar.xz) = 07344fa902ad169967ca39d19b09dfea24e698011031dd63dce3eb997a4cb86622ee9427b216976b3ef60e5cbabb710a621621447c6bfa2313748fc1a1cf4b06
|
||||
SHA512 (brltty-6.1.tar.xz) = 030ef60ef7a9a60dc2fba2a64ea0a0868395eee6f2f86876b4e4111e804a05b44f798a154a69a8f5e0f6358130993c360a550f7decac0535450f9cf939231eaf
|
||||
|
Loading…
Reference in New Issue
Block a user