Don't pass unnecessary -Wno-format to Python bindings
Fixes FTBFS on gcc7
This commit is contained in:
parent
14512078b8
commit
0b88ce91e4
11
brltty-format-security.patch
Normal file
11
brltty-format-security.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- configure.orig 2017-03-17 10:38:18.549098316 -0400
|
||||||
|
+++ configure 2017-03-17 10:38:26.499963667 -0400
|
||||||
|
@@ -8673,7 +8673,7 @@
|
||||||
|
|
||||||
|
if test "${GCC}" = "yes"
|
||||||
|
then
|
||||||
|
- CYTHON_CFLAGS="-Wno-parentheses -Wno-unused -Wno-format -fno-strict-aliasing -U_POSIX_C_SOURCE -U_XOPEN_SOURCE"
|
||||||
|
+ CYTHON_CFLAGS="-Wno-parentheses -Wno-unused -fno-strict-aliasing -U_POSIX_C_SOURCE -U_XOPEN_SOURCE"
|
||||||
|
else
|
||||||
|
case "${host_os}"
|
||||||
|
in
|
10
brltty.spec
10
brltty.spec
@ -22,7 +22,7 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
@ -33,6 +33,9 @@ Patch1: brltty-loadLibrary.patch
|
|||||||
Patch2: brltty-5.0-libspeechd.patch
|
Patch2: brltty-5.0-libspeechd.patch
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1392147
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1392147
|
||||||
Patch3: brltty-ocaml-4-04-fix.patch
|
Patch3: brltty-ocaml-4-04-fix.patch
|
||||||
|
# Don't pass unnecessary -Wno-format
|
||||||
|
# Submitted to upstream: https://github.com/brltty/brltty/pull/91
|
||||||
|
Patch4: brltty-format-security.patch
|
||||||
Summary: Braille display driver for Linux/Unix
|
Summary: Braille display driver for Linux/Unix
|
||||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||||
BuildRequires: gettext, at-spi2-core-devel, espeak-devel
|
BuildRequires: gettext, at-spi2-core-devel, espeak-devel
|
||||||
@ -200,6 +203,7 @@ This package provides the OCaml binding for BrlAPI.
|
|||||||
%patch1 -p1 -b .loadLibrary
|
%patch1 -p1 -b .loadLibrary
|
||||||
%patch2 -p1 -b .libspeechd
|
%patch2 -p1 -b .libspeechd
|
||||||
%patch3 -p1 -b .ocaml-4-04
|
%patch3 -p1 -b .ocaml-4-04
|
||||||
|
%patch4 -p0 -b .format-sec
|
||||||
|
|
||||||
# remove packaged binary file
|
# remove packaged binary file
|
||||||
rm -f Programs/brltty-ktb
|
rm -f Programs/brltty-ktb
|
||||||
@ -420,6 +424,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 17 2017 Stephen Gallagher <sgallagh@redhat.com> - 5.4-8
|
||||||
|
- Don't pass unnecessary -Wno-format to Python bindings
|
||||||
|
- Fixes FTBFS on gcc7
|
||||||
|
|
||||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.4-7
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.4-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user