6.4
This commit is contained in:
parent
fd37f4ef2a
commit
0b21674243
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ brltty-4.2.tar.gz
|
|||||||
/brltty-6.0.tar.xz
|
/brltty-6.0.tar.xz
|
||||||
/brltty-6.1.tar.xz
|
/brltty-6.1.tar.xz
|
||||||
/brltty-6.3.tar.xz
|
/brltty-6.3.tar.xz
|
||||||
|
/brltty-6.4.tar.xz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 09b9701a17618939fa0746ff532449f933213a68 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
|
||||||
Date: Thu, 15 Apr 2021 11:32:15 +0200
|
|
||||||
Subject: [PATCH] Python modules check: Assert exit code, not empty output
|
|
||||||
|
|
||||||
Distutils is deprecated in Python 3.10+:
|
|
||||||
https://www.python.org/dev/peps/pep-0632/
|
|
||||||
|
|
||||||
When importing it, there is a warning:
|
|
||||||
|
|
||||||
DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
|
|
||||||
|
|
||||||
The configure script falsely assumed this is an error.
|
|
||||||
Instead, we now check for the exit code, which is more explicit.
|
|
||||||
|
|
||||||
In the long term, we need to migrate away from distutils, this is a stopgap measure only.
|
|
||||||
---
|
|
||||||
Bindings/Python/bindings.m4 | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Bindings/Python/bindings.m4 b/Bindings/Python/bindings.m4
|
|
||||||
index 784418f0c..ee28525fc 100644
|
|
||||||
--- a/Bindings/Python/bindings.m4
|
|
||||||
+++ b/Bindings/Python/bindings.m4
|
|
||||||
@@ -40,7 +40,7 @@ else
|
|
||||||
for python_module in sys distutils.sysconfig
|
|
||||||
do
|
|
||||||
python_error="`"${PYTHON}" -c "import ${python_module};" 2>&1`"
|
|
||||||
- if test -n "${python_error}"
|
|
||||||
+ if test $? -ne 0
|
|
||||||
then
|
|
||||||
AC_MSG_WARN([Python module not found: ${python_module}: ${python_error}])
|
|
||||||
PYTHON_OK=false
|
|
11
brltty.spec
11
brltty.spec
@ -1,5 +1,5 @@
|
|||||||
%define pkg_version 6.3
|
%define pkg_version 6.4
|
||||||
%define api_version 0.8.2
|
%define api_version 0.8.3
|
||||||
|
|
||||||
# minimal means brltty-minimal subpackage with minimal deps for
|
# minimal means brltty-minimal subpackage with minimal deps for
|
||||||
# braille support in Anaconda installer
|
# braille support in Anaconda installer
|
||||||
@ -38,7 +38,7 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://brltty.app/
|
URL: http://brltty.app/
|
||||||
Source0: http://brltty.app/archive/%{name}-%{version}.tar.xz
|
Source0: http://brltty.app/archive/%{name}-%{version}.tar.xz
|
||||||
@ -48,7 +48,6 @@ Source3: brlapi-forbuild.h
|
|||||||
Patch1: brltty-6.3-loadLibrary.patch
|
Patch1: brltty-6.3-loadLibrary.patch
|
||||||
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
||||||
Patch2: brltty-6.3-libspeechd.patch
|
Patch2: brltty-6.3-libspeechd.patch
|
||||||
Patch3: 09b9701a17618939fa0746ff532449f933213a68.patch
|
|
||||||
Summary: Braille display driver for Linux/Unix
|
Summary: Braille display driver for Linux/Unix
|
||||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||||
BuildRequires: gettext, at-spi2-core-devel, alsa-lib-devel
|
BuildRequires: gettext, at-spi2-core-devel, alsa-lib-devel
|
||||||
@ -256,7 +255,6 @@ mv %{name}-%{version} python2
|
|||||||
pushd python2
|
pushd python2
|
||||||
%patch1 -p1 -b .loadLibrary
|
%patch1 -p1 -b .loadLibrary
|
||||||
%patch2 -p1 -b .libspeechd
|
%patch2 -p1 -b .libspeechd
|
||||||
%patch3 -p1 -b .py10
|
|
||||||
|
|
||||||
# remove packaged binary file
|
# remove packaged binary file
|
||||||
rm -f Programs/brltty-ktb
|
rm -f Programs/brltty-ktb
|
||||||
@ -646,6 +644,9 @@ fi
|
|||||||
%config(noreplace) %verify(not size md5 mtime) %{_sysconfdir}/brltty/Initramfs/cmdline
|
%config(noreplace) %verify(not size md5 mtime) %{_sysconfdir}/brltty/Initramfs/cmdline
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 24 2021 Gwyn Ciesla <gwync@protonmail.com> - 6.4-1
|
||||||
|
- 6.4
|
||||||
|
|
||||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 6.3-10
|
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 6.3-10
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (brltty-6.3.tar.xz) = 8a15ffcc433f97925252d2355841e50a55179072d4cf294488fe52038b5e053ba688b7745716c49f4a20e0a626ecaf4ecd3ae7ca79527747c84c6e8a4d8d84a1
|
SHA512 (brltty-6.4.tar.xz) = 384848d05f78732952079d6f5170046927fcb35f400ece71ca897415a793c0aa1047934f8cd5e9e781536fb0b7cb71273283f3bba21e59f082ba8f6f2416352e
|
||||||
|
Loading…
Reference in New Issue
Block a user