Update to 3.11.4
This commit is contained in:
parent
32388feef7
commit
a893a073fc
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@ brasero-2.31.5.tar.bz2
|
|||||||
/brasero-3.10.0.tar.xz
|
/brasero-3.10.0.tar.xz
|
||||||
/brasero-3.11.0.tar.xz
|
/brasero-3.11.0.tar.xz
|
||||||
/brasero-3.11.3.tar.xz
|
/brasero-3.11.3.tar.xz
|
||||||
|
/brasero-3.11.4.tar.xz
|
||||||
|
@ -1,52 +0,0 @@
|
|||||||
From 4ef90701cfbc1dfdef71299d495339185d1b910a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christophe Fergeau <cfergeau@redhat.com>
|
|
||||||
Date: Mon, 18 Aug 2014 19:14:17 +0200
|
|
||||||
Subject: [PATCH] Chain up to parent constructor in 'constructed' vfuncs
|
|
||||||
|
|
||||||
Since gtk+ commit
|
|
||||||
commit 9c37b3de7466a22d4c784657a86c522e2a4f118a
|
|
||||||
Author: Jasper St. Pierre <jstpierre@mecheye.net>
|
|
||||||
Date: Thu Jun 26 18:22:42 2014 -0400
|
|
||||||
|
|
||||||
gtk: Don't use GObjectClass.constructor
|
|
||||||
|
|
||||||
Use the newer constructed instead, which has a fast path in GObject.
|
|
||||||
|
|
||||||
brasero crashes at startup. This is caused by some 'constructed'
|
|
||||||
implementations which don't' chain up to the parent class.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=732692
|
|
||||||
---
|
|
||||||
libbrasero-burn/brasero-tool-dialog.c | 2 ++
|
|
||||||
libbrasero-media/brasero-medium-selection.c | 2 ++
|
|
||||||
2 files changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/libbrasero-burn/brasero-tool-dialog.c b/libbrasero-burn/brasero-tool-dialog.c
|
|
||||||
index df5dccf..b0019b5 100644
|
|
||||||
--- a/libbrasero-burn/brasero-tool-dialog.c
|
|
||||||
+++ b/libbrasero-burn/brasero-tool-dialog.c
|
|
||||||
@@ -510,6 +510,8 @@ brasero_tool_dialog_constructed (GObject *object)
|
|
||||||
{
|
|
||||||
BraseroToolDialogPrivate *priv;
|
|
||||||
|
|
||||||
+ G_OBJECT_CLASS (brasero_tool_dialog_parent_class)->constructed (object);
|
|
||||||
+
|
|
||||||
priv = BRASERO_TOOL_DIALOG_PRIVATE (object);
|
|
||||||
|
|
||||||
brasero_medium_selection_show_media_type (BRASERO_MEDIUM_SELECTION (priv->selector),
|
|
||||||
diff --git a/libbrasero-media/brasero-medium-selection.c b/libbrasero-media/brasero-medium-selection.c
|
|
||||||
index 858b1d1..47dc75f 100644
|
|
||||||
--- a/libbrasero-media/brasero-medium-selection.c
|
|
||||||
+++ b/libbrasero-media/brasero-medium-selection.c
|
|
||||||
@@ -823,6 +823,8 @@ brasero_medium_selection_medium_removed_cb (BraseroMediumMonitor *monitor,
|
|
||||||
static void
|
|
||||||
brasero_medium_selection_constructed (GObject *object)
|
|
||||||
{
|
|
||||||
+ G_OBJECT_CLASS (brasero_medium_selection_parent_class)->constructed (object);
|
|
||||||
+
|
|
||||||
brasero_medium_selection_set_show_used_space (BRASERO_MEDIUM_SELECTION (object));
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,17 +0,0 @@
|
|||||||
--- brasero/configure.tracker_10 2014-02-19 10:39:34.190886512 +0100
|
|
||||||
+++ brasero/configure 2014-02-19 10:39:51.140505861 +0100
|
|
||||||
@@ -16711,6 +16711,14 @@
|
|
||||||
test $ac_status = 0; }; then
|
|
||||||
tracker_api="0.18"
|
|
||||||
fi
|
|
||||||
+ if test -n "$PKG_CONFIG" && \
|
|
||||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"tracker-sparql-1.0 >= \$TRACKER_REQUIRED\""; } >&5
|
|
||||||
+ ($PKG_CONFIG --exists --print-errors "tracker-sparql-1.0 >= $TRACKER_REQUIRED") 2>&5
|
|
||||||
+ ac_status=$?
|
|
||||||
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
||||||
+ test $ac_status = 0; }; then
|
|
||||||
+ tracker_api="1.0"
|
|
||||||
+fi
|
|
||||||
|
|
||||||
fi
|
|
||||||
|
|
13
brasero.spec
13
brasero.spec
@ -1,6 +1,6 @@
|
|||||||
Name: brasero
|
Name: brasero
|
||||||
Version: 3.11.3
|
Version: 3.11.4
|
||||||
Release: 11%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Gnome CD/DVD burning application
|
Summary: Gnome CD/DVD burning application
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
# see https://bugzilla.gnome.org/show_bug.cgi?id=683503
|
# see https://bugzilla.gnome.org/show_bug.cgi?id=683503
|
||||||
@ -8,10 +8,6 @@ License: GPLv3+
|
|||||||
URL: http://www.gnome.org/projects/brasero/
|
URL: http://www.gnome.org/projects/brasero/
|
||||||
#VCS: git:git://git.gnome.org/brasero
|
#VCS: git:git://git.gnome.org/brasero
|
||||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/brasero/3.11/%{name}-%{version}.tar.xz
|
Source0: http://ftp.gnome.org/pub/GNOME/sources/brasero/3.11/%{name}-%{version}.tar.xz
|
||||||
# Support tracker 1.0 API, backported from upstream
|
|
||||||
Patch0: brasero-tracker-1.0.patch
|
|
||||||
# Fix crashes with gtk+ 3.13.x, patch backported from upstream
|
|
||||||
Patch1: 0001-Chain-up-to-parent-constructor-in-constructed-vfuncs.patch
|
|
||||||
|
|
||||||
BuildRequires: gtk3-devel >= 2.99.0
|
BuildRequires: gtk3-devel >= 2.99.0
|
||||||
BuildRequires: glib2-devel >= 2.15.6
|
BuildRequires: glib2-devel >= 2.15.6
|
||||||
@ -93,8 +89,6 @@ developing brasero applications.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .tracker_10
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -198,6 +192,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.11.4-1
|
||||||
|
- Update to 3.11.4
|
||||||
|
|
||||||
* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 3.11.3-11
|
* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 3.11.3-11
|
||||||
- Backport a patch to fix crashes with gtk+ 3.13.x
|
- Backport a patch to fix crashes with gtk+ 3.13.x
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user