From 4ef87c1a182784bc56204578f35e37beaeeed976 Mon Sep 17 00:00:00 2001
From: Denis Leroy <denis@fedoraproject.org>
Date: Fri, 17 Aug 2007 07:23:37 +0000
Subject: [PATCH] Updated License tag, better open() fix

---
 brasero-0.6.0-open.patch | 7 ++++---
 brasero.spec             | 8 ++++++--
 2 files changed, 10 insertions(+), 5 deletions(-)

diff --git a/brasero-0.6.0-open.patch b/brasero-0.6.0-open.patch
index 25824b3..3648119 100644
--- a/brasero-0.6.0-open.patch
+++ b/brasero-0.6.0-open.patch
@@ -1,11 +1,12 @@
 --- brasero-0.6.0/src/burn-transcode.c~	2007-07-11 14:48:14.000000000 +0200
-+++ brasero-0.6.0/src/burn-transcode.c	2007-08-11 20:47:36.000000000 +0200
-@@ -1402,7 +1402,7 @@
++++ brasero-0.6.0/src/burn-transcode.c	2007-08-17 09:17:31.000000000 +0200
+@@ -1402,7 +1402,8 @@
  	int fd;
  	gboolean result;
  
 -	fd = open (transcode->priv->current->dest, O_WRONLY | O_CREAT | O_APPEND);
-+	fd = (open)(transcode->priv->current->dest, O_WRONLY | O_CREAT | O_APPEND);
++	fd = open (transcode->priv->current->dest, O_WRONLY | O_CREAT | O_APPEND,
++		   S_IRWXU | S_IRGRP | S_IROTH);
  	if (fd == -1) {
  		g_set_error (error,
  			     BRASERO_BURN_ERROR,
diff --git a/brasero.spec b/brasero.spec
index 5a2200f..7f4bf18 100644
--- a/brasero.spec
+++ b/brasero.spec
@@ -1,10 +1,10 @@
 
 Name:      brasero
 Version:   0.6.0
-Release:   1%{?dist}
+Release:   2%{?dist}
 Summary:   Gnome CD/DVD burning application
 Group:     Applications/Multimedia
-License:   GPL
+License:   GPLv2+
 URL:       http://www.gnome.org/projects/brasero/
 Source0:   http://ftp.gnome.org/pub/GNOME/sources/brasero/0.6/%{name}-%{version}.tar.bz2
 Patch0:    brasero-0.6.0-tooltips.patch
@@ -124,6 +124,10 @@ fi
 
 
 %changelog
+* Fri Aug 17 2007 Denis Leroy <denis@poolshark.org> - 0.6.0-2
+- Updated License tag
+- Fixed open() O_CREAT problem
+
 * Fri Aug 10 2007 Denis Leroy <denis@poolshark.org> - 0.6.0-1
 - Update to 0.6.0
 - Removed libburn support until it compiles against libisofs 0.2.8