- Update to 0.6.0
- Removed libburn support until it compiles against libisofs 0.2.8 - Fixed project URL
This commit is contained in:
parent
12f62e0b31
commit
4435139c01
@ -1 +1 @@
|
||||
brasero-0.5.2.tar.bz2
|
||||
brasero-0.6.0.tar.bz2
|
||||
|
@ -1,68 +0,0 @@
|
||||
--- brasero-0.5.1/src/burn-libisofs.c~ 2006-11-13 20:51:32.000000000 +0100
|
||||
+++ brasero-0.5.1/src/burn-libisofs.c 2007-01-17 01:00:02.000000000 +0100
|
||||
@@ -46,7 +46,7 @@
|
||||
|
||||
#ifdef HAVE_LIBBURN
|
||||
|
||||
-#include <libburn/libisofs.h>
|
||||
+#include <libisofs/libisofs.h>
|
||||
#include <libburn/libburn.h>
|
||||
|
||||
static void brasero_libisofs_class_init (BraseroLibisofsClass *klass);
|
||||
--- brasero-0.5.1/src/burn-libburn-common.c~ 2006-09-16 10:06:14.000000000 +0200
|
||||
+++ brasero-0.5.1/src/burn-libburn-common.c 2007-01-17 01:07:11.000000000 +0100
|
||||
@@ -247,38 +247,6 @@
|
||||
return BRASERO_BURN_OK;
|
||||
}
|
||||
|
||||
-static gboolean
|
||||
-brasero_libburn_common_process_message (BraseroLibburnCommon *self,
|
||||
- struct burn_message *mes)
|
||||
-{
|
||||
- GError *error;
|
||||
- gboolean retval = TRUE;
|
||||
-
|
||||
- switch (mes->type) {
|
||||
- case BURN_MESSAGE_ERROR:
|
||||
- if (mes->detail.error.message == BURN_ERROR_CANCELLED) {
|
||||
- retval = TRUE;
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
- case BURN_MESSAGE_WARNING:
|
||||
- error = g_error_new (BRASERO_BURN_ERROR,
|
||||
- BRASERO_BURN_ERROR_GENERAL,
|
||||
- _("an unknown error occured with libburn"));
|
||||
- brasero_job_error (BRASERO_JOB (self), error);
|
||||
- retval = FALSE;
|
||||
- break;
|
||||
-
|
||||
- case BURN_MESSAGE_INFO:
|
||||
- BRASERO_JOB_LOG (self, _("(%s) libburn tried to say something"));
|
||||
- retval = TRUE;
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
- burn_message_free (mes);
|
||||
- return retval;
|
||||
-}
|
||||
-
|
||||
static void
|
||||
brasero_libburn_common_status_changed (BraseroLibburnCommon *self,
|
||||
enum burn_drive_status status,
|
||||
@@ -381,15 +349,9 @@
|
||||
gdouble fraction;
|
||||
gint64 sectors;
|
||||
|
||||
- struct burn_message *message;
|
||||
enum burn_drive_status status;
|
||||
struct burn_progress progress;
|
||||
|
||||
- /* see if there is any pending message */
|
||||
- message = burn_get_message ();
|
||||
- if (message && !brasero_libburn_common_process_message (self, message))
|
||||
- return;
|
||||
-
|
||||
if (!self->priv->drive)
|
||||
return;
|
||||
|
25
brasero.spec
25
brasero.spec
@ -1,12 +1,12 @@
|
||||
|
||||
Name: brasero
|
||||
Version: 0.5.2
|
||||
Release: 4%{?dist}
|
||||
Version: 0.6.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Gnome CD/DVD burning application
|
||||
Group: Applications/Multimedia
|
||||
License: GPL
|
||||
URL: http://perso.orange.fr/bonfire/
|
||||
Source0: http://download.sourceforge.net/bonfire/%{name}-%{version}.tar.bz2
|
||||
URL: http://www.gnome.org/projects/brasero/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/brasero/0.6/%{name}-%{version}.tar.bz2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: gettext intltool
|
||||
@ -19,8 +19,7 @@ BuildRequires: nautilus-cd-burner-devel >= 2.16.0
|
||||
BuildRequires: libbeagle-devel >= 0.1.1
|
||||
%endif
|
||||
BuildRequires: totem-devel >= 1.2.0
|
||||
BuildRequires: libburn-devel >= 0.2.3
|
||||
BuildRequires: libisofs-devel >= 0.2.4
|
||||
BuildRequires: libnotify-devel >= 0.3.0
|
||||
|
||||
Requires: dvd+rw-tools
|
||||
Requires: cdrecord
|
||||
@ -45,7 +44,12 @@ desktop.
|
||||
|
||||
|
||||
%build
|
||||
%configure --disable-caches --disable-static --disable-schemas-install
|
||||
%configure \
|
||||
--disable-caches \
|
||||
--disable-static \
|
||||
--disable-schemas-install \
|
||||
--disable-libburn
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
@ -104,7 +108,7 @@ fi
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING ChangeLog NEWS README
|
||||
%doc %{_mandir}/man1/%{name}.*
|
||||
%{_mandir}/man1/%{name}.*
|
||||
%{_bindir}/*
|
||||
%{_datadir}/%{name}
|
||||
%{_datadir}/applications/brasero.desktop
|
||||
@ -114,6 +118,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Aug 10 2007 Denis Leroy <denis@poolshark.org> - 0.6.0-1
|
||||
- Update to 0.6.0
|
||||
- Removed libburn support until it compiles against libisofs 0.2.8
|
||||
- Fixed project URL
|
||||
|
||||
* Sun Jun 3 2007 Denis Leroy <denis@poolshark.org> - 0.5.2-4
|
||||
- Removed beagle support for ppc64
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user