- Update to upstream 2.25.90
- Split media library into separate RPM (#483754) - Added patch to validate desktop files
This commit is contained in:
parent
caecc99178
commit
3c11a36890
@ -1 +1 @@
|
||||
brasero-0.9.1.tar.bz2
|
||||
brasero-2.25.90.tar.bz2
|
||||
|
33
brasero-2.25.90-desktop.patch
Normal file
33
brasero-2.25.90-desktop.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- brasero-2.25.90/data/brasero-copy-medium.desktop.in.in~ 2009-02-01 05:50:47.000000000 -0800
|
||||
+++ brasero-2.25.90/data/brasero-copy-medium.desktop.in.in 2009-02-04 10:26:56.000000000 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
Terminal=false
|
||||
Type=Application
|
||||
NoDisplay=true
|
||||
-OnlyShowIn=GNOME
|
||||
+OnlyShowIn=GNOME;
|
||||
X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
X-GNOME-Bugzilla-Product=brasero
|
||||
X-GNOME-Bugzilla-Component=general
|
||||
--- brasero-2.25.90/data/brasero-open-playlist.desktop.in.in~ 2009-02-01 05:50:47.000000000 -0800
|
||||
+++ brasero-2.25.90/data/brasero-open-playlist.desktop.in.in 2009-02-04 10:27:07.000000000 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
Terminal=false
|
||||
Type=Application
|
||||
NoDisplay=true
|
||||
-OnlyShowIn=GNOME
|
||||
+OnlyShowIn=GNOME;
|
||||
X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
X-GNOME-Bugzilla-Product=brasero
|
||||
X-GNOME-Bugzilla-Component=general
|
||||
--- brasero-2.25.90/data/brasero-open-project.desktop.in.in~ 2009-02-01 05:50:47.000000000 -0800
|
||||
+++ brasero-2.25.90/data/brasero-open-project.desktop.in.in 2009-02-04 10:27:17.000000000 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
Terminal=false
|
||||
Type=Application
|
||||
NoDisplay=true
|
||||
-OnlyShowIn=GNOME
|
||||
+OnlyShowIn=GNOME;
|
||||
X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
X-GNOME-Bugzilla-Product=brasero
|
||||
X-GNOME-Bugzilla-Component=general
|
39
brasero.spec
39
brasero.spec
@ -1,12 +1,13 @@
|
||||
|
||||
Name: brasero
|
||||
Version: 0.9.1
|
||||
Version: 2.25.90
|
||||
Release: 1%{?dist}
|
||||
Summary: Gnome CD/DVD burning application
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org/projects/brasero/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/brasero/0.9/%{name}-%{version}.tar.bz2
|
||||
Patch0: brasero-2.25.90-desktop.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: glib2-devel >= 2.15.6
|
||||
@ -18,7 +19,7 @@ BuildRequires: libgnomeui-devel >= 2.10.0
|
||||
BuildRequires: gstreamer-devel >= 0.10.15
|
||||
BuildRequires: gstreamer-plugins-base-devel >= 0.10.0
|
||||
%ifnarch ppc64
|
||||
BuildRequires: libbeagle-devel >= 0.1.1
|
||||
BuildRequires: libbeagle-devel >= 0.3.0
|
||||
%endif
|
||||
BuildRequires: totem-pl-parser-devel >= 2.22.0
|
||||
BuildRequires: libnotify-devel >= 0.3.0
|
||||
@ -51,6 +52,16 @@ Simple and easy to use CD/DVD burning application for the Gnome
|
||||
desktop.
|
||||
|
||||
|
||||
%package libs
|
||||
Summary: Libraries for %{name}
|
||||
Group: System Environment/Libraries
|
||||
|
||||
|
||||
%description libs
|
||||
The %{name}-libs package contains the runtime shared libraries for
|
||||
%{brasero}.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Headers for developing programs that will use %{name}
|
||||
Group: Development/Libraries
|
||||
@ -65,12 +76,17 @@ developing brasero applications.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .desktop
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-nautilus \
|
||||
--enable-libburnia \
|
||||
--enable-search \
|
||||
--enable-playlist \
|
||||
--enable-preview \
|
||||
--enable-inotify \
|
||||
--disable-caches \
|
||||
--disable-static \
|
||||
--disable-schemas-install
|
||||
@ -98,7 +114,6 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
umask 022
|
||||
/sbin/ldconfig
|
||||
update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/hicolor || :
|
||||
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
@ -110,6 +125,9 @@ gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/%{name}.schemas
|
||||
killall -HUP gconfd-2 &>/dev/null || :
|
||||
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
|
||||
%postun
|
||||
umask 022
|
||||
update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
@ -123,7 +141,9 @@ if [ "$1" -gt 1 ]; then
|
||||
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
|
||||
killall -HUP gconfd-2 &>/dev/null || :
|
||||
fi
|
||||
/sbin/ldconfig
|
||||
|
||||
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
|
||||
%preun
|
||||
@ -139,7 +159,6 @@ fi
|
||||
%doc AUTHORS COPYING ChangeLog NEWS README
|
||||
%{_mandir}/man1/%{name}.*
|
||||
%{_bindir}/*
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/%{name}
|
||||
%{_libdir}/nautilus/extensions-2.0/*.so
|
||||
%{_datadir}/%{name}
|
||||
@ -151,6 +170,11 @@ fi
|
||||
%config %{_sysconfdir}/gconf/schemas/%{name}.schemas
|
||||
|
||||
|
||||
%files libs
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc %{_datadir}/gtk-doc/html/brasero
|
||||
@ -160,6 +184,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 3 2009 Denis Leroy <denis@poolshark.org> - 2.25.90-1
|
||||
- Update to upstream 2.25.90
|
||||
- Split media library into separate RPM (#483754)
|
||||
- Added patch to validate desktop files
|
||||
|
||||
* Tue Jan 20 2009 Denis Leroy <denis@poolshark.org> - 0.9.1-1
|
||||
- Update to upstream 0.9.1
|
||||
- Added development package
|
||||
|
Loading…
Reference in New Issue
Block a user