- Update to upstream 0.7.0, updated BRs
- Forward-ported open() permission patch
This commit is contained in:
parent
98e1385fcc
commit
0fd3c73e8c
@ -1 +1 @@
|
|||||||
brasero-0.6.1.tar.bz2
|
brasero-0.7.0.tar.bz2
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
--- brasero-0.6.0/src/burn-transcode.c~ 2007-07-11 14:48:14.000000000 +0200
|
|
||||||
+++ brasero-0.6.0/src/burn-transcode.c 2007-08-17 09:17:31.000000000 +0200
|
|
||||||
@@ -1402,7 +1402,8 @@
|
|
||||||
int fd;
|
|
||||||
gboolean result;
|
|
||||||
|
|
||||||
- fd = open (transcode->priv->current->dest, O_WRONLY | O_CREAT | O_APPEND);
|
|
||||||
+ fd = open (transcode->priv->current->dest, O_WRONLY | O_CREAT | O_APPEND,
|
|
||||||
+ S_IRWXU | S_IRGRP | S_IROTH);
|
|
||||||
if (fd == -1) {
|
|
||||||
g_set_error (error,
|
|
||||||
BRASERO_BURN_ERROR,
|
|
11
brasero-0.7.0-open.patch
Normal file
11
brasero-0.7.0-open.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- brasero-0.7.0/src/plugins/transcode/burn-transcode.c.orig 2007-12-30 11:17:45.000000000 +0100
|
||||||
|
+++ brasero-0.7.0/src/plugins/transcode/burn-transcode.c 2007-12-30 11:18:02.000000000 +0100
|
||||||
|
@@ -931,7 +931,7 @@
|
||||||
|
|
||||||
|
output = NULL;
|
||||||
|
brasero_job_get_audio_output (BRASERO_JOB (transcode), &output);
|
||||||
|
- fd = open (output, O_WRONLY | O_CREAT | O_APPEND);
|
||||||
|
+ fd = open (output, O_WRONLY | O_CREAT | O_APPEND, S_IRWXU | S_IRGRP | S_IROTH);
|
||||||
|
g_free (output);
|
||||||
|
|
||||||
|
if (fd == -1) {
|
27
brasero.spec
27
brasero.spec
@ -1,18 +1,18 @@
|
|||||||
|
|
||||||
Name: brasero
|
Name: brasero
|
||||||
Version: 0.6.1
|
Version: 0.7.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Gnome CD/DVD burning application
|
Summary: Gnome CD/DVD burning application
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.gnome.org/projects/brasero/
|
URL: http://www.gnome.org/projects/brasero/
|
||||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/brasero/0.6/%{name}-%{version}.tar.bz2
|
Source0: http://ftp.gnome.org/pub/GNOME/sources/brasero/0.7/%{name}-%{version}.tar.bz2
|
||||||
Patch0: brasero-0.6.0-tooltips.patch
|
Patch0: brasero-0.7.0-open.patch
|
||||||
Patch2: brasero-0.6.0-open.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: gettext intltool
|
BuildRequires: gettext intltool
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: gnome-vfs2-devel >= 2.14.2
|
||||||
BuildRequires: libgnomeui-devel >= 2.10.0
|
BuildRequires: libgnomeui-devel >= 2.10.0
|
||||||
BuildRequires: gstreamer-devel >= 0.10.6
|
BuildRequires: gstreamer-devel >= 0.10.6
|
||||||
BuildRequires: gstreamer-plugins-base-devel >= 0.10.0
|
BuildRequires: gstreamer-plugins-base-devel >= 0.10.0
|
||||||
@ -22,6 +22,10 @@ BuildRequires: libbeagle-devel >= 0.1.1
|
|||||||
%endif
|
%endif
|
||||||
BuildRequires: totem-pl-parser-devel
|
BuildRequires: totem-pl-parser-devel
|
||||||
BuildRequires: libnotify-devel >= 0.3.0
|
BuildRequires: libnotify-devel >= 0.3.0
|
||||||
|
BuildRequires: libxml2-devel >= 2.6.0
|
||||||
|
BuildRequires: dbus-glib-devel >= 0.7.2
|
||||||
|
BuildRequires: libburn-devel >= 0.4.0
|
||||||
|
BuildRequires: libisofs-devel >= 0.2.8
|
||||||
|
|
||||||
Requires: dvd+rw-tools
|
Requires: dvd+rw-tools
|
||||||
Requires: cdrecord
|
Requires: cdrecord
|
||||||
@ -43,16 +47,16 @@ desktop.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .tooltips
|
%patch0 -p1 -b .open
|
||||||
%patch2 -p1 -b .open
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
|
--enable-dbus \
|
||||||
|
--enable-preview \
|
||||||
--disable-caches \
|
--disable-caches \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--disable-schemas-install \
|
--disable-schemas-install
|
||||||
--disable-libburn
|
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -113,6 +117,7 @@ fi
|
|||||||
%doc AUTHORS COPYING ChangeLog NEWS README
|
%doc AUTHORS COPYING ChangeLog NEWS README
|
||||||
%{_mandir}/man1/%{name}.*
|
%{_mandir}/man1/%{name}.*
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
|
%{_libdir}/%{name}
|
||||||
%{_datadir}/%{name}
|
%{_datadir}/%{name}
|
||||||
%{_datadir}/applications/brasero.desktop
|
%{_datadir}/applications/brasero.desktop
|
||||||
%{_datadir}/icons/hicolor/*/apps/*
|
%{_datadir}/icons/hicolor/*/apps/*
|
||||||
@ -121,6 +126,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 30 2007 Denis Leroy <denis@poolshark.org> - 0.7.0-1
|
||||||
|
- Update to upstream 0.7.0, updated BRs
|
||||||
|
- Forward-ported open() permission patch
|
||||||
|
|
||||||
* Mon Dec 10 2007 Denis Leroy <denis@poolshark.org> - 0.6.1-4
|
* Mon Dec 10 2007 Denis Leroy <denis@poolshark.org> - 0.6.1-4
|
||||||
- Changed totem-devel req to totem-pl-parser-devel
|
- Changed totem-devel req to totem-pl-parser-devel
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user