Rebase bpftrace to version 0.22.1
Resolves: RHEL-63882 The version also contains built-in support for LLVM 19 so we can drop the extra patch. Signed-off-by: Viktor Malik <vmalik@redhat.com>
This commit is contained in:
parent
1245e5c105
commit
9a60ac5899
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@
|
|||||||
/bpftrace-0.19.1.tar.gz
|
/bpftrace-0.19.1.tar.gz
|
||||||
/bpftrace-0.20.1.tar.gz
|
/bpftrace-0.20.1.tar.gz
|
||||||
/bpftrace-0.21.1.tar.gz
|
/bpftrace-0.21.1.tar.gz
|
||||||
|
/bpftrace-0.22.1.tar.gz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From 6531fcc5da47ec8c161b08587f69eb90bffa53b8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Date: Fri, 16 Feb 2024 10:14:41 -0800
|
|
||||||
Subject: [PATCH] cmake: Bump max LLVM version to 19
|
|
||||||
|
|
||||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 2e1a32bd..3f095dba 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -149,7 +149,7 @@ else()
|
|
||||||
endif()
|
|
||||||
|
|
||||||
set(MIN_LLVM_MAJOR 6)
|
|
||||||
-set(MAX_LLVM_MAJOR 18)
|
|
||||||
+set(MAX_LLVM_MAJOR 19)
|
|
||||||
|
|
||||||
if((${LLVM_VERSION_MAJOR} VERSION_LESS ${MIN_LLVM_MAJOR}) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER ${MAX_LLVM_MAJOR}))
|
|
||||||
message(SEND_ERROR "Unsupported LLVM version found via ${LLVM_INCLUDE_DIRS}: ${LLVM_VERSION_MAJOR}")
|
|
||||||
--
|
|
||||||
2.47.0
|
|
||||||
|
|
@ -1,13 +1,12 @@
|
|||||||
Name: bpftrace
|
Name: bpftrace
|
||||||
Version: 0.21.1
|
Version: 0.22.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: High-level tracing language for Linux eBPF
|
Summary: High-level tracing language for Linux eBPF
|
||||||
License: Apache-2.0
|
License: Apache-2.0
|
||||||
|
|
||||||
URL: https://github.com/iovisor/bpftrace
|
URL: https://github.com/iovisor/bpftrace
|
||||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: %{name}-%{version}-cmake-Bump-max-LLVM-version-to-19.patch
|
|
||||||
Patch10: %{name}-%{version}-RHEL-aarch64-fixes-statsnoop-and-opensnoop.patch
|
Patch10: %{name}-%{version}-RHEL-aarch64-fixes-statsnoop-and-opensnoop.patch
|
||||||
|
|
||||||
# Arches will be included as upstream support is added and dependencies are
|
# Arches will be included as upstream support is added and dependencies are
|
||||||
@ -84,6 +83,9 @@ find %{buildroot}%{_datadir}/%{name}/tools -type f -exec \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 16 2025 Viktor Malik <vmalik@redhat.com> - 0.22.1-1
|
||||||
|
- Rebase to upstream version 0.22.1 (RHEL-63882)
|
||||||
|
|
||||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.21.1-3
|
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.21.1-3
|
||||||
- Bump release for October 2024 mass rebuild:
|
- Bump release for October 2024 mass rebuild:
|
||||||
Resolves: RHEL-64018
|
Resolves: RHEL-64018
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (bpftrace-0.21.1.tar.gz) = db6f5faf65fc2ac55ffbd1799b70941b8a6e4036c7fc2f56fe134f932dcf8a14fdd11a5a8b1d4b20261932d2d1ac18636cc1d7d4b87b31e366a9e53514a84ad3
|
SHA512 (bpftrace-0.22.1.tar.gz) = 3bf00f97750092e66bd94b20b3889f29e932f45ae7f75966f1f364013fb9aeaad837617c0a28402fd9323d62773dd3dab0e9749d8dcb9da9c77093f17fce4d91
|
||||||
|
Loading…
Reference in New Issue
Block a user