import CS bpftrace-0.16.0-4.el8
This commit is contained in:
parent
15d74ae9c4
commit
9486fd81b5
@ -0,0 +1,26 @@
|
|||||||
|
From b74ab9e00b4628e0d8607c6ead8a674bedf280b9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Khem Raj <raj.khem@gmail.com>
|
||||||
|
Date: Fri, 10 Mar 2023 00:08:27 -0800
|
||||||
|
Subject: [PATCH] cmake: Raise max llvm major version to 16
|
||||||
|
|
||||||
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index e63bc83c..433153be 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -169,7 +169,7 @@ else()
|
||||||
|
endif()
|
||||||
|
|
||||||
|
set(MIN_LLVM_MAJOR 6)
|
||||||
|
- set(MAX_LLVM_MAJOR 15)
|
||||||
|
+ set(MAX_LLVM_MAJOR 16)
|
||||||
|
|
||||||
|
if((${LLVM_VERSION_MAJOR} VERSION_LESS ${MIN_LLVM_MAJOR}) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER ${MAX_LLVM_MAJOR}))
|
||||||
|
message(SEND_ERROR "Unsupported LLVM version found via ${LLVM_INCLUDE_DIRS}: ${LLVM_VERSION_MAJOR}")
|
||||||
|
--
|
||||||
|
2.40.1
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: bpftrace
|
Name: bpftrace
|
||||||
Version: 0.16.0
|
Version: 0.16.0
|
||||||
Release: 1%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: High-level tracing language for Linux eBPF
|
Summary: High-level tracing language for Linux eBPF
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
|
|
||||||
@ -19,6 +19,7 @@ Patch0: %{name}-%{version}-IR-builder-get-rid-of-getPointerElementType-c
|
|||||||
Patch1: %{name}-%{version}-tools-old-mdflush.bt-fix-BPFTRACE_HAVE_BTF-macro.patch
|
Patch1: %{name}-%{version}-tools-old-mdflush.bt-fix-BPFTRACE_HAVE_BTF-macro.patch
|
||||||
Patch2: %{name}-%{version}-tcpdrop-Fix-ERROR-Error-attaching-probe-kprobe-tcp_d.patch
|
Patch2: %{name}-%{version}-tcpdrop-Fix-ERROR-Error-attaching-probe-kprobe-tcp_d.patch
|
||||||
Patch3: %{name}-%{version}-RHEL8-remove-not-existing-attachpoints-from-tools.patch
|
Patch3: %{name}-%{version}-RHEL8-remove-not-existing-attachpoints-from-tools.patch
|
||||||
|
Patch4: %{name}-%{version}-cmake-Raise-max-llvm-major-version-to-16.patch
|
||||||
Patch10: %{name}-%{version}-RHEL-8-aarch64-fixes-statsnoop-and-opensnoop.patch
|
Patch10: %{name}-%{version}-RHEL-8-aarch64-fixes-statsnoop-and-opensnoop.patch
|
||||||
|
|
||||||
# Arches will be included as upstream support is added and dependencies are
|
# Arches will be included as upstream support is added and dependencies are
|
||||||
@ -110,6 +111,14 @@ cp %{buildroot}/%{_datadir}/%{name}/tools/old/mdflush.bt %{buildroot}/%{_datadir
|
|||||||
%exclude %{_datadir}/%{name}/tools/old
|
%exclude %{_datadir}/%{name}/tools/old
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 09 2023 Viktor Malik <vmalik@redhat.com> - 0.16.0-3
|
||||||
|
- Add forgotten patch raising LLVM version in CMake
|
||||||
|
- Resolves: rhbz#2192950
|
||||||
|
|
||||||
|
* Fri Jun 09 2023 Viktor Malik <vmalik@redhat.com> - 0.16.0-2
|
||||||
|
- Rebuild for LLVM16
|
||||||
|
- Resolves: rhbz#2192950
|
||||||
|
|
||||||
* Wed Nov 30 2022 Viktor Malik <vmalik@redhat.com> - 0.16.0-1
|
* Wed Nov 30 2022 Viktor Malik <vmalik@redhat.com> - 0.16.0-1
|
||||||
- Rebase on bpftrace 0.16.0
|
- Rebase on bpftrace 0.16.0
|
||||||
- Rebuild for LLVM15
|
- Rebuild for LLVM15
|
||||||
|
Loading…
Reference in New Issue
Block a user