import bpftrace-0.12.1-2.el9
This commit is contained in:
commit
71470d9187
1
.bpftrace.metadata
Normal file
1
.bpftrace.metadata
Normal file
@ -0,0 +1 @@
|
||||
9cc3a1b5d4efd1649753cdb374102440c6625b57 SOURCES/bpftrace-0.12.1.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/bpftrace-0.12.1.tar.gz
|
56
SOURCES/bpftrace-0.12.1-RHEL-9-fixes.patch
Normal file
56
SOURCES/bpftrace-0.12.1-RHEL-9-fixes.patch
Normal file
@ -0,0 +1,56 @@
|
||||
From 453e1ea9b9d036cc9cfa0ef2e20c53e926e1b3b8 Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Marchand <jmarchan@redhat.com>
|
||||
Date: Tue, 11 Jun 2019 16:41:59 +0200
|
||||
Subject: [PATCH] RHEL 9 fixes
|
||||
|
||||
Fixes the following RHEL 8 specific issues:
|
||||
- library path in gethostlatency and threadsnoop
|
||||
---
|
||||
tools/gethostlatency.bt | 12 ++++++------
|
||||
tools/threadsnoop.bt | 2 +-
|
||||
2 files changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/tools/gethostlatency.bt b/tools/gethostlatency.bt
|
||||
index 9f4ec31e..dd389c6f 100755
|
||||
--- a/tools/gethostlatency.bt
|
||||
+++ b/tools/gethostlatency.bt
|
||||
@@ -26,17 +26,17 @@ BEGIN
|
||||
"HOST");
|
||||
}
|
||||
|
||||
-uprobe:/lib/x86_64-linux-gnu/libc.so.6:getaddrinfo,
|
||||
-uprobe:/lib/x86_64-linux-gnu/libc.so.6:gethostbyname,
|
||||
-uprobe:/lib/x86_64-linux-gnu/libc.so.6:gethostbyname2
|
||||
+uprobe:/lib64/libc.so.6:getaddrinfo,
|
||||
+uprobe:/lib64/libc.so.6:gethostbyname,
|
||||
+uprobe:/lib64/libc.so.6:gethostbyname2
|
||||
{
|
||||
@start[tid] = nsecs;
|
||||
@name[tid] = arg0;
|
||||
}
|
||||
|
||||
-uretprobe:/lib/x86_64-linux-gnu/libc.so.6:getaddrinfo,
|
||||
-uretprobe:/lib/x86_64-linux-gnu/libc.so.6:gethostbyname,
|
||||
-uretprobe:/lib/x86_64-linux-gnu/libc.so.6:gethostbyname2
|
||||
+uretprobe:/lib64/libc.so.6:getaddrinfo,
|
||||
+uretprobe:/lib64/libc.so.6:gethostbyname,
|
||||
+uretprobe:/lib64/libc.so.6:gethostbyname2
|
||||
/@start[tid]/
|
||||
{
|
||||
$latms = (nsecs - @start[tid]) / 1e6;
|
||||
diff --git a/tools/threadsnoop.bt b/tools/threadsnoop.bt
|
||||
index 3824bc6d..bdc6e4df 100755
|
||||
--- a/tools/threadsnoop.bt
|
||||
+++ b/tools/threadsnoop.bt
|
||||
@@ -18,7 +18,7 @@ BEGIN
|
||||
printf("%-10s %-6s %-16s %s\n", "TIME(ms)", "PID", "COMM", "FUNC");
|
||||
}
|
||||
|
||||
-uprobe:/lib/x86_64-linux-gnu/libpthread.so.0:pthread_create
|
||||
+uprobe:/usr/lib64/libpthread.so:pthread_create
|
||||
{
|
||||
printf("%-10u %-6d %-16s %s\n", elapsed / 1e6, pid, comm,
|
||||
usym(arg2));
|
||||
--
|
||||
2.31.1
|
||||
|
163
SPECS/bpftrace.spec
Normal file
163
SPECS/bpftrace.spec
Normal file
@ -0,0 +1,163 @@
|
||||
Name: bpftrace
|
||||
Version: 0.12.1
|
||||
Release: 2%{?dist}
|
||||
Summary: High-level tracing language for Linux eBPF
|
||||
License: ASL 2.0
|
||||
|
||||
URL: https://github.com/iovisor/bpftrace
|
||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: %{name}-%{version}-RHEL-9-fixes.patch
|
||||
|
||||
# Arches will be included as upstream support is added and dependencies are
|
||||
# satisfied in the respective arches
|
||||
ExclusiveArch: x86_64 %{power64} aarch64 s390x
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: bison
|
||||
BuildRequires: flex
|
||||
BuildRequires: cmake
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: llvm-devel
|
||||
BuildRequires: clang-devel
|
||||
BuildRequires: bcc-devel >= 0.19.0-1
|
||||
BuildRequires: libbpf-devel
|
||||
BuildRequires: libbpf-static
|
||||
BuildRequires: binutils-devel
|
||||
|
||||
|
||||
%description
|
||||
BPFtrace is a high-level tracing language for Linux enhanced Berkeley Packet
|
||||
Filter (eBPF) available in recent Linux kernels (4.x). BPFtrace uses LLVM as a
|
||||
backend to compile scripts to BPF-bytecode and makes use of BCC for
|
||||
interacting with the Linux BPF system, as well as existing Linux tracing
|
||||
capabilities: kernel dynamic tracing (kprobes), user-level dynamic tracing
|
||||
(uprobes), and tracepoints. The BPFtrace language is inspired by awk and C,
|
||||
and predecessor tracers such as DTrace and SystemTap
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
|
||||
%build
|
||||
%cmake . \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DBUILD_TESTING:BOOL=OFF \
|
||||
-DBUILD_SHARED_LIBS:BOOL=OFF
|
||||
%cmake_build
|
||||
|
||||
|
||||
%install
|
||||
# The post hooks strip the binary which removes
|
||||
# the BEGIN_trigger and END_trigger functions
|
||||
# which are needed for the BEGIN and END probes
|
||||
%global __os_install_post %{nil}
|
||||
%global _find_debuginfo_opts -g
|
||||
|
||||
%cmake_install
|
||||
|
||||
# Fix shebangs (https://fedoraproject.org/wiki/Packaging:Guidelines#Shebang_lines)
|
||||
find %{buildroot}%{_datadir}/%{name}/tools -type f -exec \
|
||||
sed -i -e '1s=^#!/usr/bin/env %{name}\([0-9.]\+\)\?$=#!%{_bindir}/%{name}=' {} \;
|
||||
|
||||
|
||||
%files
|
||||
%doc README.md CONTRIBUTING-TOOLS.md
|
||||
%doc docs/reference_guide.md docs/tutorial_one_liners.md
|
||||
%license LICENSE
|
||||
%dir %{_datadir}/%{name}
|
||||
%dir %{_datadir}/%{name}/tools
|
||||
%dir %{_datadir}/%{name}/tools/doc
|
||||
%{_bindir}/%{name}
|
||||
%{_mandir}/man8/*
|
||||
%attr(0755,-,-) %{_datadir}/%{name}/tools/*.bt
|
||||
%{_datadir}/%{name}/tools/doc/*.txt
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.12.1-2
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Thu May 27 2021 Jerome Marchand <jmarchan@redhat.com> - 0.12.0-1
|
||||
- Rebase to bpftrace 0.12.1
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0.11.0-10
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Fri Feb 12 2021 Jerome Marchand <jmarchan@redhat.com> - 0.11.0-9
|
||||
- Last build failed: rebuild.
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Jan 22 2021 Tom Stellard <tstellar@redhat.com> - 0.11.0-7
|
||||
- Rebuild for clang-11.1.0
|
||||
|
||||
* Fri Dec 04 2020 Jeff Law <law@redhat.com> - 0.11.0-6
|
||||
- Fix missing #include for gcc-11
|
||||
|
||||
* Fri Nov 13 2020 Jerome Marchand <jmarchan@redhat.com> - 0.11.0-5
|
||||
- Rebuilt for LLVM 11
|
||||
|
||||
* Tue Aug 04 2020 Augusto Caringi <acaringi@redhat.com> - 0.11.0-4
|
||||
- Fix FTBFS due to cmake wide changes #1863295
|
||||
- Fix 'bpftrace symbols are stripped' #1865787
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-3
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jul 16 2020 Augusto Caringi <acaringi@redhat.com> - 0.11.0-1
|
||||
* Rebased to version 0.11.0
|
||||
|
||||
* Tue May 19 2020 Augusto Caringi <acaringi@redhat.com> - 0.10.0-2
|
||||
- Rebuilt for new bcc/libbpf versions
|
||||
|
||||
* Tue Apr 14 2020 Augusto Caringi <acaringi@redhat.com> - 0.10.0-1
|
||||
- Rebased to version 0.10.0
|
||||
- Dropped support for s390x temporaly due to build error
|
||||
|
||||
* Thu Feb 06 2020 Augusto Caringi <acaringi@redhat.com> - 0.9.4-1
|
||||
- Rebased to version 0.9.4
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Nov 21 2019 Augusto Caringi <acaringi@redhat.com> - 0.9.3-1
|
||||
- Rebased to version 0.9.3
|
||||
|
||||
* Thu Aug 01 2019 Augusto Caringi <acaringi@redhat.com> - 0.9.2-1
|
||||
- Rebased to version 0.9.2
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed Jun 26 2019 Augusto Caringi <acaringi@redhat.com> - 0.9.1-1
|
||||
- Rebased to version 0.9.1
|
||||
|
||||
* Thu Apr 25 2019 Augusto Caringi <acaringi@redhat.com> - 0.9-3
|
||||
- Rebuilt for bcc 0.9.0
|
||||
|
||||
* Mon Apr 22 2019 Neal Gompa <ngompa@datto.com> - 0.9-2
|
||||
- Fix Source0 reference
|
||||
- Use make_build macro for calling make
|
||||
|
||||
* Mon Apr 1 2019 Peter Robinson <pbrobinson@fedoraproject.org> 0.9-1
|
||||
- Build on aarch64 and s390x
|
||||
|
||||
* Mon Mar 25 2019 Augusto Caringi <acaringi@redhat.com> - 0.9-0
|
||||
- Updated to version 0.9
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.0-2.20181210gitc49b333
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Dec 10 2018 Augusto Caringi <acaringi@redhat.com> - 0.0-1.20181210gitc49b333
|
||||
- Updated to latest upstream (c49b333c034a6d29a7ce90f565e27da1061af971)
|
||||
|
||||
* Wed Nov 07 2018 Augusto Caringi <acaringi@redhat.com> - 0.0-1.20181107git029717b
|
||||
- Initial import
|
Loading…
Reference in New Issue
Block a user