Rebuild for LLVM 19

Resolves: RHEL-64926

Signed-off-by: Viktor Malik <vmalik@redhat.com>
This commit is contained in:
Viktor Malik 2024-10-29 08:47:09 +01:00
parent 22056494a9
commit 41965577f2
No known key found for this signature in database
GPG Key ID: AF7A2E1F6EE74FB3
2 changed files with 31 additions and 0 deletions

View File

@ -0,0 +1,26 @@
From 6531fcc5da47ec8c161b08587f69eb90bffa53b8 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 16 Feb 2024 10:14:41 -0800
Subject: [PATCH] cmake: Bump max LLVM version to 19
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e1a32bd..3f095dba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -149,7 +149,7 @@ else()
endif()
set(MIN_LLVM_MAJOR 6)
-set(MAX_LLVM_MAJOR 18)
+set(MAX_LLVM_MAJOR 19)
if((${LLVM_VERSION_MAJOR} VERSION_LESS ${MIN_LLVM_MAJOR}) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER ${MAX_LLVM_MAJOR}))
message(SEND_ERROR "Unsupported LLVM version found via ${LLVM_INCLUDE_DIRS}: ${LLVM_VERSION_MAJOR}")
--
2.47.0

View File

@ -7,6 +7,7 @@ License: Apache-2.0
URL: https://github.com/iovisor/bpftrace
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: %{name}-%{version}-cmake-Bump-max-LLVM-version-to-19.patch
Patch10: %{name}-%{version}-RHEL-aarch64-fixes-statsnoop-and-opensnoop.patch
# Arches will be included as upstream support is added and dependencies are
@ -83,6 +84,10 @@ find %{buildroot}%{_datadir}/%{name}/tools -type f -exec \
%changelog
* Tue Oct 29 2024 Viktor Malik <vmalik@redhat.com> - 0.21.1-1
- Rebuild for LLVM 19
- Resolves: RHEL-64926
* Tue Jun 25 2024 Viktor Malik <vmalik@redhat.com> - 0.21.1-1
- Rebased to version 0.21.1
- Resolves: RHEL-36076