34 lines
1.0 KiB
Diff
34 lines
1.0 KiB
Diff
From 2f944ea46b1b39113a34ca586cd8e3cd8f0d1d70 Mon Sep 17 00:00:00 2001
|
|
From: Jan Friesse <jfriesse@redhat.com>
|
|
Date: Wed, 3 Jun 2020 15:04:56 +0200
|
|
Subject: [PATCH] build: Do not link with pcmk libraries
|
|
|
|
Patch 4205de05fe337d1b1127fae302e6e6c2f0613ccf introduced better way to
|
|
check for pacemaker headers but also usage of PCMK_LIBS when linking
|
|
boothd.
|
|
|
|
This is not needed, because boothd uses just crm/services.h header file
|
|
for inclusion of OCF return codes, so patch removes the use of PCMK_LIBS.
|
|
|
|
Signed-off-by: Jan Friesse <jfriesse@redhat.com>
|
|
---
|
|
src/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index 8598725..4023791 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -23,7 +23,7 @@ boothd_SOURCES += auth.c
|
|
endif
|
|
|
|
boothd_LDFLAGS = $(OS_DYFLAGS) -L./
|
|
-boothd_LDADD = -lm $(GLIB_LIBS) $(ZLIB_LIBS) $(PCMK_LIBS)
|
|
+boothd_LDADD = -lm $(GLIB_LIBS) $(ZLIB_LIBS)
|
|
boothd_CFLAGS = $(GLIB_CFLAGS) $(PCMK_CFLAGS)
|
|
|
|
if !LOGGING_LIBQB
|
|
--
|
|
2.18.2
|
|
|