Remove unneeded patches
Signed-off-by: Jan Friesse <jfriesse@redhat.com>
This commit is contained in:
parent
e5a92625e9
commit
da88b3aa00
@ -1,33 +0,0 @@
|
|||||||
From 2f944ea46b1b39113a34ca586cd8e3cd8f0d1d70 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jan Friesse <jfriesse@redhat.com>
|
|
||||||
Date: Wed, 3 Jun 2020 15:04:56 +0200
|
|
||||||
Subject: [PATCH] build: Do not link with pcmk libraries
|
|
||||||
|
|
||||||
Patch 4205de05fe337d1b1127fae302e6e6c2f0613ccf introduced better way to
|
|
||||||
check for pacemaker headers but also usage of PCMK_LIBS when linking
|
|
||||||
boothd.
|
|
||||||
|
|
||||||
This is not needed, because boothd uses just crm/services.h header file
|
|
||||||
for inclusion of OCF return codes, so patch removes the use of PCMK_LIBS.
|
|
||||||
|
|
||||||
Signed-off-by: Jan Friesse <jfriesse@redhat.com>
|
|
||||||
---
|
|
||||||
src/Makefile.am | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
||||||
index 8598725..4023791 100644
|
|
||||||
--- a/src/Makefile.am
|
|
||||||
+++ b/src/Makefile.am
|
|
||||||
@@ -23,7 +23,7 @@ boothd_SOURCES += auth.c
|
|
||||||
endif
|
|
||||||
|
|
||||||
boothd_LDFLAGS = $(OS_DYFLAGS) -L./
|
|
||||||
-boothd_LDADD = -lm $(GLIB_LIBS) $(ZLIB_LIBS) $(PCMK_LIBS)
|
|
||||||
+boothd_LDADD = -lm $(GLIB_LIBS) $(ZLIB_LIBS)
|
|
||||||
boothd_CFLAGS = $(GLIB_CFLAGS) $(PCMK_CFLAGS)
|
|
||||||
|
|
||||||
if !LOGGING_LIBQB
|
|
||||||
--
|
|
||||||
2.18.2
|
|
||||||
|
|
@ -1,41 +0,0 @@
|
|||||||
From eda7abe337e5e37ef8d1d8ff7abdce334fa9bd21 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jan Friesse <jfriesse@redhat.com>
|
|
||||||
Date: Tue, 29 Sep 2020 14:22:30 +0200
|
|
||||||
Subject: [PATCH] test: Add compatibility with iproute ss command
|
|
||||||
|
|
||||||
ensure_boothd_not_running is now exectured only when single instance is
|
|
||||||
used, but if so, it requires netstat command. Netstat is deprecated for
|
|
||||||
some time and it is slowly disappearing from distributions, so add
|
|
||||||
support for iproute ss command.
|
|
||||||
|
|
||||||
Parameters for both ss and netstat are same, but sadly output differs so
|
|
||||||
both netstat and ss output is matched.
|
|
||||||
|
|
||||||
Signed-off-by: Jan Friesse <jfriesse@redhat.com>
|
|
||||||
---
|
|
||||||
test/boothtestenv.py.in | 6 ++++--
|
|
||||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/test/boothtestenv.py.in b/test/boothtestenv.py.in
|
|
||||||
index 26a40cb..8a23615 100644
|
|
||||||
--- a/test/boothtestenv.py.in
|
|
||||||
+++ b/test/boothtestenv.py.in
|
|
||||||
@@ -31,11 +31,13 @@ class BoothTestEnvironment(unittest.TestCase, BoothAssertions):
|
|
||||||
|
|
||||||
def ensure_boothd_not_running(self):
|
|
||||||
# Need to redirect STDERR in case we're not root, in which
|
|
||||||
- # case netstat's -p option causes a warning. However we only
|
|
||||||
+ # case netstat's -p option causes a warning (ss doesn't). However we only
|
|
||||||
# want to kill boothd processes which we own; -p will list the
|
|
||||||
# pid for those and only those, which is exactly what we want
|
|
||||||
# here.
|
|
||||||
- subprocess.call("netstat -tpln 2>&1 | perl -lne 'm,LISTEN\s+(\d+)/boothd, and kill 15, $1'", shell=True)
|
|
||||||
+ subprocess.call("(netstat -tlnp || ss -tlnp) 2>&1 | " +
|
|
||||||
+ "perl -lne '(m,LISTEN\s+(\d+)/boothd, || /\"boothd\".*pid=(\d+)/) and kill 15, $1'",
|
|
||||||
+ shell=True)
|
|
||||||
|
|
||||||
def get_tempfile(self, identity):
|
|
||||||
tf = tempfile.NamedTemporaryFile(
|
|
||||||
--
|
|
||||||
2.18.2
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user