- Apply a unneccessary_iostreams patch from Caolan McNamara
- Fix soname patch so that it applies with fuzz=0. Use fuzz=0 option in spec file just like ordinary patches do. - Resolves: #479409
This commit is contained in:
parent
463220e7bb
commit
d2ca7a19ed
@ -1,7 +1,7 @@
|
||||
--- boost_1_36_0_beta1/tools/build/v2/tools/gcc.jam.orig 2008-08-11 13:15:13.000000000 +0200
|
||||
+++ boost_1_36_0_beta1/tools/build/v2/tools/gcc.jam 2008-08-11 15:21:05.000000000 +0200
|
||||
@@ -336,7 +336,8 @@
|
||||
# OSF does have an option called -soname but it doesn't seem to work as
|
||||
# OSF does have an option called -soname but it does not seem to work as
|
||||
# expected, therefore it has been disabled.
|
||||
HAVE_SONAME = "" ;
|
||||
- SONAME_OPTION = -h ;
|
||||
@ -11,11 +11,11 @@
|
||||
|
||||
|
||||
@@ -726,7 +727,7 @@
|
||||
# Differ from 'link' above only by -shared.
|
||||
# Differs from 'link' above only by -shared.
|
||||
actions link.dll bind LIBRARIES
|
||||
{
|
||||
- "$(CONFIG_COMMAND)" -L"$(LINKPATH)" -Wl,$(RPATH_OPTION:E=-R)$(SPACE)-Wl,"$(RPATH)" "$(.IMPLIB-COMMAND)$(<[1])" -o "$(<[-1])" $(HAVE_SONAME)-Wl,$(SONAME_OPTION)$(SPACE)-Wl,$(<[-1]:D=) -shared $(START-GROUP) "$(>)" "$(LIBRARIES)" $(FINDLIBS-ST-PFX) -l$(FINDLIBS-ST) $(FINDLIBS-SA-PFX) -l$(FINDLIBS-SA) $(END-GROUP) $(OPTIONS) $(USER_OPTIONS)
|
||||
+ "$(CONFIG_COMMAND)" -L"$(LINKPATH)" -Wl,$(RPATH_OPTION:E=-R)$(SPACE)-Wl,"$(RPATH)" "$(.IMPLIB-COMMAND)$(<[1])" -o "$(<[-1])" $(HAVE_SONAME)-Wl,$(SONAME_OPTION)$(SPACE)-Wl,$(<[-1]:D=).$(SONAME_VERSION) -shared $(START-GROUP) "$(>)" "$(LIBRARIES)" $(FINDLIBS-ST-PFX) -l$(FINDLIBS-ST) $(FINDLIBS-SA-PFX) -l$(FINDLIBS-SA) $(END-GROUP) $(OPTIONS) $(USER_OPTIONS)
|
||||
}
|
||||
|
||||
# Set up threading support. It's somewhat contrived, so perform it at the end,
|
||||
rule setup-threading ( targets * : sources * : properties * )
|
||||
|
11
boost-unneccessary_iostreams.patch
Normal file
11
boost-unneccessary_iostreams.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -ru boost_1_37_0.orig/boost/spirit/home/classic/iterator/multi_pass.hpp boost_1_37_0/boost/spirit/home/classic/iterator/multi_pass.hpp
|
||||
--- boost/spirit/home/classic/iterator/multi_pass.hpp 2009-01-09 10:38:36.000000000 +0000
|
||||
+++ boost/spirit/home/classic/iterator/multi_pass.hpp 2009-01-09 10:39:41.000000000 +0000
|
||||
@@ -12,7 +12,6 @@
|
||||
#include <boost/throw_exception.hpp>
|
||||
#include <deque>
|
||||
#include <iterator>
|
||||
-#include <iostream>
|
||||
#include <algorithm> // for std::swap
|
||||
#include <exception> // for std::exception
|
||||
#include <boost/limits.hpp>
|
14
boost.spec
14
boost.spec
@ -4,7 +4,7 @@
|
||||
Name: boost
|
||||
Summary: The Boost C++ Libraries
|
||||
Version: 1.37.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: Boost
|
||||
URL: http://www.boost.org/
|
||||
Group: System Environment/Libraries
|
||||
@ -27,6 +27,7 @@ Patch2: boost-run-tests.patch
|
||||
Patch3: boost-gcc43.patch
|
||||
Patch4: boost-gcc-soname.patch
|
||||
Patch5: boost-function_template.patch
|
||||
Patch6: boost-unneccessary_iostreams.patch
|
||||
|
||||
%description
|
||||
Boost provides free peer-reviewed portable C++ source libraries. The
|
||||
@ -66,12 +67,13 @@ HTML documentation files for Boost C++ libraries.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}_1_37_0
|
||||
%patch0 -p0
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
%patch3 -p1
|
||||
sed 's/!!!SONAME!!!/%{sonamever}/' %{PATCH4} | %{__patch} -p1
|
||||
sed 's/!!!SONAME!!!/%{sonamever}/' %{PATCH4} | %{__patch} -p1 --fuzz=0
|
||||
%patch5 -p0
|
||||
%patch6 -p0
|
||||
|
||||
%build
|
||||
BOOST_ROOT=`pwd`
|
||||
@ -204,6 +206,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc %{_docdir}/%{name}-%{version}
|
||||
|
||||
%changelog
|
||||
* Mon Jan 12 2009 Petr Machata <pmachata@redhat.com> - 1.37.0-3
|
||||
- Apply a unneccessary_iostreams patch from Caolan McNamara
|
||||
- Fix soname patch so that it applies with fuzz=0. Use fuzz=0 option
|
||||
in spec file just like ordinary patches do.
|
||||
- Resolves: #479409
|
||||
|
||||
* Fri Dec 19 2008 Petr Machata <pmachata@redhat.com> - 1.37.0-2
|
||||
- Apply a function_template patch from Caolan McNamara
|
||||
- Resolves: #477131
|
||||
|
Loading…
Reference in New Issue
Block a user