Patch to fix #1485641
This commit is contained in:
parent
91d3fad8f3
commit
b9e2eb12e9
37
boost-1.64.0-icl-ttp-matching.patch
Normal file
37
boost-1.64.0-icl-ttp-matching.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
From 32178e147a976419b9ac846d3c40c3ab4d1e0ff6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mathias Gaunard <mathias@gaunard.com>
|
||||||
|
Date: Thu, 4 May 2017 17:18:22 +0100
|
||||||
|
Subject: [PATCH] Compatibility with GCC 7.1
|
||||||
|
|
||||||
|
The libstdc++ shipped with GCC 7.1 uses a unary class template for std::string.
|
||||||
|
type_to_string needs to be adapted to deal with this properly.
|
||||||
|
---
|
||||||
|
include/boost/icl/type_traits/type_to_string.hpp | 8 +++++++-
|
||||||
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/include/boost/icl/type_traits/type_to_string.hpp b/include/boost/icl/type_traits/type_to_string.hpp
|
||||||
|
index 80c473a..994711b 100644
|
||||||
|
--- a/include/boost/icl/type_traits/type_to_string.hpp
|
||||||
|
+++ b/include/boost/icl/type_traits/type_to_string.hpp
|
||||||
|
@@ -43,7 +43,6 @@ namespace boost{ namespace icl
|
||||||
|
|
||||||
|
template<>inline std::string type_to_string<float>::apply() { return "flt"; }
|
||||||
|
template<>inline std::string type_to_string<double>::apply() { return "dbl"; }
|
||||||
|
- template<>inline std::string type_to_string<std::string>::apply() { return "string"; }
|
||||||
|
|
||||||
|
//-------------------------------------------------------------------------
|
||||||
|
template<template<class> class Templ>
|
||||||
|
@@ -78,6 +77,13 @@ namespace boost{ namespace icl
|
||||||
|
}
|
||||||
|
};
|
||||||
|
|
||||||
|
+ // ---------------------------------------------------------------------------
|
||||||
|
+ template<>
|
||||||
|
+ struct type_to_string<std::string>
|
||||||
|
+ {
|
||||||
|
+ static std::string apply() { return "string"; }
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
}} // namespace boost icl
|
||||||
|
|
||||||
|
#endif
|
10
boost.spec
10
boost.spec
@ -35,7 +35,7 @@ Name: boost
|
|||||||
Summary: The free peer-reviewed portable C++ source libraries
|
Summary: The free peer-reviewed portable C++ source libraries
|
||||||
Version: 1.64.0
|
Version: 1.64.0
|
||||||
%global version_enc 1_64_0
|
%global version_enc 1_64_0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: Boost and MIT and Python
|
License: Boost and MIT and Python
|
||||||
|
|
||||||
%global toplev_dirname %{name}_%{version_enc}
|
%global toplev_dirname %{name}_%{version_enc}
|
||||||
@ -140,6 +140,10 @@ Patch84: boost-1.64.0-mpi-get_data.patch
|
|||||||
# https://github.com/boostorg/serialization/commit/1d86261581230e2dc5d617a9b16287d326f3e229
|
# https://github.com/boostorg/serialization/commit/1d86261581230e2dc5d617a9b16287d326f3e229
|
||||||
Patch85: boost-1.64.0-serialization-make_array.patch
|
Patch85: boost-1.64.0-serialization-make_array.patch
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1485641
|
||||||
|
# https://github.com/boostorg/icl/pull/9
|
||||||
|
Patch86: boost-1.64.0-icl-ttp-matching.patch
|
||||||
|
|
||||||
%bcond_with tests
|
%bcond_with tests
|
||||||
%bcond_with docs_generated
|
%bcond_with docs_generated
|
||||||
|
|
||||||
@ -762,6 +766,7 @@ a number of significant features and is now developed independently
|
|||||||
%patch83 -p1
|
%patch83 -p1
|
||||||
%patch84 -p2
|
%patch84 -p2
|
||||||
%patch85 -p2
|
%patch85 -p2
|
||||||
|
%patch86 -p2
|
||||||
|
|
||||||
# At least python2_version needs to be a macro so that it's visible in
|
# At least python2_version needs to be a macro so that it's visible in
|
||||||
# %%install as well.
|
# %%install as well.
|
||||||
@ -1551,6 +1556,9 @@ fi
|
|||||||
%{_mandir}/man1/bjam.1*
|
%{_mandir}/man1/bjam.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 12 2017 Jonathan Wakely <jwakely@redhat.com> - 1.64.0-2
|
||||||
|
- Patch to fix #1485641
|
||||||
|
|
||||||
* Wed Sep 06 2017 Jonathan Wakely <jwakely@redhat.com> - 1.64.0-1
|
* Wed Sep 06 2017 Jonathan Wakely <jwakely@redhat.com> - 1.64.0-1
|
||||||
- Fix descriptions
|
- Fix descriptions
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user