Patch to prevent address model being set by Boost.Build.
This commit is contained in:
parent
a1b6b50100
commit
b86f78331a
13
boost-1.58.0-address-model.patch
Normal file
13
boost-1.58.0-address-model.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- boost_1_58_0/tools/build/src/tools/gcc.jam~ 2015-07-17 15:14:57.381636224 +0100
|
||||
+++ boost_1_58_0/tools/build/src/tools/gcc.jam 2015-07-27 17:35:29.122264048 +0100
|
||||
@@ -421,7 +421,9 @@
|
||||
|
||||
rule setup-address-model ( targets * : sources * : properties * )
|
||||
{
|
||||
- local model = [ feature.get-values address-model : $(properties) ] ;
|
||||
+ # For RPM builds the address model flag is passed in %{optflags}.
|
||||
+ # local model = [ feature.get-values address-model : $(properties) ] ;
|
||||
+ local model ;
|
||||
if $(model)
|
||||
{
|
||||
local option ;
|
12
boost.spec
12
boost.spec
@ -32,7 +32,7 @@ Name: boost
|
||||
Summary: The free peer-reviewed portable C++ source libraries
|
||||
Version: 1.58.0
|
||||
%define version_enc 1_58_0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: Boost and MIT and Python
|
||||
|
||||
%define toplev_dirname %{name}_%{version_enc}
|
||||
@ -127,6 +127,9 @@ Patch66: boost-1.57.0-uuid-comparison.patch
|
||||
# https://svn.boost.org/trac/boost/ticket/11283
|
||||
Patch67: boost-1.58.0-variant-includes.patch
|
||||
|
||||
# Prevent gcc.jam from setting -m32 or -m64.
|
||||
Patch68: boost-1.58.0-address-model.patch
|
||||
|
||||
Patch70: 0001-Changes-required-for-aarch64-support-in-boost-config.patch
|
||||
|
||||
%bcond_with tests
|
||||
@ -617,6 +620,7 @@ a number of significant features and is now developed independently
|
||||
%patch65 -p1
|
||||
%patch66 -p2
|
||||
%patch67 -p2
|
||||
%patch68 -p1
|
||||
%patch70 -p1
|
||||
|
||||
# At least python2_version needs to be a macro so that it's visible in
|
||||
@ -676,8 +680,7 @@ echo ============================= build serial ==================
|
||||
variant=release threading=multi debug-symbols=on pch=off \
|
||||
python=%{python2_version} stage
|
||||
|
||||
# See boost-1.54.0-thread-link_atomic.patch for where this file comes
|
||||
# from.
|
||||
# See libs/thread/build/Jamfile.v2 for where this file comes from.
|
||||
if [ $(find serial -type f -name has_atomic_flag_lockfree \
|
||||
-print -quit | wc -l) -ne 0 ]; then
|
||||
DEF=D
|
||||
@ -1237,6 +1240,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man1/bjam.1*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 04 2015 Jonathan Wakely <jwakely@redhat.com> 1.58.0-4
|
||||
- Patch to prevent address model being set by Boost.Build.
|
||||
|
||||
* Mon Jul 27 2015 Jonathan Wakely <jwakely@redhat.com> 1.58.0-3
|
||||
- Patch for missing include (boost-1.58.0-variant-includes.patch).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user