- Apply a SMP patch from Stefan Ring
- Apply a workaround for "cannot appear in a constant-expression" in dynamic_bitset library. - Resolves: #491537
This commit is contained in:
parent
c99df9fbf7
commit
8493f2dec8
12
boost-1_37_0-smp.patch
Normal file
12
boost-1_37_0-smp.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up boost_1_37_0/configure.smp boost_1_37_0/configure
|
||||
--- boost_1_37_0/configure.smp 2009-02-05 18:49:01.000000000 +0100
|
||||
+++ boost_1_37_0/configure 2009-02-05 18:53:55.000000000 +0100
|
||||
@@ -347,7 +347,7 @@ LIBS=$LIBS
|
||||
|
||||
all: .dummy
|
||||
@echo "\$(BJAM) \$(BJAM_CONFIG) --user-config=user-config.jam \$(LIBS) stage"
|
||||
- @\$(BJAM) \$(BJAM_CONFIG) --user-config=user-config.jam \$(LIBS) stage || \\
|
||||
+ @\$(BJAM) \$(BJAM_CONFIG) --user-config=user-config.jam \$(LIBS) !!!SMP_FLAGS!!! stage || \\
|
||||
echo "Not all Boost libraries built properly."
|
||||
|
||||
clean: .dummy
|
15
boost-bitset.patch
Normal file
15
boost-bitset.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- boost_1_37_0/boost/dynamic_bitset/dynamic_bitset.hpp.debug 2008-10-22 03:13:59.000000000 +0900
|
||||
+++ boost_1_37_0/boost/dynamic_bitset/dynamic_bitset.hpp 2009-03-23 03:36:40.000000000 +0900
|
||||
@@ -1017,8 +1017,11 @@
|
||||
? access_by_bytes
|
||||
: access_by_blocks;
|
||||
|
||||
+ if (mode)
|
||||
+ return do_count(m_bits.begin(), num_blocks(), Block(0),
|
||||
+ static_cast<value_to_type<true> *>(0));
|
||||
return do_count(m_bits.begin(), num_blocks(), Block(0),
|
||||
- static_cast<value_to_type<mode> *>(0));
|
||||
+ static_cast<value_to_type<false> *>(0));
|
||||
}
|
||||
|
||||
|
13
boost.spec
13
boost.spec
@ -4,7 +4,7 @@
|
||||
Name: boost
|
||||
Summary: The Boost C++ Libraries
|
||||
Version: 1.37.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: Boost
|
||||
URL: http://www.boost.org/
|
||||
Group: System Environment/Libraries
|
||||
@ -28,6 +28,8 @@ Patch3: boost-gcc43.patch
|
||||
Patch4: boost-gcc-soname.patch
|
||||
Patch5: boost-function_template.patch
|
||||
Patch6: boost-unneccessary_iostreams.patch
|
||||
Patch7: boost-1_37_0-smp.patch
|
||||
Patch8: boost-bitset.patch
|
||||
|
||||
%description
|
||||
Boost provides free peer-reviewed portable C++ source libraries. The
|
||||
@ -74,6 +76,9 @@ HTML documentation files for Boost C++ libraries.
|
||||
sed 's/!!!SONAME!!!/%{sonamever}/' %{PATCH4} | %{__patch} -p1 --fuzz=0
|
||||
%patch5 -p0
|
||||
%patch6 -p0
|
||||
%patch7 -p1
|
||||
#sed 's/!!!SMP_FLAGS!!!/%{?_smp_mflags}/' %{PATCH7} | %{__patch} -p1 --fuzz=0
|
||||
%patch8 -p1
|
||||
|
||||
%build
|
||||
BOOST_ROOT=`pwd`
|
||||
@ -206,6 +211,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc %{_docdir}/%{name}-%{version}
|
||||
|
||||
%changelog
|
||||
* Mon Mar 23 2009 Petr Machata <pmachata@redhat.com> - 1.37.0-5
|
||||
- Apply a SMP patch from Stefan Ring
|
||||
- Apply a workaround for "cannot appear in a constant-expression" in
|
||||
dynamic_bitset library.
|
||||
- Resolves: #491537
|
||||
|
||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.37.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user