- Fixes for GCC 4.3
- Resolves: #431609 - Single '%' signs appearing over the spec have been replaced with "%%" combo
This commit is contained in:
parent
7bb17cb51c
commit
73ed8a269d
140
boost-gcc43.patch
Normal file
140
boost-gcc43.patch
Normal file
@ -0,0 +1,140 @@
|
|||||||
|
diff -urp boost_1_34_1/boost/spirit/phoenix/operators.hpp boost_1_34_1.pm/boost/spirit/phoenix/operators.hpp
|
||||||
|
--- boost_1_34_1/boost/spirit/phoenix/operators.hpp 2006-08-25 18:27:30.000000000 +0200
|
||||||
|
+++ boost_1_34_1.pm/boost/spirit/phoenix/operators.hpp 2008-02-06 16:29:32.000000000 +0100
|
||||||
|
@@ -24,6 +24,7 @@
|
||||||
|
#include <boost/spirit/phoenix/composite.hpp>
|
||||||
|
#include <boost/config.hpp>
|
||||||
|
#include <boost/mpl/if.hpp>
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
///////////////////////////////////////////////////////////////////////////////
|
||||||
|
namespace phoenix {
|
||||||
|
diff -urp boost_1_34_1/boost/regex/v4/basic_regex_creator.hpp boost_1_34_1.pm/boost/regex/v4/basic_regex_creator.hpp
|
||||||
|
--- boost_1_34_1/boost/regex/v4/basic_regex_creator.hpp 2006-07-16 18:06:38.000000000 +0200
|
||||||
|
+++ boost_1_34_1.pm/boost/regex/v4/basic_regex_creator.hpp 2008-02-06 17:36:42.000000000 +0100
|
||||||
|
@@ -24,6 +24,8 @@
|
||||||
|
# include BOOST_ABI_PREFIX
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
namespace boost{
|
||||||
|
|
||||||
|
namespace re_detail{
|
||||||
|
diff -urp boost_1_34_1/boost/regex/v4/basic_regex.hpp boost_1_34_1.pm/boost/regex/v4/basic_regex.hpp
|
||||||
|
--- boost_1_34_1/boost/regex/v4/basic_regex.hpp 2007-06-05 19:28:18.000000000 +0200
|
||||||
|
+++ boost_1_34_1.pm/boost/regex/v4/basic_regex.hpp 2008-02-06 17:33:30.000000000 +0100
|
||||||
|
@@ -23,6 +23,8 @@
|
||||||
|
# include BOOST_ABI_PREFIX
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
namespace boost{
|
||||||
|
#ifdef BOOST_MSVC
|
||||||
|
#pragma warning(push)
|
||||||
|
diff -urp boost_1_34_1/boost/regex/v4/basic_regex_parser.hpp boost_1_34_1.pm/boost/regex/v4/basic_regex_parser.hpp
|
||||||
|
--- boost_1_34_1/boost/regex/v4/basic_regex_parser.hpp 2008-02-06 17:45:26.000000000 +0100
|
||||||
|
+++ boost_1_34_1.pm/boost/regex/v4/basic_regex_parser.hpp 2008-02-06 17:38:58.000000000 +0100
|
||||||
|
@@ -23,6 +23,8 @@
|
||||||
|
# include BOOST_ABI_PREFIX
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
namespace boost{
|
||||||
|
namespace re_detail{
|
||||||
|
|
||||||
|
diff -urp boost_1_34_1/boost/regex/v4/cpp_regex_traits.hpp boost_1_34_1.pm/boost/regex/v4/cpp_regex_traits.hpp
|
||||||
|
--- boost_1_34_1/boost/regex/v4/cpp_regex_traits.hpp 2007-01-15 12:09:44.000000000 +0100
|
||||||
|
+++ boost_1_34_1.pm/boost/regex/v4/cpp_regex_traits.hpp 2008-02-06 17:26:51.000000000 +0100
|
||||||
|
@@ -41,6 +41,7 @@
|
||||||
|
|
||||||
|
#include <istream>
|
||||||
|
#include <ios>
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
#ifdef BOOST_HAS_ABI_HEADERS
|
||||||
|
# include BOOST_ABI_PREFIX
|
||||||
|
diff -urp boost_1_34_1/boost/regex/v4/perl_matcher.hpp boost_1_34_1.pm/boost/regex/v4/perl_matcher.hpp
|
||||||
|
--- boost_1_34_1/boost/regex/v4/perl_matcher.hpp 2006-10-18 14:55:30.000000000 +0200
|
||||||
|
+++ boost_1_34_1.pm/boost/regex/v4/perl_matcher.hpp 2008-02-06 17:39:44.000000000 +0100
|
||||||
|
@@ -18,6 +18,8 @@
|
||||||
|
# include BOOST_ABI_PREFIX
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
namespace boost{
|
||||||
|
namespace re_detail{
|
||||||
|
|
||||||
|
diff -urp boost_1_34_1/boost/regex/v4/regex_split.hpp boost_1_34_1.pm/boost/regex/v4/regex_split.hpp
|
||||||
|
--- boost_1_34_1/boost/regex/v4/regex_split.hpp 2005-01-21 18:22:38.000000000 +0100
|
||||||
|
+++ boost_1_34_1.pm/boost/regex/v4/regex_split.hpp 2008-02-06 17:42:13.000000000 +0100
|
||||||
|
@@ -21,6 +21,8 @@
|
||||||
|
#ifndef BOOST_REGEX_SPLIT_HPP
|
||||||
|
#define BOOST_REGEX_SPLIT_HPP
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
namespace boost{
|
||||||
|
|
||||||
|
#ifdef BOOST_HAS_ABI_HEADERS
|
||||||
|
diff -urp boost_1_34_1/boost/regex/v4/states.hpp boost_1_34_1.pm/boost/regex/v4/states.hpp
|
||||||
|
--- boost_1_34_1/boost/regex/v4/states.hpp 2005-09-20 14:01:25.000000000 +0200
|
||||||
|
+++ boost_1_34_1.pm/boost/regex/v4/states.hpp 2008-02-06 17:32:42.000000000 +0100
|
||||||
|
@@ -23,6 +23,8 @@
|
||||||
|
# include BOOST_ABI_PREFIX
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
namespace boost{
|
||||||
|
namespace re_detail{
|
||||||
|
|
||||||
|
diff -urp boost_1_34_1/boost/test/test_tools.hpp boost_1_34_1.pm/boost/test/test_tools.hpp
|
||||||
|
--- boost_1_34_1/boost/test/test_tools.hpp 2007-02-22 18:57:29.000000000 +0100
|
||||||
|
+++ boost_1_34_1.pm/boost/test/test_tools.hpp 2008-02-06 17:18:20.000000000 +0100
|
||||||
|
@@ -44,6 +44,7 @@
|
||||||
|
// STL
|
||||||
|
#include <cstddef> // for std::size_t
|
||||||
|
#include <iosfwd>
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
#include <boost/test/detail/suppress_warnings.hpp>
|
||||||
|
|
||||||
|
diff -urp boost_1_34_1/boost/wave/cpplexer/re2clex/cpp_re2c_lexer.hpp boost_1_34_1.pm/boost/wave/cpplexer/re2clex/cpp_re2c_lexer.hpp
|
||||||
|
--- boost_1_34_1/boost/wave/cpplexer/re2clex/cpp_re2c_lexer.hpp 2006-12-20 17:38:24.000000000 +0100
|
||||||
|
+++ boost_1_34_1.pm/boost/wave/cpplexer/re2clex/cpp_re2c_lexer.hpp 2008-02-06 17:25:00.000000000 +0100
|
||||||
|
@@ -16,6 +16,8 @@
|
||||||
|
#include <string>
|
||||||
|
#include <cstdio>
|
||||||
|
#include <cstdarg>
|
||||||
|
+#include <cstring>
|
||||||
|
+
|
||||||
|
#if defined(BOOST_SPIRIT_DEBUG)
|
||||||
|
#include <iostream>
|
||||||
|
#endif // defined(BOOST_SPIRIT_DEBUG)
|
||||||
|
diff -urp boost_1_34_1/boost/wave/util/flex_string.hpp boost_1_34_1.pm/boost/wave/util/flex_string.hpp
|
||||||
|
--- boost_1_34_1/boost/wave/util/flex_string.hpp 2006-04-25 19:21:01.000000000 +0200
|
||||||
|
+++ boost_1_34_1.pm/boost/wave/util/flex_string.hpp 2008-02-06 17:22:31.000000000 +0100
|
||||||
|
@@ -94,6 +94,7 @@ class StoragePolicy
|
||||||
|
#include <limits>
|
||||||
|
#include <stdexcept>
|
||||||
|
#include <cstddef>
|
||||||
|
+#include <cstring>
|
||||||
|
|
||||||
|
// this must occur after all of the includes and before any code appears
|
||||||
|
#ifdef BOOST_HAS_ABI_HEADERS
|
||||||
|
diff -urp boost_1_34_1/boost/archive/polymorphic_iarchive.hpp boost_1_34_1.pm/boost/archive/polymorphic_iarchive.hpp
|
||||||
|
--- boost_1_34_1/boost/archive/polymorphic_iarchive.hpp 2005-12-11 07:12:51.000000000 +0100
|
||||||
|
+++ boost_1_34_1.pm/boost/archive/polymorphic_iarchive.hpp 2008-02-06 18:42:07.000000000 +0100
|
||||||
|
@@ -33,6 +33,8 @@ namespace std{
|
||||||
|
#include <boost/archive/detail/interface_iarchive.hpp>
|
||||||
|
#include <boost/serialization/nvp.hpp>
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
// determine if its necessary to handle (u)int64_t specifically
|
||||||
|
// i.e. that its not a synonym for (unsigned) long
|
||||||
|
// if there is no 64 bit int or if its the same as a long
|
@ -1,12 +0,0 @@
|
|||||||
diff -urp boost_1_34_1/boost/spirit/phoenix/operators.hpp boost_1_34_1.pm/boost/spirit/phoenix/operators.hpp
|
|
||||||
--- boost_1_34_1/boost/spirit/phoenix/operators.hpp 2006-08-25 18:27:30.000000000 +0200
|
|
||||||
+++ boost_1_34_1.pm/boost/spirit/phoenix/operators.hpp 2008-02-06 16:29:32.000000000 +0100
|
|
||||||
@@ -24,6 +24,7 @@
|
|
||||||
#include <boost/spirit/phoenix/composite.hpp>
|
|
||||||
#include <boost/config.hpp>
|
|
||||||
#include <boost/mpl/if.hpp>
|
|
||||||
+#include <limits.h>
|
|
||||||
|
|
||||||
///////////////////////////////////////////////////////////////////////////////
|
|
||||||
namespace phoenix {
|
|
||||||
Only in boost_1_34_1.pm/boost/spirit/phoenix: operators.hpp~
|
|
18
boost.spec
18
boost.spec
@ -1,7 +1,7 @@
|
|||||||
Name: boost
|
Name: boost
|
||||||
Summary: The Boost C++ Libraries
|
Summary: The Boost C++ Libraries
|
||||||
Version: 1.34.1
|
Version: 1.34.1
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
License: Boost Software License (GPL-Compatible, Free Software License)
|
License: Boost Software License (GPL-Compatible, Free Software License)
|
||||||
URL: http://www.boost.org/
|
URL: http://www.boost.org/
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -26,7 +26,7 @@ Patch1: boost-gcc-soname.patch
|
|||||||
Patch2: boost-use-rpm-optflags.patch
|
Patch2: boost-use-rpm-optflags.patch
|
||||||
Patch3: boost-run-tests.patch
|
Patch3: boost-run-tests.patch
|
||||||
Patch4: boost-regex.patch
|
Patch4: boost-regex.patch
|
||||||
Patch5: boost-phoenix-limits.patch
|
Patch5: boost-gcc43.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Boost provides free peer-reviewed portable C++ source libraries. The
|
Boost provides free peer-reviewed portable C++ source libraries. The
|
||||||
@ -203,8 +203,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc %{_docdir}/boost-%{version}
|
%doc %{_docdir}/boost-%{version}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Feb 6 2008 Petr Machata <pmachata@redhat.com> - 1.34.1-8
|
* Wed Feb 6 2008 Petr Machata <pmachata@redhat.com> - 1.34.1-9
|
||||||
- Add an include to boost/spirit/phoenix/operators.hpp
|
- Fixes for GCC 4.3
|
||||||
- Resolves: #431609
|
- Resolves: #431609
|
||||||
|
|
||||||
* Mon Jan 14 2008 Benjamin Kosnik <bkoz@redhat.com> 1.34.1-7
|
* Mon Jan 14 2008 Benjamin Kosnik <bkoz@redhat.com> 1.34.1-7
|
||||||
@ -248,15 +248,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
Clarified BSL as GPL-Compatible, Free Software License.
|
Clarified BSL as GPL-Compatible, Free Software License.
|
||||||
Remove Obsoletes.
|
Remove Obsoletes.
|
||||||
Add Provides boost-python.
|
Add Provides boost-python.
|
||||||
Remove mkdir -p $RPM_BUILD_ROOT%{_docdir}
|
Remove mkdir -p $RPM_BUILD_ROOT%%{_docdir}
|
||||||
Added periods for decription text.
|
Added periods for decription text.
|
||||||
Fix Group field.
|
Fix Group field.
|
||||||
Remove doc Requires boost.
|
Remove doc Requires boost.
|
||||||
Preserve timestamps on install.
|
Preserve timestamps on install.
|
||||||
Use %defattr(-, root, root, -)
|
Use %%defattr(-, root, root, -)
|
||||||
Added static package for .a libs.
|
Added static package for .a libs.
|
||||||
Install static libs with 0644 permissions.
|
Install static libs with 0644 permissions.
|
||||||
Use %doc for doc files.
|
Use %%doc for doc files.
|
||||||
|
|
||||||
* Mon Jan 22 2007 Benjamin Kosnik <bkoz@redhat.com> 1.34.0-0.5
|
* Mon Jan 22 2007 Benjamin Kosnik <bkoz@redhat.com> 1.34.0-0.5
|
||||||
- Update to boost.RC_1_34_0 snapshot as of 2007-01-19.
|
- Update to boost.RC_1_34_0 snapshot as of 2007-01-19.
|
||||||
@ -265,8 +265,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
threads (regex and thread).
|
threads (regex and thread).
|
||||||
|
|
||||||
* Thu Nov 23 2006 Benjamin Kosnik <bkoz@redhat.com> 1.33.1-10
|
* Thu Nov 23 2006 Benjamin Kosnik <bkoz@redhat.com> 1.33.1-10
|
||||||
- (#182414: boost: put tests in %check section) via Rex Dieter
|
- (#182414: boost: put tests in %%check section) via Rex Dieter
|
||||||
- Fix EVR with %{?dist} tag via Gianluca Sforna
|
- Fix EVR with %%{?dist} tag via Gianluca Sforna
|
||||||
|
|
||||||
* Wed Nov 15 2006 Benjamin Kosnik <bkoz@redhat.com> 1.33.1-9
|
* Wed Nov 15 2006 Benjamin Kosnik <bkoz@redhat.com> 1.33.1-9
|
||||||
- (#154784: boost-debuginfo package is empty)
|
- (#154784: boost-debuginfo package is empty)
|
||||||
|
Loading…
Reference in New Issue
Block a user