Change spec file to use autospec for applying patches
Also renumber the patches from 0-7 since any historical significance of the numbers is already gone from the spec file.
This commit is contained in:
parent
131ff2b1a6
commit
6b80e21fd9
@ -13,8 +13,8 @@ Fixes #29
|
|||||||
|
|
||||||
diff --git a/include/boost/numeric/interval/detail/ppc_rounding_control.hpp b/include/boost/numeric/interval/detail/ppc_rounding_control.hpp
|
diff --git a/include/boost/numeric/interval/detail/ppc_rounding_control.hpp b/include/boost/numeric/interval/detail/ppc_rounding_control.hpp
|
||||||
index 87fe8ee..99f9986 100644
|
index 87fe8ee..99f9986 100644
|
||||||
--- a/include/boost/numeric/interval/detail/ppc_rounding_control.hpp
|
--- boost_1_76_0/boost/numeric/interval/detail/ppc_rounding_control.hpp
|
||||||
+++ b/include/boost/numeric/interval/detail/ppc_rounding_control.hpp
|
+++ boost_1_76_0/boost/numeric/interval/detail/ppc_rounding_control.hpp
|
||||||
@@ -28,10 +28,10 @@ typedef union {
|
@@ -28,10 +28,10 @@ typedef union {
|
||||||
double dmode;
|
double dmode;
|
||||||
} rounding_mode_struct;
|
} rounding_mode_struct;
|
||||||
|
29
boost.spec
29
boost.spec
@ -42,7 +42,7 @@ Name: boost
|
|||||||
%global real_name boost
|
%global real_name boost
|
||||||
Summary: The free peer-reviewed portable C++ source libraries
|
Summary: The free peer-reviewed portable C++ source libraries
|
||||||
Version: 1.81.0
|
Version: 1.81.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: Boost and MIT and Python
|
License: Boost and MIT and Python
|
||||||
|
|
||||||
# Replace each . with _ in %%{version}
|
# Replace each . with _ in %%{version}
|
||||||
@ -128,29 +128,29 @@ BuildRequires: bison
|
|||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
||||||
Patch111: boost-1.81.0-build-optflags.patch
|
Patch0: boost-1.81.0-build-optflags.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1318383
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1318383
|
||||||
Patch106: boost-1.78.0-no-rpath.patch
|
Patch1: boost-1.78.0-no-rpath.patch
|
||||||
|
|
||||||
# https://lists.boost.org/Archives/boost/2020/04/248812.php
|
# https://lists.boost.org/Archives/boost/2020/04/248812.php
|
||||||
Patch88: boost-1.73.0-cmakedir.patch
|
Patch2: boost-1.73.0-cmakedir.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
||||||
Patch107: boost-1.78.0-b2-build-flags.patch
|
Patch3: boost-1.78.0-b2-build-flags.patch
|
||||||
|
|
||||||
# https://github.com/boostorg/random/issues/82
|
# https://github.com/boostorg/random/issues/82
|
||||||
Patch102: boost-1.76.0-random-test.patch
|
Patch4: boost-1.76.0-random-test.patch
|
||||||
|
|
||||||
# PR https://github.com/boostorg/interval/pull/30
|
# PR https://github.com/boostorg/interval/pull/30
|
||||||
# Fixes narrowing conversions for ppc -
|
# Fixes narrowing conversions for ppc -
|
||||||
# https://github.com/boostorg/interval/issues/29
|
# https://github.com/boostorg/interval/issues/29
|
||||||
Patch104: boost-1.76.0-fix-narrowing-conversions-for-ppc.patch
|
Patch5: boost-1.76.0-fix-narrowing-conversions-for-ppc.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2178210
|
# https://bugzilla.redhat.com/show_bug.cgi?id=2178210
|
||||||
# https://github.com/boostorg/phoenix/issues/111
|
# https://github.com/boostorg/phoenix/issues/111
|
||||||
# https://github.com/boostorg/phoenix/issues/115
|
# https://github.com/boostorg/phoenix/issues/115
|
||||||
Patch112: boost-1.81-phoenix-multiple-defn.patch
|
Patch6: boost-1.81-phoenix-multiple-defn.patch
|
||||||
|
|
||||||
%bcond_with tests
|
%bcond_with tests
|
||||||
%bcond_with docs_generated
|
%bcond_with docs_generated
|
||||||
@ -659,17 +659,9 @@ Historically, B2 was based on on FTJam and on Perforce Jam but has grown
|
|||||||
a number of significant features and is now developed independently.
|
a number of significant features and is now developed independently.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{toplev_dirname}
|
%autosetup -n %{toplev_dirname} -p1
|
||||||
find ./boost -name '*.hpp' -perm /111 | xargs --no-run-if-empty chmod a-x
|
find ./boost -name '*.hpp' -perm /111 | xargs --no-run-if-empty chmod a-x
|
||||||
|
|
||||||
%patch111 -p1
|
|
||||||
%patch106 -p1
|
|
||||||
%patch107 -p1
|
|
||||||
%patch88 -p1
|
|
||||||
%patch102 -p1
|
|
||||||
%patch104 -p2
|
|
||||||
%patch112 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%set_build_flags
|
%set_build_flags
|
||||||
# Dump the versions being used into the build logs.
|
# Dump the versions being used into the build logs.
|
||||||
@ -1283,6 +1275,9 @@ fi
|
|||||||
%{_mandir}/man1/b2.1*
|
%{_mandir}/man1/b2.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 15 2023 Jonathan Wakely <jwakely@fedoraproject.org> - 1.81.0-2
|
||||||
|
- Change spec file to use autospec for applying patches
|
||||||
|
|
||||||
* Wed Mar 15 2023 Jonathan Wakely <jwakely@fedoraproject.org> - 1.81.0-1
|
* Wed Mar 15 2023 Jonathan Wakely <jwakely@fedoraproject.org> - 1.81.0-1
|
||||||
- Add patch for Boost.Phoenix bugs (#2178210)
|
- Add patch for Boost.Phoenix bugs (#2178210)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user