Rebase to 1.78.0
See https://fedoraproject.org/wiki/Changes/F37Boost178 Drop patches: deleted: boost-1.75.0-build-optflags.patch deleted: boost-1.75.0-no-rpath.patch deleted: boost-1.76.0-b2-build-flags.patch deleted: boost-1.76.0-fix-include-inside-boost-namespace.patch deleted: boost-1.76.0-fix-duplicate-typedef-in-mp.patch Fix silent dropping of some libraries See https://github.com/bfgroup/b2/pull/113
This commit is contained in:
parent
9c645e2838
commit
5827653083
@ -1,25 +0,0 @@
|
||||
From 5dde5a5a3c12dd8f52cb61ba220ec221ecfa98f0 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Rodgers <rodgert@twrodgers.com>
|
||||
Date: Thu, 29 Jul 2021 10:15:37 -0700
|
||||
Subject: [PATCH] Use options from RPM for release builds with GCC
|
||||
|
||||
---
|
||||
tools/build/src/engine/build.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/build/src/engine/build.sh b/tools/build/src/engine/build.sh
|
||||
index 58f41cb4a..f85040f99 100755
|
||||
--- a/tools/build/src/engine/build.sh
|
||||
+++ b/tools/build/src/engine/build.sh
|
||||
@@ -325,7 +325,7 @@ case "${B2_TOOLSET}" in
|
||||
B2_CXX="${B2_CXX} -pthread"
|
||||
;;
|
||||
esac
|
||||
- B2_CXXFLAGS_RELEASE="-O2 -s"
|
||||
+ B2_CXXFLAGS_RELEASE="${RPM_OPT_FLAGS} ${RPM_LD_FLAGS}"
|
||||
B2_CXXFLAGS_DEBUG="-O0 -g"
|
||||
;;
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 62fcbde69aae70af24a51cb6582a2a95f65441c2 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Rodgers <rodgert@twrodgers.com>
|
||||
Date: Wed, 4 Aug 2021 13:22:35 -0700
|
||||
Subject: [PATCH] Fix duplicate typedef in mp.hpp [#671]
|
||||
|
||||
https://github.com/boostorg/math/pull/671
|
||||
---
|
||||
boost/math/tools/mp.hpp | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/boost/math/tools/mp.hpp b/boost/math/tools/mp.hpp
|
||||
index dc8440988..3100a0bb6 100644
|
||||
--- a/boost/math/tools/mp.hpp
|
||||
+++ b/boost/math/tools/mp.hpp
|
||||
@@ -426,9 +426,6 @@ struct make_integer_sequence_impl
|
||||
template<typename T, T N>
|
||||
using make_integer_sequence = typename detail::make_integer_sequence_impl<T, N>::type;
|
||||
|
||||
-template<std::size_t... I>
|
||||
-using index_sequence = integer_sequence<std::size_t, I...>;
|
||||
-
|
||||
template<std::size_t N>
|
||||
using make_index_sequence = make_integer_sequence<std::size_t, N>;
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,33 +0,0 @@
|
||||
From f6818a161d3f835d246aceea0804243c887ac10b Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Rodgers <rodgert@twrodgers.com>
|
||||
Date: Wed, 4 Aug 2021 13:09:57 -0700
|
||||
Subject: [PATCH] Fix include inside boost namespace [#670]
|
||||
|
||||
https://github.com/boostorg/math/pull/670/commits/1ec5c98d80de97f9e962c5627e1a0e6096099894
|
||||
---
|
||||
boost/math/tools/mp.hpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/boost/math/tools/mp.hpp b/boost/math/tools/mp.hpp
|
||||
index 35565646f..dc8440988 100644
|
||||
--- a/boost/math/tools/mp.hpp
|
||||
+++ b/boost/math/tools/mp.hpp
|
||||
@@ -13,6 +13,7 @@
|
||||
|
||||
#include <type_traits>
|
||||
#include <cstddef>
|
||||
+#include <utility>
|
||||
|
||||
namespace boost { namespace math { namespace tools { namespace meta_programming {
|
||||
|
||||
@@ -338,7 +339,6 @@ using mp_remove_if_q = mp_remove_if<L, Q::template fn>;
|
||||
// Index sequence
|
||||
// Use C++14 index sequence if available
|
||||
#if defined(__cpp_lib_integer_sequence) && (__cpp_lib_integer_sequence >= 201304)
|
||||
-#include <utility>
|
||||
template<std::size_t... I>
|
||||
using index_sequence = std::index_sequence<I...>;
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
25
boost-1.78.0-b2-build-flags.patch
Normal file
25
boost-1.78.0-b2-build-flags.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 1ded9b9c219542442b3c10af815e5413a2a89c75 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas W Rodgers <trodgers@redhat.com>
|
||||
Date: Tue, 1 Mar 2022 10:03:34 -0800
|
||||
Subject: [PATCH] Adjust b2 build flags for Fedora Packaging
|
||||
|
||||
---
|
||||
src/engine/build.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/build/src/engine/build.sh b/tools/build/src/engine/build.sh
|
||||
index f1ad08cb..ab58deba 100755
|
||||
--- a/tools/build/src/engine/build.sh
|
||||
+++ b/tools/build/src/engine/build.sh
|
||||
@@ -323,7 +323,7 @@ case "${B2_TOOLSET}" in
|
||||
|
||||
gcc|gcc-*)
|
||||
CXX_VERSION_OPT=${CXX_VERSION_OPT:---version}
|
||||
- B2_CXXFLAGS_RELEASE="-O2 -s"
|
||||
+ B2_CXXFLAGS_RELEASE="${RPM_OPT_FLAGS} ${RPM_LD_FLAGS}"
|
||||
B2_CXXFLAGS_DEBUG="-O0 -g"
|
||||
;;
|
||||
|
||||
--
|
||||
2.35.1
|
||||
|
@ -1,26 +1,34 @@
|
||||
From 739edb2889cb63c281a3597e712988a40bc82829 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas W Rodgers <rodgert@twrodgers.com>
|
||||
Date: Mon, 28 Feb 2022 20:55:14 -0800
|
||||
Subject: [PATCH 1/3] Adjust options for Fedora package build
|
||||
|
||||
---
|
||||
src/tools/gcc.jam | 31 ++++++++++++++++---------------
|
||||
1 file changed, 16 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/tools/build/src/tools/gcc.jam b/tools/build/src/tools/gcc.jam
|
||||
index ff3209f7b..1d8e7cbfe 100644
|
||||
index 47a11322..543cfd84 100644
|
||||
--- a/tools/build/src/tools/gcc.jam
|
||||
+++ b/tools/build/src/tools/gcc.jam
|
||||
@@ -577,7 +577,7 @@ rule compile.fortran ( targets * : sources * : properties * )
|
||||
@@ -510,7 +510,7 @@ rule compile.fortran ( targets * : sources * : properties * )
|
||||
|
||||
actions compile.c++ bind PCH_FILE
|
||||
{
|
||||
- "$(CONFIG_COMMAND)" $(LANG) -ftemplate-depth-$(TEMPLATE_DEPTH) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(PCH_FILE:D)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" -c -o "$(<:W)" "$(>:W)"
|
||||
+ "$(CONFIG_COMMAND)" $(LANG) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(PCH_FILE:D)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" -c -o "$(<:W)" "$(>:W)"
|
||||
- "$(CONFIG_COMMAND)" $(LANG) -ftemplate-depth-$(TEMPLATE_DEPTH) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" -c -o "$(<:W)" "$(>:W)"
|
||||
+ "$(CONFIG_COMMAND)" $(LANG) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" -c -o "$(<:W)" "$(>:W)"
|
||||
}
|
||||
|
||||
actions compile.c bind PCH_FILE
|
||||
@@ -587,7 +587,7 @@ actions compile.c bind PCH_FILE
|
||||
|
||||
@@ -521,6 +521,7 @@ actions compile.c bind PCH_FILE
|
||||
actions compile.c++.preprocess bind PCH_FILE
|
||||
{
|
||||
- "$(CONFIG_COMMAND)" $(LANG) -ftemplate-depth-$(TEMPLATE_DEPTH) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(PCH_FILE:D)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
+ "$(CONFIG_COMMAND)" $(LANG) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(PCH_FILE:D)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
"$(CONFIG_COMMAND)" $(LANG) -ftemplate-depth-$(TEMPLATE_DEPTH) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
++ "$(CONFIG_COMMAND)" $(LANG) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" $(PCH_FILE:D)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
}
|
||||
|
||||
actions compile.c.preprocess bind PCH_FILE
|
||||
@@ -704,20 +704,20 @@ actions compile.c.pch
|
||||
@@ -623,20 +624,20 @@ actions compile.c.pch
|
||||
###
|
||||
|
||||
# Declare flags and action for compilation.
|
||||
@ -56,5 +64,5 @@ index ff3209f7b..1d8e7cbfe 100644
|
||||
toolset.flags gcc.compile OPTIONS <debug-symbols>on : -g ;
|
||||
toolset.flags gcc.compile OPTIONS <profiling>on : -pg ;
|
||||
--
|
||||
2.26.2
|
||||
2.35.1
|
||||
|
72
boost-1.78.0-fix-b2-staging.patch
Normal file
72
boost-1.78.0-fix-b2-staging.patch
Normal file
@ -0,0 +1,72 @@
|
||||
From 78fd284a42caabe8815cb0870b46e5567872e75b Mon Sep 17 00:00:00 2001
|
||||
From: Dmitry <grisumbras@gmail.com>
|
||||
Date: Sat, 11 Dec 2021 16:58:23 +0300
|
||||
Subject: [PATCH] Don't skip install targets if there's <build>no in ureqs
|
||||
(#113)
|
||||
|
||||
---
|
||||
src/tools/stage.jam | 4 ++++
|
||||
test/install_build_no.py | 26 ++++++++++++++++++++++++++
|
||||
test/test_all.py | 1 +
|
||||
3 files changed, 31 insertions(+)
|
||||
create mode 100755 test/install_build_no.py
|
||||
|
||||
diff --git a/tools/build/src/tools/stage.jam b/tools/build/src/tools/stage.jam
|
||||
index c5f02e3ba4..325129dc81 100644
|
||||
--- a/tools/build/src/tools/stage.jam
|
||||
+++ b/tools/build/src/tools/stage.jam
|
||||
@@ -478,6 +478,10 @@ class install-target-class : basic-target
|
||||
return [ sequence.unique $(result2) ] ;
|
||||
}
|
||||
|
||||
+ rule skip-from-usage-requirements ( )
|
||||
+ {
|
||||
+ }
|
||||
+
|
||||
# Returns true iff 'type' is subtype of some element of 'types-to-include'.
|
||||
#
|
||||
local rule include-type ( type : types-to-include * )
|
||||
diff --git a/tools/build/test/install_build_no.py b/tools/build/test/install_build_no.py
|
||||
new file mode 100755
|
||||
index 0000000000..0ccf3c5cc6
|
||||
--- /dev/null
|
||||
+++ b/tools/build/test/install_build_no.py
|
||||
@@ -0,0 +1,26 @@
|
||||
+#!/usr/bin/python
|
||||
+
|
||||
+# Copyright 2021 Dmitry Arkhipov (grisumbras@gmail.com)
|
||||
+# Distributed under the Boost Software License, Version 1.0.
|
||||
+# (See accompanying file LICENSE.txt or https://www.bfgroup.xyz/b2/LICENSE.txt)
|
||||
+
|
||||
+# Check that <build>no in usage-requirements of dependencies does not affect
|
||||
+# install rule, i.e. a skipped installed target does not affect insallation of
|
||||
+# other targets.
|
||||
+
|
||||
+import BoostBuild
|
||||
+
|
||||
+t = BoostBuild.Tester()
|
||||
+
|
||||
+t.write("a.cpp", "int main() {}\n")
|
||||
+
|
||||
+t.write("jamroot.jam", """
|
||||
+make x : : maker : <build>no ;
|
||||
+exe a : a.cpp ;
|
||||
+install install : x a ;
|
||||
+""")
|
||||
+
|
||||
+t.run_build_system()
|
||||
+t.expect_addition("install/a.exe")
|
||||
+
|
||||
+t.cleanup()
|
||||
diff --git a/tools/build/test/test_all.py b/tools/build/test/test_all.py
|
||||
index b7ef5ad701..9ed729d017 100644
|
||||
--- a/tools/build/test/test_all.py
|
||||
+++ b/tools/build/test/test_all.py
|
||||
@@ -250,6 +250,7 @@ def reorder_tests(tests, first_test):
|
||||
"inherit_toolset",
|
||||
"inherited_dependency",
|
||||
"inline",
|
||||
+ "install_build_no",
|
||||
"libjpeg",
|
||||
"liblzma",
|
||||
"libpng",
|
@ -1,20 +1,23 @@
|
||||
From 25e4220a4564a3f8ec22607fcdbee90c81f040d6 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas W Rodgers <trodgers@redhat.com>
|
||||
Date: Mon, 28 Feb 2022 21:24:07 -0800
|
||||
Subject: [PATCH 2/3] Adjust options to remove RPATH for Fedora package builds
|
||||
|
||||
---
|
||||
src/tools/gcc.jam | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/tools/build/src/tools/gcc.jam b/tools/build/src/tools/gcc.jam
|
||||
index 02dc154cf..c076f70f4 100644
|
||||
index 543cfd84..fd213ccb 100644
|
||||
--- a/tools/build/src/tools/gcc.jam
|
||||
+++ b/tools/build/src/tools/gcc.jam
|
||||
@@ -1132,17 +1132,17 @@ actions link.mingw bind LIBRARIES
|
||||
|
||||
actions link.dll.mingw bind LIBRARIES
|
||||
{
|
||||
- "$(CONFIG_COMMAND)" -L"$(LINKPATH)" "$(.IMPLIB-COMMAND)$(<[1])" -o "$(<[-1])" -shared @"@($(<[-1]:T).rsp:E=$(START-GROUP) "$(>:T)" "$(LIBRARIES:T)" $(FINDLIBS-ST-PFX:T) -l$(FINDLIBS-ST:T) $(FINDLIBS-SA-PFX:T) -l$(FINDLIBS-SA:T) $(END-GROUP))" $(OPTIONS) $(USER_OPTIONS)
|
||||
+ "$(CONFIG_COMMAND)" -L"$(LINKPATH)" "$(.IMPLIB-COMMAND)$(<[0])" -o "$(<[-1])" -shared @"@($(<[-1]:T).rsp:E=$(START-GROUP) "$(>:T)" "$(LIBRARIES:T)" $(FINDLIBS-ST-PFX:T) -l$(FINDLIBS-ST:T) $(FINDLIBS-SA-PFX:T) -l$(FINDLIBS-SA:T) $(END-GROUP))" $(OPTIONS) $(USER_OPTIONS)
|
||||
}
|
||||
@@ -1045,12 +1045,11 @@ actions link.dll.mingw bind LIBRARIES
|
||||
|
||||
actions link bind LIBRARIES
|
||||
{
|
||||
- "$(CONFIG_COMMAND)" -L"$(LINKPATH)" -Wl,$(RPATH_OPTION:E=-R)$(SPACE)-Wl,$(RPATH) -Wl,-rpath-link$(SPACE)-Wl,"$(RPATH_LINK)" -o "$(<)" $(START-GROUP) "$(>)" "$(LIBRARIES)" $(FINDLIBS-ST-PFX) -l$(FINDLIBS-ST) $(FINDLIBS-SA-PFX) -l$(FINDLIBS-SA) $(END-GROUP) $(OPTIONS) $(USER_OPTIONS)
|
||||
+ "$(CONFIG_COMMAND)" -L"$(LINKPATH)" -o "$(<)" $(START-GROUP) "$(>)" "$(LIBRARIES)" $(FINDLIBS-ST-PFX) -l$(FINDLIBS-ST) $(FINDLIBS-SA-PFX) -l$(FINDLIBS-SA) $(END-GROUP) $(OPTIONS) $(USER_OPTIONS)
|
||||
}
|
||||
-}
|
||||
+ "$(CONFIG_COMMAND)" -L"$(LINKPATH)" -o "$(<)" $(START-GROUP) "$(>)" "$(LIBRARIES)" $(FINDLIBS-ST-PFX) -l$(FINDLIBS-ST) $(FINDLIBS-SA-PFX) -l$(FINDLIBS-SA) $(END-GROUP) $(OPTIONS) $(USER_OPTIONS)}
|
||||
|
||||
actions link.dll bind LIBRARIES
|
||||
{
|
||||
@ -23,3 +26,6 @@ index 02dc154cf..c076f70f4 100644
|
||||
}
|
||||
|
||||
###
|
||||
--
|
||||
2.35.1
|
||||
|
55
boost.spec
55
boost.spec
@ -41,8 +41,8 @@
|
||||
Name: boost
|
||||
%global real_name boost
|
||||
Summary: The free peer-reviewed portable C++ source libraries
|
||||
Version: 1.76.0
|
||||
Release: 13%{?dist}
|
||||
Version: 1.78.0
|
||||
Release: 0%{?dist}
|
||||
License: Boost and MIT and Python
|
||||
|
||||
# Replace each . with _ in %%{version}
|
||||
@ -54,6 +54,7 @@ License: Boost and MIT and Python
|
||||
%global toplev_dirname %{real_name}_%{version_enc}
|
||||
URL: http://www.boost.org
|
||||
|
||||
# https://boostorg.jfrog.io/artifactory/main/release/1.78.0/source/boost_1_78_0.tar.bz2
|
||||
Source0: https://boostorg.jfrog.io/artifactory/main/release/%{version}/source/%{name}_%{version_enc}.tar.bz2
|
||||
Source1: libboost_thread.so
|
||||
# Add a manual page for b2, based on the online documentation:
|
||||
@ -134,10 +135,10 @@ Patch15: boost-1.58.0-pool.patch
|
||||
Patch51: boost-1.58.0-pool-test_linking.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
||||
Patch96: boost-1.75.0-build-optflags.patch
|
||||
Patch105: boost-1.78.0-build-optflags.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1318383
|
||||
Patch97: boost-1.75.0-no-rpath.patch
|
||||
Patch106: boost-1.78.0-no-rpath.patch
|
||||
|
||||
# https://lists.boost.org/Archives/boost/2020/04/248812.php
|
||||
Patch88: boost-1.73.0-cmakedir.patch
|
||||
@ -146,18 +147,8 @@ Patch88: boost-1.73.0-cmakedir.patch
|
||||
# https://github.com/boostorg/locale/issues/52
|
||||
Patch94: boost-1.73-locale-empty-vector.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1958382
|
||||
# https://github.com/boostorg/graph/pull/218
|
||||
Patch98: boost-1.75.0-remove-deprecated-boost-iterator.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
||||
Patch99: boost-1.76.0-b2-build-flags.patch
|
||||
|
||||
# https://github.com/boostorg/math/pull/670
|
||||
Patch100: boost-1.76.0-fix-include-inside-boost-namespace.patch
|
||||
|
||||
# https://github.com/boostorg/math/pull/671
|
||||
Patch101: boost-1.76.0-fix-duplicate-typedef-in-mp.patch
|
||||
Patch107: boost-1.78.0-b2-build-flags.patch
|
||||
|
||||
# https://github.com/boostorg/random/issues/82
|
||||
Patch102: boost-1.76.0-random-test.patch
|
||||
@ -172,10 +163,14 @@ Patch103: boost-1.76.0-fix_multiprecision_issue_419-ppc64le.patch
|
||||
Patch104: boost-1.76.0-fix-narrowing-conversions-for-ppc.patch
|
||||
|
||||
# https://github.com/boostorg/ptr_container/pull/27
|
||||
Patch105: boost-1.76.0-ptr_cont-xml.patch
|
||||
Patch108: boost-1.76.0-ptr_cont-xml.patch
|
||||
|
||||
# Fixes missing libboost_fiber.so
|
||||
# https://github.com/boostorg/boost/issues/632
|
||||
Patch109: boost-1.78.0-fix-b2-staging.patch
|
||||
|
||||
# https://github.com/boostorg/python/pull/385
|
||||
Patch106: boost-1.76.0-enum_type_object-type-python-3.11.patch
|
||||
Patch110: boost-1.76.0-enum_type_object-type-python-3.11.patch
|
||||
|
||||
%bcond_with tests
|
||||
%bcond_with docs_generated
|
||||
@ -692,19 +687,17 @@ find ./boost -name '*.hpp' -perm /111 | xargs chmod a-x
|
||||
|
||||
%patch15 -p0
|
||||
%patch51 -p1
|
||||
%patch96 -p1
|
||||
%patch97 -p1
|
||||
%patch99 -p1
|
||||
%patch105 -p1
|
||||
%patch106 -p1
|
||||
%patch107 -p1
|
||||
%patch88 -p1
|
||||
%patch94 -p1
|
||||
%patch98 -p1
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
%patch103 -p2
|
||||
%patch104 -p2
|
||||
%patch105 -p1
|
||||
%patch106 -p1
|
||||
%patch108 -p1
|
||||
%patch109 -p1
|
||||
%patch110 -p1
|
||||
|
||||
%build
|
||||
%set_build_flags
|
||||
@ -1306,6 +1299,18 @@ fi
|
||||
%{_mandir}/man1/b2.1*
|
||||
|
||||
%changelog
|
||||
* Fri Apr 29 2022 Thomas Rodgers <trodgers@redhat.com> - 1.78.0-0
|
||||
- Rebase to 1.78.0
|
||||
See https://fedoraproject.org/wiki/Changes/F37Boost178
|
||||
- Drop patches:
|
||||
deleted: boost-1.75.0-build-optflags.patch
|
||||
deleted: boost-1.75.0-no-rpath.patch
|
||||
deleted: boost-1.76.0-b2-build-flags.patch
|
||||
deleted: boost-1.76.0-fix-include-inside-boost-namespace.patch
|
||||
deleted: boost-1.76.0-fix-duplicate-typedef-in-mp.patch
|
||||
- Fix silent dropping of some libraries
|
||||
See https://github.com/bfgroup/b2/pull/113
|
||||
|
||||
* Wed Apr 27 2022 Thomas Rodgers <trodgers@redhat.com> - 1.76.0-13
|
||||
- Add missing boost-1.76.0-enum_type_object-type-python-3.11.patch file
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (boost_1_76_0.tar.bz2) = 5d68bed98c57e03b4cb2420d9b856e5f0669561a6142a4b0c9c8a58dc5b6b28e16ccbb16ac559c3a3198c45769a246bf996b96cb7b6a019dd15f05c2270e9429
|
||||
SHA512 (boost_1_78_0.tar.bz2) = 9c34a387a203b99aa773eb0c59f5abac7a99ba10e4623653e793c1d5b29b99b88e0e4e0d4e2e4ca5d497c42f2e46e23bab66417722433a457dc818d7670bcbbf
|
||||
|
Loading…
Reference in New Issue
Block a user