Use correct sources for release, not a snapshot
Also add -Wno-deprecated-declarations to build flags to silence hundreds of warnings about std::auto_ptr.
This commit is contained in:
parent
b9ad2bf8a2
commit
51c6915fb4
@ -1,114 +0,0 @@
|
||||
commit babaa35f51d8b009eba762bc50a5290906b4b0ca
|
||||
Author: Jonathan Wakely <jwakely@redhat.com>
|
||||
Date: Thu Jan 26 20:15:19 2017 +0000
|
||||
|
||||
Replace boost::serialization::detail::get_data function.
|
||||
|
||||
diff --git a/include/boost/mpi/detail/mpi_datatype_primitive.hpp b/include/boost/mpi/detail/mpi_datatype_primitive.hpp
|
||||
index c230055..b95fc38 100644
|
||||
--- a/include/boost/mpi/detail/mpi_datatype_primitive.hpp
|
||||
+++ b/include/boost/mpi/detail/mpi_datatype_primitive.hpp
|
||||
@@ -25,7 +25,6 @@ namespace std{
|
||||
#include <boost/assert.hpp>
|
||||
#include <boost/mpl/placeholders.hpp>
|
||||
#include <boost/serialization/array.hpp>
|
||||
-#include <boost/serialization/detail/get_data.hpp>
|
||||
#include <stdexcept>
|
||||
#include <iostream>
|
||||
#include <vector>
|
||||
@@ -80,18 +79,18 @@ public:
|
||||
BOOST_MPI_CHECK_RESULT(MPI_Type_create_struct,
|
||||
(
|
||||
addresses.size(),
|
||||
- boost::serialization::detail::get_data(lengths),
|
||||
- boost::serialization::detail::get_data(addresses),
|
||||
- boost::serialization::detail::get_data(types),
|
||||
+ get_data(lengths),
|
||||
+ get_data(addresses),
|
||||
+ get_data(types),
|
||||
&datatype_
|
||||
));
|
||||
#else
|
||||
BOOST_MPI_CHECK_RESULT(MPI_Type_struct,
|
||||
(
|
||||
addresses.size(),
|
||||
- boost::serialization::detail::get_data(lengths),
|
||||
- boost::serialization::detail::get_data(addresses),
|
||||
- boost::serialization::detail::get_data(types),
|
||||
+ get_data(lengths),
|
||||
+ get_data(addresses),
|
||||
+ get_data(types),
|
||||
&datatype_
|
||||
));
|
||||
#endif
|
||||
@@ -129,6 +128,12 @@ private:
|
||||
lengths.push_back(l);
|
||||
}
|
||||
|
||||
+ template <class T>
|
||||
+ static T* get_data(std::vector<T>& v)
|
||||
+ {
|
||||
+ return v.empty() ? 0 : &(v[0]);
|
||||
+ }
|
||||
+
|
||||
std::vector<MPI_Aint> addresses;
|
||||
std::vector<MPI_Datatype> types;
|
||||
std::vector<int> lengths;
|
||||
diff --git a/include/boost/mpi/detail/packed_iprimitive.hpp b/include/boost/mpi/detail/packed_iprimitive.hpp
|
||||
index 7080cbf..227dc8e 100644
|
||||
--- a/include/boost/mpi/detail/packed_iprimitive.hpp
|
||||
+++ b/include/boost/mpi/detail/packed_iprimitive.hpp
|
||||
@@ -16,7 +16,6 @@
|
||||
#include <boost/mpi/exception.hpp>
|
||||
#include <boost/assert.hpp>
|
||||
#include <boost/serialization/array.hpp>
|
||||
-#include <boost/serialization/detail/get_data.hpp>
|
||||
#include <vector>
|
||||
#include <boost/mpi/allocator.hpp>
|
||||
|
||||
@@ -104,7 +103,12 @@ private:
|
||||
void load_impl(void * p, MPI_Datatype t, int l)
|
||||
{
|
||||
BOOST_MPI_CHECK_RESULT(MPI_Unpack,
|
||||
- (const_cast<char*>(boost::serialization::detail::get_data(buffer_)), buffer_.size(), &position, p, l, t, comm));
|
||||
+ (get_data(buffer_), buffer_.size(), &position, p, l, t, comm));
|
||||
+ }
|
||||
+
|
||||
+ static buffer_type::value_type* get_data(buffer_type& b)
|
||||
+ {
|
||||
+ return b.empty() ? 0 : &(b[0]);
|
||||
}
|
||||
|
||||
buffer_type & buffer_;
|
||||
diff --git a/include/boost/mpi/detail/packed_oprimitive.hpp b/include/boost/mpi/detail/packed_oprimitive.hpp
|
||||
index fbcde9a..3c81a70 100644
|
||||
--- a/include/boost/mpi/detail/packed_oprimitive.hpp
|
||||
+++ b/include/boost/mpi/detail/packed_oprimitive.hpp
|
||||
@@ -15,7 +15,6 @@
|
||||
|
||||
#include <boost/mpi/datatype.hpp>
|
||||
#include <boost/mpi/exception.hpp>
|
||||
-#include <boost/serialization/detail/get_data.hpp>
|
||||
#include <boost/serialization/array.hpp>
|
||||
#include <boost/assert.hpp>
|
||||
#include <vector>
|
||||
@@ -103,13 +102,18 @@ private:
|
||||
|
||||
// pack the data into the buffer
|
||||
BOOST_MPI_CHECK_RESULT(MPI_Pack,
|
||||
- (const_cast<void*>(p), l, t, boost::serialization::detail::get_data(buffer_), buffer_.size(), &position, comm));
|
||||
+ (const_cast<void*>(p), l, t, get_data(buffer_), buffer_.size(), &position, comm));
|
||||
// reduce the buffer size if needed
|
||||
BOOST_ASSERT(std::size_t(position) <= buffer_.size());
|
||||
if (std::size_t(position) < buffer_.size())
|
||||
buffer_.resize(position);
|
||||
}
|
||||
|
||||
+ static buffer_type::value_type* get_data(buffer_type& b)
|
||||
+ {
|
||||
+ return b.empty() ? 0 : &(b[0]);
|
||||
+ }
|
||||
+
|
||||
buffer_type& buffer_;
|
||||
mutable std::size_t size_;
|
||||
MPI_Comm comm;
|
@ -1,18 +0,0 @@
|
||||
commit cfc7c8306a61ed84255973ad93aa4322f86a811a
|
||||
Author: Jonathan Wakely <jwakely@redhat.com>
|
||||
Date: Thu Jan 26 21:52:37 2017 +0000
|
||||
|
||||
Add header for serialization::make_array
|
||||
|
||||
diff --git a/include/boost/mpi/python/serialize.hpp b/include/boost/mpi/python/serialize.hpp
|
||||
index 5f9136b..8933b34 100644
|
||||
--- a/include/boost/mpi/python/serialize.hpp
|
||||
+++ b/include/boost/mpi/python/serialize.hpp
|
||||
@@ -36,6 +36,7 @@
|
||||
|
||||
#include <boost/serialization/split_free.hpp>
|
||||
#include <boost/serialization/array.hpp>
|
||||
+#include <boost/serialization/array_wrapper.hpp>
|
||||
|
||||
#include <boost/assert.hpp>
|
||||
|
17
boost.spec
17
boost.spec
@ -38,14 +38,14 @@ Name: boost
|
||||
Summary: The free peer-reviewed portable C++ source libraries
|
||||
Version: 1.63.0
|
||||
%global version_enc 1_63_0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: Boost and MIT and Python
|
||||
|
||||
%global toplev_dirname %{name}_%{version_enc}
|
||||
URL: http://www.boost.org
|
||||
Group: System Environment/Libraries
|
||||
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{toplev_dirname}.tar.bz2
|
||||
Source0: https://sourceforge.net/projects/boost/files/boost/%{version}/%{toplev_dirname}.tar.bz2
|
||||
Source1: ver.py
|
||||
Source2: libboost_thread.so
|
||||
|
||||
@ -130,11 +130,6 @@ Patch68: boost-1.58.0-address-model.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1318383
|
||||
Patch82: boost-1.60.0-no-rpath.patch
|
||||
|
||||
# https://github.com/boostorg/mpi/pull/39
|
||||
Patch83: boost-1.63.0-mpi-getdata.patch
|
||||
# https://github.com/boostorg/mpi/pull/40
|
||||
Patch84: boost-1.63.0-mpi-serialize.patch
|
||||
|
||||
%bcond_with tests
|
||||
%bcond_with docs_generated
|
||||
|
||||
@ -654,8 +649,6 @@ a number of significant features and is now developed independently
|
||||
%patch65 -p1
|
||||
%patch68 -p1
|
||||
%patch82 -p0
|
||||
%patch83 -p2
|
||||
%patch84 -p2
|
||||
|
||||
# At least python2_version needs to be a macro so that it's visible in
|
||||
# %%install as well.
|
||||
@ -675,7 +668,7 @@ a number of significant features and is now developed independently
|
||||
# There are many strict aliasing warnings, and it's not feasible to go
|
||||
# through them all at this time.
|
||||
# There are also lots of noisy but harmless unused local typedef warnings.
|
||||
export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-unused-local-typedefs"
|
||||
export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-unused-local-typedefs -Wno-deprecated-declarations"
|
||||
|
||||
cat > ./tools/build/src/user-config.jam << "EOF"
|
||||
import os ;
|
||||
@ -1299,6 +1292,10 @@ fi
|
||||
%{_mandir}/man1/bjam.1*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 27 2017 Jonathan Wakely <jwakely@redhat.com> - 1.63.0-2
|
||||
- Use correct sources for release, not a snapshot.
|
||||
- Add -Wno-deprecated-declarations to build flags.
|
||||
|
||||
* Thu Jan 26 2017 Jonathan Wakely <jwakely@redhat.com> - 1.63.0-1
|
||||
- Rebase to 1.63.0 (#1401431)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (boost_1_63_0.tar.bz2) = 6423191392a26345a4fcea84dc3ce5b7fb79c6b06c91fa2e84b3064b7ce8512ada0e51fca8e2b102e672c709db04754499a4df9710727b531d0fee8b6f86485c
|
||||
SHA512 (boost_1_63_0.tar.bz2) = c915c5f5778dee49b8e9d0a40f37f90f56fb1fdb1d8ce92d97bf48bc7bc462212487badfe4bbe30b06196d1149cfb221da12ac54e97499b0d4cb6466813bb4ad
|
||||
|
Loading…
Reference in New Issue
Block a user