Fix template <class T> class boost::rv, which for union T's inherits off them
This commit is contained in:
parent
19702186d2
commit
3c9c670991
20
boost-1.57.0-move-is_class.patch
Normal file
20
boost-1.57.0-move-is_class.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -up ./move/core.hpp~ ./move/core.hpp
|
||||||
|
--- boost/move/core.hpp~ 2015-02-09 17:33:35.000000000 +0100
|
||||||
|
+++ boost/move/core.hpp 2015-02-13 13:54:52.012130813 +0100
|
||||||
|
@@ -43,6 +43,7 @@
|
||||||
|
#if defined(BOOST_NO_CXX11_RVALUE_REFERENCES) && !defined(BOOST_MOVE_DOXYGEN_INVOKED)
|
||||||
|
|
||||||
|
#include <boost/move/detail/meta_utils.hpp>
|
||||||
|
+ #include <boost/type_traits/is_class.hpp>
|
||||||
|
|
||||||
|
//Move emulation rv breaks standard aliasing rules so add workarounds for some compilers
|
||||||
|
#if defined(__GNUC__) && (__GNUC__ >= 4) && \
|
||||||
|
@@ -65,7 +66,7 @@
|
||||||
|
template <class T>
|
||||||
|
class rv
|
||||||
|
: public ::boost::move_detail::if_c
|
||||||
|
- < ::boost::move_detail::is_class_or_union<T>::value
|
||||||
|
+ < ::boost::is_class<T>::value
|
||||||
|
, T
|
||||||
|
, ::boost::move_detail::nat
|
||||||
|
>::type
|
11
boost.spec
11
boost.spec
@ -32,7 +32,7 @@ Name: boost
|
|||||||
Summary: The free peer-reviewed portable C++ source libraries
|
Summary: The free peer-reviewed portable C++ source libraries
|
||||||
Version: 1.57.0
|
Version: 1.57.0
|
||||||
%define version_enc 1_57_0
|
%define version_enc 1_57_0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: Boost and MIT and Python
|
License: Boost and MIT and Python
|
||||||
|
|
||||||
%define toplev_dirname %{name}_%{version_enc}
|
%define toplev_dirname %{name}_%{version_enc}
|
||||||
@ -131,6 +131,10 @@ Patch65: boost-1.57.0-build-optflags.patch
|
|||||||
# https://svn.boost.org/trac/boost/ticket/10510
|
# https://svn.boost.org/trac/boost/ticket/10510
|
||||||
Patch66: boost-1.57.0-uuid-comparison.patch
|
Patch66: boost-1.57.0-uuid-comparison.patch
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1192002
|
||||||
|
# https://svn.boost.org/trac/boost/ticket/11044
|
||||||
|
Patch67: boost-1.57.0-move-is_class.patch
|
||||||
|
|
||||||
%bcond_with tests
|
%bcond_with tests
|
||||||
%bcond_with docs_generated
|
%bcond_with docs_generated
|
||||||
|
|
||||||
@ -620,6 +624,7 @@ a number of significant features and is now developed independently
|
|||||||
%patch64 -p2
|
%patch64 -p2
|
||||||
%patch65 -p1
|
%patch65 -p1
|
||||||
%patch66 -p2
|
%patch66 -p2
|
||||||
|
%patch67 -p0
|
||||||
|
|
||||||
# At least python2_version needs to be a macro so that it's visible in
|
# At least python2_version needs to be a macro so that it's visible in
|
||||||
# %%install as well.
|
# %%install as well.
|
||||||
@ -1239,6 +1244,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/bjam.1*
|
%{_mandir}/man1/bjam.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 18 2015 Petr Machata <pmachata@redhat.com> - 1.57.0-4
|
||||||
|
- Fix template <class T> class boost::rv, which for union T's inherits
|
||||||
|
off them. (boost-1.57.0-move-is_class.patch)
|
||||||
|
|
||||||
* Mon Feb 9 2015 Petr Machata <pmachata@redhat.com> - 1.57.0-3
|
* Mon Feb 9 2015 Petr Machata <pmachata@redhat.com> - 1.57.0-3
|
||||||
- Honor RPM_OPT_FLAGS (boost-1.57.0-build-optflags.patch)
|
- Honor RPM_OPT_FLAGS (boost-1.57.0-build-optflags.patch)
|
||||||
- And don't pass -ftemplate-depth at all. The intention there was
|
- And don't pass -ftemplate-depth at all. The intention there was
|
||||||
|
Loading…
Reference in New Issue
Block a user