Integrated into "upstream" (CMake-ified Boost) the Boost.TR1/Math patch.

This commit is contained in:
Denis Arnaud 2012-01-04 23:01:07 +01:00
parent 54ddcfc414
commit 39e2c15fd4
3 changed files with 88 additions and 101 deletions

View File

@ -5699,7 +5699,7 @@ index 0000000..7684320
+boost_test_run(tribool_io_test) +boost_test_run(tribool_io_test)
diff --git a/libs/math/CMakeLists.txt b/libs/math/CMakeLists.txt diff --git a/libs/math/CMakeLists.txt b/libs/math/CMakeLists.txt
new file mode 100644 new file mode 100644
index 0000000..0f7652e index 0000000..84080d5
--- /dev/null --- /dev/null
+++ b/libs/math/CMakeLists.txt +++ b/libs/math/CMakeLists.txt
@@ -0,0 +1,28 @@ @@ -0,0 +1,28 @@
@ -5720,7 +5720,7 @@ index 0000000..0f7652e
+# Add a library target to the build system +# Add a library target to the build system
+boost_library_project( +boost_library_project(
+ math + math
+ # SRCDIRS + SRCDIRS src/tr1
+ TESTDIRS test + TESTDIRS test
+ HEADERS ${lib_headers} + HEADERS ${lib_headers}
+ # DOCDIRS + # DOCDIRS
@ -5739,6 +5739,88 @@ index 0000000..e222098
@@ -0,0 +1 @@ @@ -0,0 +1 @@
+boost_module(math DEPENDS format array) +boost_module(math DEPENDS format array)
\ No newline at end of file \ No newline at end of file
diff --git a/libs/math/src/tr1/CMakeLists.txt b/libs/math/src/tr1/CMakeLists.txt
new file mode 100644
index 0000000..692fa72
--- /dev/null
+++ b/libs/math/src/tr1/CMakeLists.txt
@@ -0,0 +1,76 @@
+boost_add_library(math_tr1
+
+ assoc_laguerre.cpp assoc_legendre.cpp beta.cpp
+ comp_ellint_1.cpp comp_ellint_2.cpp comp_ellint_3.cpp
+ cyl_bessel_i.cpp cyl_bessel_j.cpp cyl_bessel_k.cpp
+ cyl_neumann.cpp ellint_1.cpp ellint_2.cpp ellint_3.cpp
+ expint.cpp hermite.cpp laguerre.cpp legendre.cpp
+ riemann_zeta.cpp sph_bessel.cpp sph_legendre.cpp
+ sph_neumann.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1f
+
+ assoc_laguerref.cpp assoc_legendref.cpp betaf.cpp
+ comp_ellint_1f.cpp comp_ellint_2f.cpp comp_ellint_3f.cpp
+ cyl_bessel_if.cpp cyl_bessel_jf.cpp cyl_bessel_kf.cpp
+ cyl_neumannf.cpp ellint_1f.cpp ellint_2f.cpp ellint_3f.cpp
+ expintf.cpp hermitef.cpp laguerref.cpp legendref.cpp
+ riemann_zetaf.cpp sph_besself.cpp sph_legendref.cpp
+ sph_neumannf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1l
+
+ assoc_laguerrel.cpp assoc_legendrel.cpp betal.cpp
+ comp_ellint_1l.cpp comp_ellint_2l.cpp comp_ellint_3l.cpp
+ cyl_bessel_il.cpp cyl_bessel_jl.cpp cyl_bessel_kl.cpp
+ cyl_neumannl.cpp ellint_1l.cpp ellint_2l.cpp ellint_3l.cpp
+ expintl.cpp hermitel.cpp laguerrel.cpp legendrel.cpp
+ riemann_zetal.cpp sph_bessell.cpp sph_legendrel.cpp
+ sph_neumannl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99
+
+ acosh.cpp asinh.cpp atanh.cpp cbrt.cpp copysign.cpp erfc.cpp
+ erf.cpp expm1.cpp fmax.cpp fmin.cpp fpclassify.cpp hypot.cpp
+ lgamma.cpp llround.cpp log1p.cpp lround.cpp nextafter.cpp
+ nexttoward.cpp round.cpp tgamma.cpp trunc.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99f
+
+ acoshf.cpp asinhf.cpp atanhf.cpp cbrtf.cpp copysignf.cpp
+ erfcf.cpp erff.cpp expm1f.cpp fmaxf.cpp fminf.cpp
+ fpclassifyf.cpp hypotf.cpp lgammaf.cpp llroundf.cpp log1pf.cpp
+ lroundf.cpp nextafterf.cpp nexttowardf.cpp roundf.cpp
+ tgammaf.cpp truncf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99l
+
+ acoshl.cpp asinhl.cpp atanhl.cpp cbrtl.cpp copysignl.cpp
+ erfcl.cpp erfl.cpp expm1l.cpp fmaxl.cpp fminl.cpp
+ fpclassifyl.cpp hypotl.cpp lgammal.cpp llroundl.cpp log1pl.cpp
+ lroundl.cpp nextafterl.cpp nexttowardl.cpp roundl.cpp
+ tgammal.cpp truncl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
diff --git a/libs/math/test/CMakeLists.txt b/libs/math/test/CMakeLists.txt diff --git a/libs/math/test/CMakeLists.txt b/libs/math/test/CMakeLists.txt
new file mode 100644 new file mode 100644
index 0000000..88f26b7 index 0000000..88f26b7

View File

@ -1,94 +0,0 @@
diff -up boost_1_48_0/libs/math/CMakeLists.txt\~ boost_1_48_0/libs/math/CMakeLists.txt
--- boost_1_48_0/libs/math/CMakeLists.txt~ 2012-01-03 18:15:11.568913701 +0100
+++ boost_1_48_0/libs/math/CMakeLists.txt 2012-01-03 18:51:11.437962984 +0100
@@ -15,7 +15,7 @@ set (lib_headers
# Add a library target to the build system
boost_library_project(
math
- # SRCDIRS
+ SRCDIRS src/tr1
TESTDIRS test
HEADERS ${lib_headers}
# DOCDIRS
diff -up boost_1_48_0/libs/math/src/tr1/CMakeLists.txt\~ boost_1_48_0/libs/math/src/tr1/CMakeLists.txt
--- boost_1_48_0/libs/math/src/tr1/CMakeLists.txt~ 2012-01-03 18:50:07.514961526 +0100
+++ boost_1_48_0/libs/math/src/tr1/CMakeLists.txt 2012-01-03 18:47:32.803957995 +0100
@@ -0,0 +1,76 @@
+boost_add_library(math_tr1
+
+ assoc_laguerre.cpp assoc_legendre.cpp beta.cpp
+ comp_ellint_1.cpp comp_ellint_2.cpp comp_ellint_3.cpp
+ cyl_bessel_i.cpp cyl_bessel_j.cpp cyl_bessel_k.cpp
+ cyl_neumann.cpp ellint_1.cpp ellint_2.cpp ellint_3.cpp
+ expint.cpp hermite.cpp laguerre.cpp legendre.cpp
+ riemann_zeta.cpp sph_bessel.cpp sph_legendre.cpp
+ sph_neumann.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1f
+
+ assoc_laguerref.cpp assoc_legendref.cpp betaf.cpp
+ comp_ellint_1f.cpp comp_ellint_2f.cpp comp_ellint_3f.cpp
+ cyl_bessel_if.cpp cyl_bessel_jf.cpp cyl_bessel_kf.cpp
+ cyl_neumannf.cpp ellint_1f.cpp ellint_2f.cpp ellint_3f.cpp
+ expintf.cpp hermitef.cpp laguerref.cpp legendref.cpp
+ riemann_zetaf.cpp sph_besself.cpp sph_legendref.cpp
+ sph_neumannf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1l
+
+ assoc_laguerrel.cpp assoc_legendrel.cpp betal.cpp
+ comp_ellint_1l.cpp comp_ellint_2l.cpp comp_ellint_3l.cpp
+ cyl_bessel_il.cpp cyl_bessel_jl.cpp cyl_bessel_kl.cpp
+ cyl_neumannl.cpp ellint_1l.cpp ellint_2l.cpp ellint_3l.cpp
+ expintl.cpp hermitel.cpp laguerrel.cpp legendrel.cpp
+ riemann_zetal.cpp sph_bessell.cpp sph_legendrel.cpp
+ sph_neumannl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99
+
+ acosh.cpp asinh.cpp atanh.cpp cbrt.cpp copysign.cpp erfc.cpp
+ erf.cpp expm1.cpp fmax.cpp fmin.cpp fpclassify.cpp hypot.cpp
+ lgamma.cpp llround.cpp log1p.cpp lround.cpp nextafter.cpp
+ nexttoward.cpp round.cpp tgamma.cpp trunc.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99f
+
+ acoshf.cpp asinhf.cpp atanhf.cpp cbrtf.cpp copysignf.cpp
+ erfcf.cpp erff.cpp expm1f.cpp fmaxf.cpp fminf.cpp
+ fpclassifyf.cpp hypotf.cpp lgammaf.cpp llroundf.cpp log1pf.cpp
+ lroundf.cpp nextafterf.cpp nexttowardf.cpp roundf.cpp
+ tgammaf.cpp truncf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99l
+
+ acoshl.cpp asinhl.cpp atanhl.cpp cbrtl.cpp copysignl.cpp
+ erfcl.cpp erfl.cpp expm1l.cpp fmaxl.cpp fminl.cpp
+ fpclassifyl.cpp hypotl.cpp lgammal.cpp llroundl.cpp log1pl.cpp
+ lroundl.cpp nextafterl.cpp nexttowardl.cpp roundl.cpp
+ tgammal.cpp truncl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
Diff finished. Tue Jan 3 18:50:10 2012

View File

@ -28,7 +28,7 @@ Name: boost
Summary: The free peer-reviewed portable C++ source libraries Summary: The free peer-reviewed portable C++ source libraries
Version: 1.48.0 Version: 1.48.0
%define version_enc 1_48_0 %define version_enc 1_48_0
Release: 4%{?dist} Release: 5%{?dist}
License: Boost and MIT and Python License: Boost and MIT and Python
# The CMake build framework (set of CMakeLists.txt and module.cmake files) is # The CMake build framework (set of CMakeLists.txt and module.cmake files) is
@ -113,9 +113,6 @@ Patch7: boost-1.48.0-foreach.patch
# https://svn.boost.org/trac/boost/ticket/6165 # https://svn.boost.org/trac/boost/ticket/6165
Patch8: boost-1.48.0-gcc47-pthreads.patch Patch8: boost-1.48.0-gcc47-pthreads.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=771370
Patch9: boost-1.48.0-mathlib.patch
%bcond_with tests %bcond_with tests
%bcond_with docs_generated %bcond_with docs_generated
@ -472,7 +469,6 @@ sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH1} | %{__patch} -p0 --fuzz=0
%patch6 -p1 %patch6 -p1
%patch7 -p2 %patch7 -p2
%patch8 -p0 %patch8 -p0
%patch9 -p1
%build %build
# Support for building tests. # Support for building tests.
@ -967,6 +963,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/bjam.1* %{_mandir}/man1/bjam.1*
%changelog %changelog
* Wed Jan 4 2012 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.48.0-5
- Integrated into "upstream" (CMake-ified Boost) the Boost.TR1/Math patch.
* Wed Jan 4 2012 Petr Machata <pmachata@redhat.com> - 1.48.0-4 * Wed Jan 4 2012 Petr Machata <pmachata@redhat.com> - 1.48.0-4
- Build math portion of Boost.TR1, package DSOs in boost-math. - Build math portion of Boost.TR1, package DSOs in boost-math.
- Resolves: #771370 - Resolves: #771370