Merge branch 'f14'
Conflicts: boost.spec
This commit is contained in:
commit
38b520ef67
23
boost-random-dso.patch
Normal file
23
boost-random-dso.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -urpN boost_1_44_0/libs/random/CMakeLists.txt boost_1_44_0-pm/libs/random/CMakeLists.txt
|
||||||
|
--- boost_1_44_0/libs/random/CMakeLists.txt 2011-01-03 16:52:25.000000000 +0100
|
||||||
|
+++ boost_1_44_0-pm/libs/random/CMakeLists.txt 2011-01-03 16:51:17.000000000 +0100
|
||||||
|
@@ -15,7 +15,7 @@ set (lib_headers
|
||||||
|
# Add a library target to the build system
|
||||||
|
boost_library_project(
|
||||||
|
random
|
||||||
|
- # SRCDIRS
|
||||||
|
+ SRCDIRS src
|
||||||
|
TESTDIRS test
|
||||||
|
HEADERS ${lib_headers}
|
||||||
|
# DOCDIRS
|
||||||
|
diff -urpN boost_1_44_0/libs/random/src/CMakeLists.txt boost_1_44_0-pm/libs/random/src/CMakeLists.txt
|
||||||
|
--- boost_1_44_0/libs/random/src/CMakeLists.txt 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ boost_1_44_0-pm/libs/random/src/CMakeLists.txt 2011-01-03 16:50:40.000000000 +0100
|
||||||
|
@@ -0,0 +1,7 @@
|
||||||
|
+add_definitions(-DBOOST_RANDOM_NO_LIB=1)
|
||||||
|
+boost_add_library(
|
||||||
|
+ random
|
||||||
|
+ random_device.cpp
|
||||||
|
+ STATIC_COMPILE_FLAGS -DBOOST_RANDOM_STATIC_LINK
|
||||||
|
+ SHARED_COMPILE_FLAGS -DBOOST_ALL_DYN_LINK=1
|
||||||
|
+ )
|
24
boost.spec
24
boost.spec
@ -59,6 +59,7 @@ Requires: boost-graph = %{version}-%{release}
|
|||||||
Requires: boost-iostreams = %{version}-%{release}
|
Requires: boost-iostreams = %{version}-%{release}
|
||||||
Requires: boost-program-options = %{version}-%{release}
|
Requires: boost-program-options = %{version}-%{release}
|
||||||
Requires: boost-python = %{version}-%{release}
|
Requires: boost-python = %{version}-%{release}
|
||||||
|
Requires: boost-random = %{version}-%{release}
|
||||||
Requires: boost-regex = %{version}-%{release}
|
Requires: boost-regex = %{version}-%{release}
|
||||||
Requires: boost-serialization = %{version}-%{release}
|
Requires: boost-serialization = %{version}-%{release}
|
||||||
Requires: boost-signals = %{version}-%{release}
|
Requires: boost-signals = %{version}-%{release}
|
||||||
@ -79,6 +80,7 @@ BuildRequires: chrpath
|
|||||||
|
|
||||||
Patch0: cmakeify_boost_1440.patch
|
Patch0: cmakeify_boost_1440.patch
|
||||||
#Patch1: boost-cmake-soname.patch
|
#Patch1: boost-cmake-soname.patch
|
||||||
|
Patch2: boost-random-dso.patch
|
||||||
|
|
||||||
%bcond_with tests
|
%bcond_with tests
|
||||||
%bcond_with docs_generated
|
%bcond_with docs_generated
|
||||||
@ -163,6 +165,14 @@ functions and objects to Python, and vice versa, using no special
|
|||||||
tools -- just your C++ compiler. This package contains runtime
|
tools -- just your C++ compiler. This package contains runtime
|
||||||
support for Boost Python Library.
|
support for Boost Python Library.
|
||||||
|
|
||||||
|
%package random
|
||||||
|
Summary: Runtime component of boost random library
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
|
||||||
|
%description random
|
||||||
|
|
||||||
|
Runtime support for boost random library.
|
||||||
|
|
||||||
%package regex
|
%package regex
|
||||||
Summary: Runtime component of boost regular expression library
|
Summary: Runtime component of boost regular expression library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -393,6 +403,7 @@ a number of significant features and is now developed independently
|
|||||||
|
|
||||||
# CMake framework (CMakeLists.txt, *.cmake and documentation files)
|
# CMake framework (CMakeLists.txt, *.cmake and documentation files)
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Support for building tests.
|
# Support for building tests.
|
||||||
@ -609,6 +620,10 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
|
|||||||
|
|
||||||
%postun python -p /sbin/ldconfig
|
%postun python -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%post random -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun random -p /sbin/ldconfig
|
||||||
|
|
||||||
%post regex -p /sbin/ldconfig
|
%post regex -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun regex -p /sbin/ldconfig
|
%postun regex -p /sbin/ldconfig
|
||||||
@ -680,6 +695,11 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
|
|||||||
%doc LICENSE_1_0.txt
|
%doc LICENSE_1_0.txt
|
||||||
%{_libdir}/libboost_python*.so.%{sonamever}
|
%{_libdir}/libboost_python*.so.%{sonamever}
|
||||||
|
|
||||||
|
%files random
|
||||||
|
%defattr(-, root, root, -)
|
||||||
|
%doc LICENSE_1_0.txt
|
||||||
|
%{_libdir}/libboost_random*.so.%{sonamever}
|
||||||
|
|
||||||
%files regex
|
%files regex
|
||||||
%defattr(-, root, root, -)
|
%defattr(-, root, root, -)
|
||||||
%doc LICENSE_1_0.txt
|
%doc LICENSE_1_0.txt
|
||||||
@ -796,6 +816,10 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
|
|||||||
%{_bindir}/bjam
|
%{_bindir}/bjam
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 3 2011 Petr Machata <pmachata@redhat.com> - 1.44.0-5
|
||||||
|
- Add boost-random DSOs
|
||||||
|
- Resolves: #665679
|
||||||
|
|
||||||
* Wed Dec 8 2010 Petr Machata <pmachata@redhat.com> - 1.44.0-4
|
* Wed Dec 8 2010 Petr Machata <pmachata@redhat.com> - 1.44.0-4
|
||||||
- Build with support for iostreams deprecated functions
|
- Build with support for iostreams deprecated functions
|
||||||
- Resolves: #654480
|
- Resolves: #654480
|
||||||
|
Loading…
Reference in New Issue
Block a user