Rebase to 1.81.0
See https://fedoraproject.org/wiki/Changes/F38Boost181 Drop patches: deleted: boost-1.58.0-pool.patch deleted: boost-1.58.0-pool-test_linking.patch deleted: boost-1.78.0-build-optflags.patch deleted: boost-1.73-locale-empty-vector.patch deleted: boost-1.76.0-fix_multiprecision_issue_419-ppc64le.patch deleted: boost-1.76.0-ptr_cont-xml.patch deleted: boost-1.78.0-fix-b2-staging.patch deleted: boost-1.76.0-enum_type_object-type-python-3.11.patch - New Boost.URL runtime component - boost_build directory is now b2 in upstream, renamte to boost_build on install
This commit is contained in:
parent
571ebc8df1
commit
3420df7244
@ -1,30 +0,0 @@
|
||||
--- boost_1_68_0/libs/pool/test/Jamfile.v2.orig 2018-08-01 20:50:52.000000000 +0000
|
||||
+++ boost_1_68_0/libs/pool/test/Jamfile.v2 2018-12-01 17:29:33.322195409 +0000
|
||||
@@ -22,18 +22,18 @@
|
||||
import testing ;
|
||||
|
||||
test-suite pool :
|
||||
- [ run test_simple_seg_storage.cpp : : : <toolset>msvc:<cxxflags>-wd4267 ]
|
||||
- [ run test_pool_alloc.cpp ]
|
||||
- [ run pool_msvc_compiler_bug_test.cpp : : : <toolset>msvc:<cxxflags>-wd4512 ]
|
||||
- [ run test_msvc_mem_leak_detect.cpp ]
|
||||
- [ run test_bug_3349.cpp ]
|
||||
- [ run test_bug_4960.cpp ]
|
||||
+ [ run test_simple_seg_storage.cpp : : : <toolset>msvc:<cxxflags>-wd4267 <library>/boost/system//boost_system ]
|
||||
+ [ run test_pool_alloc.cpp : : : <library>/boost/system//boost_system ]
|
||||
+ [ run pool_msvc_compiler_bug_test.cpp : : : <toolset>msvc:<cxxflags>-wd4512 <library>/boost/system//boost_system ]
|
||||
+ [ run test_msvc_mem_leak_detect.cpp : : : <library>/boost/system//boost_system ]
|
||||
+ [ run test_bug_3349.cpp : : : <library>/boost/system//boost_system ]
|
||||
+ [ run test_bug_4960.cpp : : : <library>/boost/system//boost_system ]
|
||||
[ run test_bug_1252.cpp : : :
|
||||
<toolset>clang:<cxxflags>-Wno-c++11-long-long
|
||||
<toolset>gcc:<cxxflags>-Wno-long-long
|
||||
- <toolset>pathscale:<cxxflags>-Wno-long-long ]
|
||||
- [ run test_bug_2696.cpp ]
|
||||
- [ run test_bug_5526.cpp ]
|
||||
+ <toolset>pathscale:<cxxflags>-Wno-long-long <library>/boost/system//boost_system ]
|
||||
+ [ run test_bug_2696.cpp : : : <library>/boost/system//boost_system ]
|
||||
+ [ run test_bug_5526.cpp : : : <library>/boost/system//boost_system ]
|
||||
[ run test_threading.cpp : : : <threading>multi <library>/boost/thread//boost_thread ]
|
||||
[ compile test_poisoned_macros.cpp ]
|
||||
;
|
@ -1,120 +0,0 @@
|
||||
Index: boost/pool/pool.hpp
|
||||
===================================================================
|
||||
--- boost/pool/pool.hpp (revision 78317)
|
||||
+++ boost/pool/pool.hpp (revision 78326)
|
||||
@@ -27,4 +27,6 @@
|
||||
#include <boost/pool/poolfwd.hpp>
|
||||
|
||||
+// std::numeric_limits
|
||||
+#include <boost/limits.hpp>
|
||||
// boost::integer::static_lcm
|
||||
#include <boost/integer/common_factor_ct.hpp>
|
||||
@@ -358,4 +360,11 @@
|
||||
}
|
||||
|
||||
+ size_type max_chunks() const
|
||||
+ { //! Calculated maximum number of memory chunks that can be allocated in a single call by this Pool.
|
||||
+ size_type partition_size = alloc_size();
|
||||
+ size_type POD_size = integer::static_lcm<sizeof(size_type), sizeof(void *)>::value + sizeof(size_type);
|
||||
+ return (std::numeric_limits<size_type>::max() - POD_size) / alloc_size();
|
||||
+ }
|
||||
+
|
||||
static void * & nextof(void * const ptr)
|
||||
{ //! \returns Pointer dereferenced.
|
||||
@@ -377,5 +388,7 @@
|
||||
//! the first time that object needs to allocate system memory.
|
||||
//! The default is 32. This parameter may not be 0.
|
||||
- //! \param nmax_size is the maximum number of chunks to allocate in one block.
|
||||
+ //! \param nmax_size is the maximum number of chunks to allocate in one block.
|
||||
+ set_next_size(nnext_size);
|
||||
+ set_max_size(nmax_size);
|
||||
}
|
||||
|
||||
@@ -400,7 +413,7 @@
|
||||
}
|
||||
void set_next_size(const size_type nnext_size)
|
||||
- { //! Set number of chunks to request from the system the next time that object needs to allocate system memory. This value should never be set to 0.
|
||||
- //! \returns nnext_size.
|
||||
- next_size = start_size = nnext_size;
|
||||
+ { //! Set number of chunks to request from the system the next time that object needs to allocate system memory. This value should never be set to 0.
|
||||
+ BOOST_USING_STD_MIN();
|
||||
+ next_size = start_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(nnext_size, max_chunks());
|
||||
}
|
||||
size_type get_max_size() const
|
||||
@@ -410,5 +423,6 @@
|
||||
void set_max_size(const size_type nmax_size)
|
||||
{ //! Set max_size.
|
||||
- max_size = nmax_size;
|
||||
+ BOOST_USING_STD_MIN();
|
||||
+ max_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(nmax_size, max_chunks());
|
||||
}
|
||||
size_type get_requested_size() const
|
||||
@@ -713,7 +727,7 @@
|
||||
BOOST_USING_STD_MIN();
|
||||
if(!max_size)
|
||||
- next_size <<= 1;
|
||||
+ set_next_size(next_size << 1);
|
||||
else if( next_size*partition_size/requested_size < max_size)
|
||||
- next_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size*requested_size/ partition_size);
|
||||
+ set_next_size(min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size * requested_size / partition_size));
|
||||
|
||||
// initialize it,
|
||||
@@ -753,7 +767,7 @@
|
||||
BOOST_USING_STD_MIN();
|
||||
if(!max_size)
|
||||
- next_size <<= 1;
|
||||
+ set_next_size(next_size << 1);
|
||||
else if( next_size*partition_size/requested_size < max_size)
|
||||
- next_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size*requested_size/ partition_size);
|
||||
+ set_next_size(min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size * requested_size / partition_size));
|
||||
|
||||
// initialize it,
|
||||
@@ -797,4 +811,6 @@
|
||||
//! \returns Address of chunk n if allocated ok.
|
||||
//! \returns 0 if not enough memory for n chunks.
|
||||
+ if (n > max_chunks())
|
||||
+ return 0;
|
||||
|
||||
const size_type partition_size = alloc_size();
|
||||
@@ -845,7 +861,7 @@
|
||||
BOOST_USING_STD_MIN();
|
||||
if(!max_size)
|
||||
- next_size <<= 1;
|
||||
+ set_next_size(next_size << 1);
|
||||
else if( next_size*partition_size/requested_size < max_size)
|
||||
- next_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size*requested_size/ partition_size);
|
||||
+ set_next_size(min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size * requested_size / partition_size));
|
||||
|
||||
// insert it into the list,
|
||||
Index: libs/pool/test/test_bug_6701.cpp
|
||||
===================================================================
|
||||
--- libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||
+++ libs/pool/test/test_bug_6701.cpp (revision 78326)
|
||||
@@ -0,0 +1,27 @@
|
||||
+/* Copyright (C) 2012 Étienne Dupuis
|
||||
+*
|
||||
+* Use, modification and distribution is subject to the
|
||||
+* Boost Software License, Version 1.0. (See accompanying
|
||||
+* file LICENSE_1_0.txt or http://www.boost.org/LICENSE_1_0.txt)
|
||||
+*/
|
||||
+
|
||||
+// Test of bug #6701 (https://svn.boost.org/trac/boost/ticket/6701)
|
||||
+
|
||||
+#include <boost/pool/object_pool.hpp>
|
||||
+#include <boost/limits.hpp>
|
||||
+
|
||||
+int main()
|
||||
+{
|
||||
+ boost::pool<> p(1024, std::numeric_limits<size_t>::max() / 768);
|
||||
+
|
||||
+ void *x = p.malloc();
|
||||
+ BOOST_ASSERT(!x);
|
||||
+
|
||||
+ BOOST_ASSERT(std::numeric_limits<size_t>::max() / 1024 >= p.get_next_size());
|
||||
+ BOOST_ASSERT(std::numeric_limits<size_t>::max() / 1024 >= p.get_max_size());
|
||||
+
|
||||
+ void *y = p.ordered_malloc(std::numeric_limits<size_t>::max() / 768);
|
||||
+ BOOST_ASSERT(!y);
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
@ -1,37 +0,0 @@
|
||||
From daf4ef50c88c2b9a6bf2c40b537eebc202caad6e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?S=C3=A9bastien=20Gonzalve?=
|
||||
<sebastien.gonzalve@aliceadsl.fr>
|
||||
Date: Sat, 14 Nov 2020 10:39:47 +0100
|
||||
Subject: [PATCH] Do not try to access element when vector is empty
|
||||
|
||||
Trying to access tmp[0] causes a crash on Fedora when assertion on STL
|
||||
are enabled.
|
||||
|
||||
/usr/include/c++/10/bits/stl_vector.h:1045: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = unsigned char; _Alloc = std::allocator<unsigned char>; std::vector<_Tp, _Alloc>::reference = unsigned char&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
|
||||
|
||||
This patch just passes nullptr as pointer to getSortKey() when tmp size
|
||||
is 0, preventing dereferencing elements in empty vector.
|
||||
|
||||
I guess that &tmp[0] should be optimized as 'no real access' when
|
||||
disabling assertion, but actually leads to crash when assert are
|
||||
enabled.
|
||||
---
|
||||
src/icu/collator.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libs/locale/src/icu/collator.cpp b/libs/locale/src/icu/collator.cpp
|
||||
index 7f1ea6a..dc59e8c 100644
|
||||
--- a/libs/locale/src/icu/collator.cpp
|
||||
+++ b/libs/locale/src/icu/collator.cpp
|
||||
@@ -93,7 +93,7 @@ namespace boost {
|
||||
std::vector<uint8_t> tmp;
|
||||
tmp.resize(str.length());
|
||||
icu::Collator *collate = get_collator(level);
|
||||
- int len = collate->getSortKey(str,&tmp[0],tmp.size());
|
||||
+ int len = collate->getSortKey(str,tmp.empty()?nullptr:&tmp[0],tmp.size());
|
||||
if(len > int(tmp.size())) {
|
||||
tmp.resize(len);
|
||||
collate->getSortKey(str,&tmp[0],tmp.size());
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,35 +0,0 @@
|
||||
From ae5da2a7e8f1111757d8a474095486a5b22aa12d Mon Sep 17 00:00:00 2001
|
||||
From: Victor Stinner <vstinner@python.org>
|
||||
Date: Mon, 25 Apr 2022 10:51:46 +0200
|
||||
Subject: [PATCH] Fix enum_type_object type on Python 3.11
|
||||
|
||||
The enum_type_object type inherits from PyLong_Type which is not tracked
|
||||
by the GC. Instances doesn't have to be tracked by the GC: remove the
|
||||
Py_TPFLAGS_HAVE_GC flag.
|
||||
|
||||
The Python C API documentation says:
|
||||
|
||||
"To create a container type, the tp_flags field of the type object
|
||||
must include the Py_TPFLAGS_HAVE_GC and provide an implementation of
|
||||
the tp_traverse handler."
|
||||
|
||||
https://docs.python.org/dev/c-api/gcsupport.html
|
||||
|
||||
The new exception was introduced in Python 3.11 by:
|
||||
https://github.com/python/cpython/issues/88429
|
||||
---
|
||||
libs/python/src/object/enum.cpp | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/libs/python/src/object/enum.cpp b/libs/python/src/object/enum.cpp
|
||||
index 293e705899..5753b32e07 100644
|
||||
--- a/libs/python/src/object/enum.cpp
|
||||
+++ b/libs/python/src/object/enum.cpp
|
||||
@@ -113,7 +113,6 @@ static PyTypeObject enum_type_object = {
|
||||
#if PY_VERSION_HEX < 0x03000000
|
||||
| Py_TPFLAGS_CHECKTYPES
|
||||
#endif
|
||||
- | Py_TPFLAGS_HAVE_GC
|
||||
| Py_TPFLAGS_BASETYPE, /* tp_flags */
|
||||
0, /* tp_doc */
|
||||
0, /* tp_traverse */
|
File diff suppressed because it is too large
Load Diff
@ -1,17 +1,17 @@
|
||||
From 739edb2889cb63c281a3597e712988a40bc82829 Mon Sep 17 00:00:00 2001
|
||||
From aabd16d1a74a1c2be151e16bda9ff55af4f0beba Mon Sep 17 00:00:00 2001
|
||||
From: Thomas W Rodgers <rodgert@twrodgers.com>
|
||||
Date: Mon, 28 Feb 2022 20:55:14 -0800
|
||||
Subject: [PATCH 1/3] Adjust options for Fedora package build
|
||||
Date: Thu, 12 Jan 2023 11:54:59 -0800
|
||||
Subject: [PATCH] Adjust options for Fedora package build
|
||||
|
||||
---
|
||||
src/tools/gcc.jam | 31 ++++++++++++++++---------------
|
||||
1 file changed, 16 insertions(+), 15 deletions(-)
|
||||
src/tools/gcc.jam | 36 ++++++++++++++++++------------------
|
||||
1 file changed, 18 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/tools/build/src/tools/gcc.jam b/tools/build/src/tools/gcc.jam
|
||||
index 47a11322..543cfd84 100644
|
||||
diff --git a/src/tools/gcc.jam b/src/tools/gcc.jam
|
||||
index 14be886f5..9dd0ba0a6 100644
|
||||
--- a/tools/build/src/tools/gcc.jam
|
||||
+++ b/tools/build/src/tools/gcc.jam
|
||||
@@ -510,7 +510,7 @@ rule compile.fortran ( targets * : sources * : properties * )
|
||||
@@ -511,7 +511,7 @@ rule compile.fortran ( targets * : sources * : properties * )
|
||||
|
||||
actions compile.c++ bind PCH_FILE
|
||||
{
|
||||
@ -20,21 +20,24 @@ index 47a11322..543cfd84 100644
|
||||
}
|
||||
|
||||
actions compile.c bind PCH_FILE
|
||||
@@ -521,6 +521,7 @@ actions compile.c bind PCH_FILE
|
||||
@@ -521,7 +521,7 @@ actions compile.c bind PCH_FILE
|
||||
|
||||
actions compile.c++.preprocess bind PCH_FILE
|
||||
{
|
||||
"$(CONFIG_COMMAND)" $(LANG) -ftemplate-depth-$(TEMPLATE_DEPTH) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
++ "$(CONFIG_COMMAND)" $(LANG) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" $(PCH_FILE:D)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
- "$(CONFIG_COMMAND)" $(LANG) -ftemplate-depth-$(TEMPLATE_DEPTH) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
+ "$(CONFIG_COMMAND)" $(LANG) $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -include"$(PCH_FILE:S=)" $(PCH_FILE:D)" -I"$(INCLUDES)" -include"$(FORCE_INCLUDES)" "$(>:W)" -E >"$(<:W)"
|
||||
}
|
||||
|
||||
actions compile.c.preprocess bind PCH_FILE
|
||||
@@ -623,20 +624,20 @@ actions compile.c.pch
|
||||
@@ -624,22 +624,22 @@ actions compile.c.pch
|
||||
###
|
||||
|
||||
# Declare flags and action for compilation.
|
||||
-toolset.flags gcc.compile OPTIONS <optimization>off : -O0 ;
|
||||
-toolset.flags gcc.compile OPTIONS <optimization>speed : -O3 ;
|
||||
-toolset.flags gcc.compile OPTIONS <optimization>space : -Os ;
|
||||
-toolset.flags gcc.compile OPTIONS <optimization>minimal : -O1 ;
|
||||
-toolset.flags gcc.compile OPTIONS <optimization>debug : -Og ;
|
||||
-
|
||||
-toolset.flags gcc.compile OPTIONS <inlining>off : -fno-inline ;
|
||||
-toolset.flags gcc.compile OPTIONS <inlining>on : -Wno-inline ;
|
||||
@ -49,6 +52,8 @@ index 47a11322..543cfd84 100644
|
||||
+toolset.flags gcc.compile OPTIONS <optimization>off : ;
|
||||
+toolset.flags gcc.compile OPTIONS <optimization>speed : ;
|
||||
+toolset.flags gcc.compile OPTIONS <optimization>space : ;
|
||||
+toolset.flags gcc.compile OPTIONS <optimization>minimal : ;
|
||||
+toolset.flags gcc.compile OPTIONS <optimization>debug : ;
|
||||
+
|
||||
+toolset.flags gcc.compile OPTIONS <inlining>off : ;
|
||||
+toolset.flags gcc.compile OPTIONS <inlining>on : ;
|
||||
@ -64,5 +69,5 @@ index 47a11322..543cfd84 100644
|
||||
toolset.flags gcc.compile OPTIONS <debug-symbols>on : -g ;
|
||||
toolset.flags gcc.compile OPTIONS <profiling>on : -pg ;
|
||||
--
|
||||
2.35.1
|
||||
2.39.0
|
||||
|
77
boost.spec
77
boost.spec
@ -41,8 +41,8 @@
|
||||
Name: boost
|
||||
%global real_name boost
|
||||
Summary: The free peer-reviewed portable C++ source libraries
|
||||
Version: 1.78.0
|
||||
Release: 11%{?dist}
|
||||
Version: 1.81.0
|
||||
Release: 0%{?dist}
|
||||
License: Boost and MIT and Python
|
||||
|
||||
# Replace each . with _ in %%{version}
|
||||
@ -54,7 +54,7 @@ License: Boost and MIT and Python
|
||||
%global toplev_dirname %{real_name}_%{version_enc}
|
||||
URL: http://www.boost.org
|
||||
|
||||
# https://boostorg.jfrog.io/artifactory/main/release/1.78.0/source/boost_1_78_0.tar.bz2
|
||||
# https://boostorg.jfrog.io/artifactory/main/release/1.81.0/source/boost_1_81_0.tar.bz2
|
||||
Source0: https://boostorg.jfrog.io/artifactory/main/release/%{version}/source/%{name}_%{version_enc}.tar.bz2
|
||||
Source1: libboost_thread.so
|
||||
# Add a manual page for b2, based on the online documentation:
|
||||
@ -127,16 +127,8 @@ BuildRequires: libquadmath-devel
|
||||
BuildRequires: bison
|
||||
BuildRequires: libzstd-devel
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=828856
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=828857
|
||||
# https://svn.boost.org/trac/boost/ticket/6701
|
||||
Patch15: boost-1.58.0-pool.patch
|
||||
|
||||
# https://svn.boost.org/trac/boost/ticket/9038
|
||||
Patch51: boost-1.58.0-pool-test_linking.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
||||
Patch105: boost-1.78.0-build-optflags.patch
|
||||
Patch111: boost-1.81.0-build-optflags.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1318383
|
||||
Patch106: boost-1.78.0-no-rpath.patch
|
||||
@ -144,35 +136,17 @@ Patch106: boost-1.78.0-no-rpath.patch
|
||||
# https://lists.boost.org/Archives/boost/2020/04/248812.php
|
||||
Patch88: boost-1.73.0-cmakedir.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1899888
|
||||
# https://github.com/boostorg/locale/issues/52
|
||||
Patch94: boost-1.73-locale-empty-vector.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1541035
|
||||
Patch107: boost-1.78.0-b2-build-flags.patch
|
||||
|
||||
# https://github.com/boostorg/random/issues/82
|
||||
Patch102: boost-1.76.0-random-test.patch
|
||||
|
||||
# PR https://github.com/boostorg/multiprecision/pull/421
|
||||
# fixes ppc64le issue https://github.com/boostorg/multiprecision/issues/419
|
||||
Patch103: boost-1.76.0-fix_multiprecision_issue_419-ppc64le.patch
|
||||
|
||||
# PR https://github.com/boostorg/interval/pull/30
|
||||
# Fixes narrowing conversions for ppc -
|
||||
# https://github.com/boostorg/interval/issues/29
|
||||
Patch104: boost-1.76.0-fix-narrowing-conversions-for-ppc.patch
|
||||
|
||||
# https://github.com/boostorg/ptr_container/pull/27
|
||||
Patch108: boost-1.76.0-ptr_cont-xml.patch
|
||||
|
||||
# Fixes missing libboost_fiber.so
|
||||
# https://github.com/boostorg/boost/issues/632
|
||||
Patch109: boost-1.78.0-fix-b2-staging.patch
|
||||
|
||||
# https://github.com/boostorg/python/pull/385
|
||||
Patch110: boost-1.76.0-enum_type_object-type-python-3.11.patch
|
||||
|
||||
%bcond_with tests
|
||||
%bcond_with docs_generated
|
||||
|
||||
@ -451,6 +425,14 @@ Requires: %{name}-system%{?_isa} = %{version}-%{release}
|
||||
The Boost.TypeErasure library provides runtime polymorphism in C++
|
||||
that is more flexible than that provided by the core language.
|
||||
|
||||
%package url
|
||||
Summary: Runtime component of boost URL library
|
||||
|
||||
%description url
|
||||
|
||||
Run-time support for the Boost.URL library, a Standards conforming
|
||||
library for parsing Uniform Resource Locators.
|
||||
|
||||
%package wave
|
||||
Summary: Run-time component of boost C99/C++ preprocessing library
|
||||
Requires: %{name}-chrono%{?_isa} = %{version}-%{release}
|
||||
@ -675,19 +657,12 @@ a number of significant features and is now developed independently.
|
||||
%setup -q -n %{toplev_dirname}
|
||||
find ./boost -name '*.hpp' -perm /111 | xargs --no-run-if-empty chmod a-x
|
||||
|
||||
%patch15 -p0
|
||||
%patch51 -p1
|
||||
%patch105 -p1
|
||||
%patch111 -p1
|
||||
%patch106 -p1
|
||||
%patch107 -p1
|
||||
%patch88 -p1
|
||||
%patch94 -p1
|
||||
%patch102 -p1
|
||||
%patch103 -p2
|
||||
%patch104 -p2
|
||||
%patch108 -p1
|
||||
%patch109 -p1
|
||||
%patch110 -p1
|
||||
|
||||
%build
|
||||
%set_build_flags
|
||||
@ -896,6 +871,11 @@ install -p -m 644 $(basename %{SOURCE1}) $RPM_BUILD_ROOT%{_libdir}/
|
||||
echo ============================= install Boost.Build ==================
|
||||
(cd tools/build
|
||||
./b2 --prefix=$RPM_BUILD_ROOT%{_prefix} install
|
||||
|
||||
# Somewhere along the line the boost-build install directory became b2
|
||||
# which seems not so great for our purposes, fix that up
|
||||
mv $RPM_BUILD_ROOT%{_datadir}/b2 $RPM_BUILD_ROOT%{_datadir}/boost-build
|
||||
|
||||
# Fix some permissions
|
||||
chmod +x $RPM_BUILD_ROOT%{_datadir}/boost-build/src/tools/doxproc.py
|
||||
# Fix shebang using unversioned python
|
||||
@ -1138,6 +1118,10 @@ fi
|
||||
%license LICENSE_1_0.txt
|
||||
%{_libdir}/libboost_type_erasure.so.%{sonamever}
|
||||
|
||||
%files url
|
||||
%license LICENSE_1_0.txt
|
||||
%{_libdir}/libboost_url.so.%{sonamever}
|
||||
|
||||
%files wave
|
||||
%license LICENSE_1_0.txt
|
||||
%{_libdir}/libboost_wave.so.%{sonamever}
|
||||
@ -1202,6 +1186,7 @@ fi
|
||||
%{_libdir}/libboost_thread.so
|
||||
%{_libdir}/libboost_timer.so
|
||||
%{_libdir}/libboost_type_erasure.so
|
||||
%{_libdir}/libboost_url.so
|
||||
%{_libdir}/libboost_wave.so
|
||||
|
||||
%files static
|
||||
@ -1269,7 +1254,6 @@ fi
|
||||
%files mpich-python3-devel
|
||||
%license LICENSE_1_0.txt
|
||||
%{_libdir}/mpich/lib/libboost_mpi_python%{python3_version_nodots}.so
|
||||
|
||||
%endif
|
||||
|
||||
%files graph-mpich
|
||||
@ -1293,6 +1277,21 @@ fi
|
||||
%{_mandir}/man1/b2.1*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 20 2023 Thomas Rodgers <trodgers@redhat.com> - 1.81.0-0
|
||||
- Rebase to 1.81.0
|
||||
See https://fedoraproject.org/wiki/Changes/F38Boost181
|
||||
- Drop patches:
|
||||
deleted: boost-1.58.0-pool.patch
|
||||
deleted: boost-1.58.0-pool-test_linking.patch
|
||||
deleted: boost-1.78.0-build-optflags.patch
|
||||
deleted: boost-1.73-locale-empty-vector.patch
|
||||
deleted: boost-1.76.0-fix_multiprecision_issue_419-ppc64le.patch
|
||||
deleted: boost-1.76.0-ptr_cont-xml.patch
|
||||
deleted: boost-1.78.0-fix-b2-staging.patch
|
||||
deleted: boost-1.76.0-enum_type_object-type-python-3.11.patch
|
||||
- New Boost.URL runtime component
|
||||
- boost_build directory is now b2 in upstream, renamte to boost_build on install
|
||||
|
||||
* Wed Jan 18 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.78.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (boost_1_78_0.tar.bz2) = 9c34a387a203b99aa773eb0c59f5abac7a99ba10e4623653e793c1d5b29b99b88e0e4e0d4e2e4ca5d497c42f2e46e23bab66417722433a457dc818d7670bcbbf
|
||||
SHA512 (boost_1_81_0.tar.bz2) = a04201e73da59f68fa02761b333c864a96ebaf268247b6b10cb19ed3d70ee9ad3da4c53123f2a7a4a9b9e1408793b51e1adbcc6fd09f60fecef3ca9522bb6b36
|
||||
|
Loading…
Reference in New Issue
Block a user