Patch Boost.build for https://bugzilla.redhat.com/show_bug.cgi\?id\=1923740
This commit is contained in:
parent
cb5a05db6c
commit
325ac22f96
25
boost-1.75.0-boost-build-fix.patch
Normal file
25
boost-1.75.0-boost-build-fix.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 40e5bcd594b01f9b7091de07f9efc4567cc1ac40 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Rodgers <rodgert@appliantology.com>
|
||||
Date: Tue, 2 Feb 2021 18:15:30 -0800
|
||||
Subject: [PATCH] Apply post 1.75.0 change from upstream
|
||||
|
||||
---
|
||||
tools/build/src/engine/startup.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/build/src/engine/startup.cpp b/tools/build/src/engine/startup.cpp
|
||||
index f58625408..a7659bb50 100644
|
||||
--- a/tools/build/src/engine/startup.cpp
|
||||
+++ b/tools/build/src/engine/startup.cpp
|
||||
@@ -195,7 +195,7 @@ bool b2::startup::bootstrap(FRAME *frame)
|
||||
{
|
||||
const std::string path{
|
||||
b2::paths::normalize(
|
||||
- b2_exe_path + "/../../share/boost-build/" + boost_build_jam)};
|
||||
+ b2_exe_path + "/../../share/boost-build/src/kernel/" + boost_build_jam)};
|
||||
if (b2::filesys::is_file(path))
|
||||
b2_file_path = path;
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
|
10
boost.spec
10
boost.spec
@ -42,7 +42,7 @@ Name: boost
|
||||
%global real_name boost
|
||||
Summary: The free peer-reviewed portable C++ source libraries
|
||||
Version: 1.75.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: Boost and MIT and Python
|
||||
|
||||
# Replace each . with _ in %%{version}
|
||||
@ -152,6 +152,10 @@ Patch93: boost-1.73-python3.10.patch
|
||||
# https://github.com/boostorg/locale/issues/52
|
||||
Patch94: boost-1.73-locale-empty-vector.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1923740
|
||||
# https://github.com/boostorg/build/issues/696
|
||||
Patch95: boost-1.75.0-boost-build-fix.patch
|
||||
|
||||
%bcond_with tests
|
||||
%bcond_with docs_generated
|
||||
|
||||
@ -672,6 +676,7 @@ find ./boost -name '*.hpp' -perm /111 | xargs chmod a-x
|
||||
%patch88 -p1
|
||||
%patch93 -p1
|
||||
%patch94 -p1
|
||||
%patch95 -p1
|
||||
|
||||
%build
|
||||
%set_build_flags
|
||||
@ -1273,6 +1278,9 @@ fi
|
||||
%{_mandir}/man1/b2.1*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 02 2021 Thomas Rodgers <trodgers@redhat.com> - 1.75.0-3
|
||||
- Patch for https://bugzilla.redhat.com/show_bug.cgi?id=1923740
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.75.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user