parent
3f89025bf6
commit
281f2147cf
@ -1 +1 @@
|
|||||||
boost-1.41.0.cmake0.tar.bz2
|
boost-1.44.0.cmake.tar.bz2
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
Index: /trunk/boost/iostreams/filter/zlib.hpp
|
|
||||||
===================================================================
|
|
||||||
--- /trunk/boost/iostreams/filter/zlib.hpp (revision 45783)
|
|
||||||
+++ /trunk/boost/iostreams/filter/zlib.hpp (revision 57610)
|
|
||||||
@@ -21,4 +21,5 @@
|
|
||||||
#include <new>
|
|
||||||
#include <boost/config.hpp> // MSVC, STATIC_CONSTANT, DEDUCED_TYPENAME, DINKUM.
|
|
||||||
+#include <boost/cstdint.hpp> // uint*_t
|
|
||||||
#include <boost/detail/workaround.hpp>
|
|
||||||
#include <boost/iostreams/constants.hpp> // buffer size.
|
|
||||||
@@ -44,7 +45,7 @@
|
|
||||||
// Typedefs
|
|
||||||
|
|
||||||
-typedef unsigned int uint;
|
|
||||||
-typedef unsigned char byte;
|
|
||||||
-typedef unsigned long ulong;
|
|
||||||
+typedef uint32_t uint;
|
|
||||||
+typedef uint8_t byte;
|
|
||||||
+typedef uint32_t ulong;
|
|
||||||
|
|
||||||
// Prefix 'x' prevents symbols from being redefined when Z_PREFIX is defined
|
|
@ -1,21 +0,0 @@
|
|||||||
diff -up /home/petr/fedora/boost/devel/boost-1.41.0.cmake0/boost/iostreams/device/mapped_file.hpp\~ /home/petr/fedora/boost/devel/boost-1.41.0.cmake0/boost/iostreams/device/mapped_file.hpp
|
|
||||||
--- boost/iostreams/device/mapped_file.hpp~ 2009-12-17 20:51:56.000000000 +0100
|
|
||||||
+++ boost/iostreams/device/mapped_file.hpp 2010-01-25 10:33:43.000000000 +0100
|
|
||||||
@@ -4,6 +4,9 @@
|
|
||||||
// Distributed under the Boost Software License, Version 1.0. (See accompanying
|
|
||||||
// file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt.)
|
|
||||||
|
|
||||||
+#ifndef BOOST_IOSTREAMS_MAPPED_FILE_HPP_INCLUDED
|
|
||||||
+#define BOOST_IOSTREAMS_MAPPED_FILE_HPP_INCLUDED
|
|
||||||
+
|
|
||||||
#if defined(_MSC_VER) && (_MSC_VER >= 1020)
|
|
||||||
# pragma once
|
|
||||||
#endif
|
|
||||||
@@ -591,3 +594,5 @@ operator^=(mapped_file::mapmode& a, mapp
|
|
||||||
} } // End namespaces iostreams, boost.
|
|
||||||
|
|
||||||
#include <boost/config/abi_suffix.hpp> // pops abi_suffix.hpp pragmas
|
|
||||||
+
|
|
||||||
+#endif // #ifndef BOOST_IOSTREAMS_MAPPED_FILE_HPP_INCLUDED
|
|
||||||
|
|
||||||
Diff finished. Mon Jan 25 10:33:55 2010
|
|
@ -1,14 +0,0 @@
|
|||||||
diff -up /home/petr/fedora/boost/devel/boost-1.41.0.cmake0/boost/archive/shared_ptr_helper.hpp\~ /home/petr/fedora/boost/devel/boost-1.41.0.cmake0/boost/archive/shared_ptr_helper.hpp
|
|
||||||
--- boost-1.41.0.cmake0/boost/archive/shared_ptr_helper.hpp~ 2009-12-17 20:51:55.000000000 +0100
|
|
||||||
+++ boost-1.41.0.cmake0/boost/archive/shared_ptr_helper.hpp 2010-02-22 14:13:18.000000000 +0100
|
|
||||||
@@ -108,7 +108,7 @@ public:
|
|
||||||
struct non_polymorphic {
|
|
||||||
static const boost::serialization::extended_type_info *
|
|
||||||
get_object_identifier(T & t){
|
|
||||||
- return boost::serialization::singleton<
|
|
||||||
+ return &boost::serialization::singleton<
|
|
||||||
BOOST_DEDUCED_TYPENAME
|
|
||||||
boost::serialization::type_info_implementation<T>::type
|
|
||||||
>::get_const_instance();
|
|
||||||
|
|
||||||
Diff finished. Mon Feb 22 14:13:38 2010
|
|
@ -1,12 +0,0 @@
|
|||||||
*** boost/graph/distributed/detail/mpi_process_group.ipp.orig 2009-12-16 15:46:32.410223363 -0800
|
|
||||||
--- boost/graph/distributed/detail/mpi_process_group.ipp 2009-12-16 15:47:28.700348300 -0800
|
|
||||||
***************
|
|
||||||
*** 19,24 ****
|
|
||||||
--- 19,25 ----
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include <cassert>
|
|
||||||
+ #include <cstdio>
|
|
||||||
#include <algorithm>
|
|
||||||
#include <boost/graph/parallel/detail/untracked_pair.hpp>
|
|
||||||
#include <numeric>
|
|
23
boost.spec
23
boost.spec
@ -21,12 +21,12 @@
|
|||||||
|
|
||||||
Name: boost
|
Name: boost
|
||||||
Summary: The free peer-reviewed portable C++ source libraries
|
Summary: The free peer-reviewed portable C++ source libraries
|
||||||
Version: 1.41.0
|
Version: 1.44.0
|
||||||
Release: 13%{?dist}
|
Release: 0.1%{?dist}
|
||||||
License: Boost
|
License: Boost
|
||||||
URL: http://sodium.resophonic.com/boost-cmake/%{version}.cmake0/
|
URL: http://gitorious.org/boost/zeuners-boost-cmake/archive-tarball/%{version}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
%define full_version %{name}-%{version}.cmake0
|
%define full_version %{name}-%{version}.cmake
|
||||||
Source: %{url}/%{full_version}.tar.bz2
|
Source: %{url}/%{full_version}.tar.bz2
|
||||||
|
|
||||||
# From the version 13 of Fedora, the Boost libraries are delivered
|
# From the version 13 of Fedora, the Boost libraries are delivered
|
||||||
@ -38,7 +38,7 @@ Source: %{url}/%{full_version}.tar.bz2
|
|||||||
%if 0%{?fedora} >= 13
|
%if 0%{?fedora} >= 13
|
||||||
%define sonamever %{version}
|
%define sonamever %{version}
|
||||||
%else
|
%else
|
||||||
%define sonamever 5
|
%define sonamever 7
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# boost is an "umbrella" package that pulls in all other boost
|
# boost is an "umbrella" package that pulls in all other boost
|
||||||
@ -70,10 +70,6 @@ BuildRequires: libicu-devel
|
|||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
|
|
||||||
Patch0: boost-cmake-soname.patch
|
Patch0: boost-cmake-soname.patch
|
||||||
Patch1: boost-graph-compile.patch
|
|
||||||
Patch2: boost-1.41.0-mapnik.patch
|
|
||||||
Patch3: boost-1.41.0-shared_ptr_serialization.patch
|
|
||||||
Patch4: boost-1.41.0-iostreams-zlib.patch
|
|
||||||
|
|
||||||
%bcond_with tests
|
%bcond_with tests
|
||||||
%bcond_with docs_generated
|
%bcond_with docs_generated
|
||||||
@ -364,10 +360,6 @@ backend to do the parallel work.
|
|||||||
%setup -q -n %{full_version}
|
%setup -q -n %{full_version}
|
||||||
|
|
||||||
sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH0} | %{__patch} -p0 --fuzz=0
|
sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH0} | %{__patch} -p0 --fuzz=0
|
||||||
%patch1 -p0
|
|
||||||
%patch2 -p0
|
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p2
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Support for building tests.
|
# Support for building tests.
|
||||||
@ -536,6 +528,7 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
|
|||||||
# MPI subpackages don't need the ldconfig magic. They are hidden by
|
# MPI subpackages don't need the ldconfig magic. They are hidden by
|
||||||
# default, in MPI backend-specific directory, and only show to the
|
# default, in MPI backend-specific directory, and only show to the
|
||||||
# user after the relevant environment module has been loaded.
|
# user after the relevant environment module has been loaded.
|
||||||
|
# rpmlint will report that as errors, but it is fine.
|
||||||
|
|
||||||
%post date-time -p /sbin/ldconfig
|
%post date-time -p /sbin/ldconfig
|
||||||
|
|
||||||
@ -739,6 +732,10 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 23 2010 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.44.0-0.1
|
||||||
|
- Upstream update: Boost-1.44 with CMake enabled
|
||||||
|
- Resolves: #607615
|
||||||
|
|
||||||
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.41.0-13
|
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.41.0-13
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||||
|
|
||||||
|
@ -1,2 +1,3 @@
|
|||||||
boost-1_37_0-1_fc10:HEAD:boost-1.37.0-1.fc10.src.rpm:1229535558
|
boost-1_37_0-1_fc10:HEAD:boost-1.37.0-1.fc10.src.rpm:1229535558
|
||||||
boost-1_39_0-1_fc10:HEAD:boost-1.39.0-1.fc10.src.rpm:1241744899
|
boost-1_39_0-1_fc10:HEAD:boost-1.39.0-1.fc10.src.rpm:1241744899
|
||||||
|
boost-1_44_0-0_1_fc13:HEAD:boost-1.44.0-0.1.fc13.src.rpm:1280248009
|
||||||
|
Loading…
Reference in New Issue
Block a user