Add patch for Boost.Phoenix bugs (#2178210)
This commit is contained in:
parent
a496150aec
commit
1116a4d288
20
boost-1.81-phoenix-multiple-defn.patch
Normal file
20
boost-1.81-phoenix-multiple-defn.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- boost_1_81_0/boost/phoenix/stl/tuple.hpp~ 2023-03-15 09:31:59.327721489 +0000
|
||||
+++ boost_1_81_0/boost/phoenix/stl/tuple.hpp 2023-03-15 09:32:02.787722445 +0000
|
||||
@@ -106,14 +106,16 @@
|
||||
tuple_detail::idx_wrap<N>(), t);
|
||||
}
|
||||
|
||||
+#ifndef BOOST_PHOENIX_NO_PREDEFINED_TERMINALS
|
||||
// Make unpacked argument placeholders
|
||||
namespace placeholders {
|
||||
#define BOOST_PP_LOCAL_LIMITS (1, BOOST_PHOENIX_ARG_LIMIT)
|
||||
#define BOOST_PP_LOCAL_MACRO(N) \
|
||||
- auto uarg##N = \
|
||||
+ const auto uarg##N = \
|
||||
boost::phoenix::get_<(N)-1>(boost::phoenix::placeholders::arg1);
|
||||
#include BOOST_PP_LOCAL_ITERATE()
|
||||
}
|
||||
+#endif
|
||||
}} // namespace boost::phoenix
|
||||
|
||||
#endif // C++ 14
|
11
boost.spec
11
boost.spec
@ -42,7 +42,7 @@ Name: boost
|
||||
%global real_name boost
|
||||
Summary: The free peer-reviewed portable C++ source libraries
|
||||
Version: 1.81.0
|
||||
Release: 0%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Boost and MIT and Python
|
||||
|
||||
# Replace each . with _ in %%{version}
|
||||
@ -147,6 +147,11 @@ Patch102: boost-1.76.0-random-test.patch
|
||||
# https://github.com/boostorg/interval/issues/29
|
||||
Patch104: boost-1.76.0-fix-narrowing-conversions-for-ppc.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2178210
|
||||
# https://github.com/boostorg/phoenix/issues/111
|
||||
# https://github.com/boostorg/phoenix/issues/115
|
||||
Patch112: boost-1.81-phoenix-multiple-defn.patch
|
||||
|
||||
%bcond_with tests
|
||||
%bcond_with docs_generated
|
||||
|
||||
@ -663,6 +668,7 @@ find ./boost -name '*.hpp' -perm /111 | xargs --no-run-if-empty chmod a-x
|
||||
%patch88 -p1
|
||||
%patch102 -p1
|
||||
%patch104 -p2
|
||||
%patch112 -p1
|
||||
|
||||
%build
|
||||
%set_build_flags
|
||||
@ -1277,6 +1283,9 @@ fi
|
||||
%{_mandir}/man1/b2.1*
|
||||
|
||||
%changelog
|
||||
* Wed Mar 15 2023 Jonathan Wakely <jwakely@fedoraproject.org> - 1.81.0-1
|
||||
- Add patch for Boost.Phoenix bugs (#2178210)
|
||||
|
||||
* Mon Feb 20 2023 Thomas Rodgers <trodgers@redhat.com> - 1.81.0-0
|
||||
- Rebase to 1.81.0
|
||||
See https://fedoraproject.org/wiki/Changes/F38Boost181
|
||||
|
Loading…
Reference in New Issue
Block a user