import boom-boot-1.0-1.el8

This commit is contained in:
CentOS Sources 2020-01-21 16:49:55 -05:00 committed by Andrew Lukoshko
commit 17093f833b
9 changed files with 335 additions and 0 deletions

1
.boom-boot.metadata Normal file
View File

@ -0,0 +1 @@
2234a16cde5e1634b25834a9891061c01bec1f48 SOURCES/boom-1.0.tar.gz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/boom-1.0.tar.gz

View File

@ -0,0 +1,16 @@
boom/command.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/boom/command.py b/boom/command.py
index a113c21..487b9bd 100644
--- a/boom/command.py
+++ b/boom/command.py
@@ -908,7 +908,7 @@ def _uname_heuristic(name, version_id):
}
if name in _name_to_uname:
- return "%s%s" % (_name_to_uname[name], version_id)
+ return "%s%s" % (_name_to_uname[name], version_id.replace(".", "_"))
return None

View File

@ -0,0 +1,32 @@
boom/_boom.py | 2 +-
boom/command.py | 4 +---
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/boom/_boom.py b/boom/_boom.py
index 4a84b78..d8fff54 100644
--- a/boom/_boom.py
+++ b/boom/_boom.py
@@ -629,7 +629,7 @@ class Selection(object):
os_version_id=args.os_version_id,
os_options=args.os_options,
os_uname_pattern=args.uname_pattern,
- host_id=args.host_profile)
+ host_id=args.host_id)
_log_debug("Initialised %s from arguments" % repr(s))
return s
diff --git a/boom/command.py b/boom/command.py
index 487b9bd..5a50f98 100644
--- a/boom/command.py
+++ b/boom/command.py
@@ -2787,9 +2787,7 @@ def main(args):
help="Take os-release values from the running host",
action="store_true")
parser.add_argument("-P", "--host-profile", metavar="PROFILE", type=str,
- help="A boom host profile identifier")
- parser.add_argument("--host-id", metavar="HOSTID", type=str,
- help="A host profile identifier")
+ help="A boom host profile identifier", dest="host_id")
parser.add_argument("--host-name", metavar="HOSTNAME", type=str,
help="The host name associated with a host profile")
parser.add_argument("-i", "--initrd", metavar="IMG", type=str,

View File

@ -0,0 +1,22 @@
.../entries/611f38fd887d41dea7eb3403b2730a76-12ce4b8-4.1.1-100.fc24.conf | 1 -
.../entries/611f38fd887d41dea7eb3403b2730a76-f2ebf21-3.10-23.el7.conf | 1 -
2 files changed, 2 deletions(-)
delete mode 120000 examples/entries/611f38fd887d41dea7eb3403b2730a76-12ce4b8-4.1.1-100.fc24.conf
delete mode 120000 examples/entries/611f38fd887d41dea7eb3403b2730a76-f2ebf21-3.10-23.el7.conf
diff --git a/examples/entries/611f38fd887d41dea7eb3403b2730a76-12ce4b8-4.1.1-100.fc24.conf b/examples/entries/611f38fd887d41dea7eb3403b2730a76-12ce4b8-4.1.1-100.fc24.conf
deleted file mode 120000
index 70b5b3f..0000000
--- a/examples/entries/611f38fd887d41dea7eb3403b2730a76-12ce4b8-4.1.1-100.fc24.conf
+++ /dev/null
@@ -1 +0,0 @@
-../../tests/loader/entries/611f38fd887d41dea7eb3403b2730a76-12ce4b8-4.1.1-100.fc24.conf
\ No newline at end of file
diff --git a/examples/entries/611f38fd887d41dea7eb3403b2730a76-f2ebf21-3.10-23.el7.conf b/examples/entries/611f38fd887d41dea7eb3403b2730a76-f2ebf21-3.10-23.el7.conf
deleted file mode 120000
index 4a62f7d..0000000
--- a/examples/entries/611f38fd887d41dea7eb3403b2730a76-f2ebf21-3.10-23.el7.conf
+++ /dev/null
@@ -1 +0,0 @@
-../../tests/loader/entries/611f38fd887d41dea7eb3403b2730a76-f2ebf21-3.10-23.el7.conf
\ No newline at end of file

View File

@ -0,0 +1,22 @@
etc/default/boom | 0
tests/bootloader_configs/boom_off/etc/default/boom | 0
tests/bootloader_configs/boom_on/etc/default/boom | 0
tests/bootloader_configs/no_grub_d/etc/default/boom | 0
4 files changed, 0 insertions(+), 0 deletions(-)
mode change 100755 => 100644 etc/default/boom
mode change 100755 => 100644 tests/bootloader_configs/boom_off/etc/default/boom
mode change 100755 => 100644 tests/bootloader_configs/boom_on/etc/default/boom
mode change 100755 => 100644 tests/bootloader_configs/no_grub_d/etc/default/boom
diff --git a/etc/default/boom b/etc/default/boom
old mode 100755
new mode 100644
diff --git a/tests/bootloader_configs/boom_off/etc/default/boom b/tests/bootloader_configs/boom_off/etc/default/boom
old mode 100755
new mode 100644
diff --git a/tests/bootloader_configs/boom_on/etc/default/boom b/tests/bootloader_configs/boom_on/etc/default/boom
old mode 100755
new mode 100644
diff --git a/tests/bootloader_configs/no_grub_d/etc/default/boom b/tests/bootloader_configs/no_grub_d/etc/default/boom
old mode 100755
new mode 100644

View File

@ -0,0 +1,18 @@
man/man8/boom.8 | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/man/man8/boom.8 b/man/man8/boom.8
index 28bad24..cfc736a 100644
--- a/man/man8/boom.8
+++ b/man/man8/boom.8
@@ -1114,8 +1114,8 @@ describing the properties of the configured host profiles.
The list of fields to display is given with \fB--options\fP as a comma
separated list of field names. To obtain a list of available fields run
-'\fBboom host list -o help\fP'. If the list of fields begins with the
-'\fB+\fP' character the specified fields are appended to the default
+\&'\fBboom host list -o help\fP'. If the list of fields begins with the
+\&'\fB+\fP' character the specified fields are appended to the default
field list. Otherwise the given list of fields replaces the default set
of report fields.

View File

@ -0,0 +1,13 @@
etc/default/boom | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/etc/default/boom b/etc/default/boom
index cd5f772..451cb37 100755
--- a/etc/default/boom
+++ b/etc/default/boom
@@ -1,3 +1,3 @@
-BOOM_USE_SUBMENU="yes"
+BOOM_USE_SUBMENU="no"
BOOM_SUBMENU_NAME="Snapshots"
-BOOM_ENABLE_GRUB="yes"
+BOOM_ENABLE_GRUB="no"

210
SPECS/boom-boot.spec Normal file
View File

@ -0,0 +1,210 @@
%global summary A set of libraries and tools for managing boot loader entries
%global sphinx_docs 1
Name: boom-boot
Version: 1.0
Release: 1%{?dist}
Summary: %{summary}
License: GPLv2
URL: https://github.com/snapshotmanager/boom
Source0: https://github.com/snapshotmanager/boom/archive/%{version}/boom-%{version}.tar.gz
Patch0: Disable-GRUB2-plugin-on-RHEL-8.patch
Patch1: 0001-boom.command-replace-.-with-_-in-automatic-uname-pat.patch
Patch2: 0002-boom.command-remove-duplicate-host-profile-argument.patch
Patch3: 0003-examples-Remove-dangling-symlinks-in-entries.patch
Patch4: 0004-etc-Remove-executable-permission-from-etc-default-bo.patch
Patch5: 0005-man-Fix-line-starting-with.patch
BuildArch: noarch
BuildRequires: python3-setuptools
BuildRequires: python3-devel
%if 0%{?sphinx_docs}
BuildRequires: python3-sphinx
%endif
Requires: python3-boom = %{version}-%{release}
Requires: %{name}-conf = %{version}-%{release}
%package -n python3-boom
Summary: %{summary}
# Unsupported on RHEL-8 :-(
#%%{?python_provide:%%python_provide python%%{__python_pkgversion}-boom}
# Do we need this??? IMO not
#Provides: python3-boom = %%{version}-%%{release}
Requires: %{__python3}
Recommends: (lvm2 or brtfs-progs)
Recommends: %{name}-conf = %{version}-%{release}
# There used to be a boom package in fedora, and there is boom packaged in
# copr. How to tell which one is installed? We need python3-boom and no boom
# only.
Conflicts: boom
%package conf
Summary: %{summary}
%package grub2
Summary: %{summary}
Supplements: (grub2 and boom-boot = %{version}-%{release})
%description
Boom is a boot manager for Linux systems using boot loaders that support
the BootLoader Specification for boot entry configuration.
Boom requires a BLS compatible boot loader to function: either the
systemd-boot project, or Grub2 with the BLS patch (Red Hat Grub2 builds
include this support in both Red Hat Enterprise Linux 7 and Fedora).
%description -n python3-boom
Boom is a boot manager for Linux systems using boot loaders that support
the BootLoader Specification for boot entry configuration.
Boom requires a BLS compatible boot loader to function: either the
systemd-boot project, or Grub2 with the BLS patch (Red Hat Grub2 builds
include this support in both Red Hat Enterprise Linux 7 and Fedora).
This package provides python3 boom module.
%description conf
Boom is a boot manager for Linux systems using boot loaders that support
the BootLoader Specification for boot entry configuration.
Boom requires a BLS compatible boot loader to function: either the
systemd-boot project, or Grub2 with the BLS patch (Red Hat Grub2 builds
include this support in both Red Hat Enterprise Linux 7 and Fedora).
This package provides configuration files for boom.
%description grub2
Boom is a boot manager for Linux systems using boot loaders that support
the BootLoader Specification for boot entry configuration.
Boom requires a BLS compatible boot loader to function: either the
systemd-boot project, or Grub2 with the BLS patch (Red Hat Grub2 builds
include this support in both Red Hat Enterprise Linux 7 and Fedora).
This package provides integration scripts for grub2 bootloader.
%prep
%setup -n boom-%{version}
# NOTE: Do not use backup extension - MANIFEST.in is picking them
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%build
%if 0%{?sphinx_docs}
make -C doc html
rm doc/_build/html/.buildinfo
mv doc/_build/html doc/html
rm -r doc/_build
%endif
%py3_build
%install
%py3_install
# Install Grub2 integration scripts
mkdir -p ${RPM_BUILD_ROOT}/etc/grub.d
mkdir -p ${RPM_BUILD_ROOT}/etc/default
install -m 755 etc/grub.d/42_boom ${RPM_BUILD_ROOT}/etc/grub.d
install -m 644 etc/default/boom ${RPM_BUILD_ROOT}/etc/default
# Make configuration directories
# mode 0700 - in line with /boot/grub2 directory:
install -d -m 700 ${RPM_BUILD_ROOT}/boot/boom/profiles
install -d -m 700 ${RPM_BUILD_ROOT}/boot/boom/hosts
install -d -m 700 ${RPM_BUILD_ROOT}/boot/loader/entries
install -m 644 examples/boom.conf ${RPM_BUILD_ROOT}/boot/boom
mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man8
mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man5
install -m 644 man/man8/boom.8 ${RPM_BUILD_ROOT}/%{_mandir}/man8
install -m 644 man/man5/boom.5 ${RPM_BUILD_ROOT}/%{_mandir}/man5
rm doc/Makefile
rm doc/conf.py
# Test suite currently does not operate in rpmbuild environment
#%%check
#%%{__python3} setup.py test
%files
%license COPYING
%doc README.md
%{_bindir}/boom
%doc %{_mandir}/man*/boom.*
%files -n python3-boom
%license COPYING
%doc README.md
%{python3_sitelib}/*
%doc doc
%doc examples
%doc tests
%files conf
%license COPYING
%doc README.md
%dir /boot/boom
%config(noreplace) /boot/boom/boom.conf
%dir /boot/boom/profiles
%dir /boot/boom/hosts
%dir /boot/loader/entries
%files grub2
%license COPYING
%doc README.md
%{_sysconfdir}/grub.d/42_boom
%config(noreplace) %{_sysconfdir}/default/boom
%changelog
* Fri Nov 29 2019 Marian Csontos <mcsontos@redhat.com> 1.0-1
- Update to new upstream release 1.0.
* Mon Jun 10 2019 Marian Csontos <mcsontos@redhat.com> 1.0-0.2.20190610git246b116
- Fix packaging issues.
* Mon May 06 2019 Marian Csontos <mcsontos@redhat.com> 1.0-0.1.20190329git6ff3e08
- Test upstream packaging.
* Mon Jan 14 2019 Marian Csontos <mcsontos@redhat.com> 0.9-7
- Reduce log level of "Could not load BootEntry" messages.
- Raise more appropriate LookupError on unknown BLS keys.
* Tue Dec 18 2018 Marian Csontos <mcsontos@redhat.com> 0.9-6
- Disable GRUB2 plugin on RHEL-8.
* Mon Sep 17 2018 Tomas Orsava <torsava@redhat.com> - 0.9-5
- Require the Python interpreter directly instead of using the package name
- Related: rhbz#1619153
* Tue Jul 17 2018 Marian Csontos <mcsontos@redhat.com> 0.9-4
- Change dependencies.
* Mon Jul 16 2018 Marian Csontos <mcsontos@redhat.com> 0.9-3
- Split executable, python module and configuration.
* Wed Jun 27 2018 Marian Csontos <mcsontos@redhat.com> 0.9-2
- Spin off grub2 into subpackage
* Wed Jun 27 2018 Marian Csontos <mcsontos@redhat.com> 0.9-1
- Update to new upstream 0.9.
- Fix boot_id caching.
* Fri Jun 08 2018 Marian Csontos <mcsontos@redhat.com> 0.8.5-6.2
- Remove example files from /boot/boom/profiles.
* Fri May 11 2018 Marian Csontos <mcsontos@redhat.com> 0.8.5-6.1
- Files in /boot are treated as configuration files.
* Thu Apr 26 2018 Marian Csontos <mcsontos@redhat.com> 0.8.5-6
- Package upstream version 0.8-5.6