v5.62
This commit is contained in:
parent
b7409fe4e5
commit
fc8573cf16
@ -1,42 +0,0 @@
|
||||
From 124dee151746b4a8a2e8a7194af78f2c82f75d79 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Wed, 3 Mar 2021 08:57:36 +0100
|
||||
Subject: [PATCH] media: rename local function conflicting with pause(2)
|
||||
|
||||
profiles/audio/media.c:1284:13: error: conflicting types for 'pause'; have '_Bool(void *)'
|
||||
1284 | static bool pause(void *user_data)
|
||||
| ^~~~~
|
||||
In file included from /usr/include/bits/sigstksz.h:24,
|
||||
from /usr/include/signal.h:315,
|
||||
from /usr/include/glib-2.0/glib/gbacktrace.h:36,
|
||||
from /usr/include/glib-2.0/glib.h:34,
|
||||
from profiles/audio/media.c:21:
|
||||
/usr/include/unistd.h:478:12: note: previous declaration of 'pause' with type 'int(void)'
|
||||
478 | extern int pause (void);
|
||||
| ^~~~~
|
||||
---
|
||||
profiles/audio/media.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/profiles/audio/media.c b/profiles/audio/media.c
|
||||
index c84bbe22dc..3d8c4b69c3 100644
|
||||
--- a/profiles/audio/media.c
|
||||
+++ b/profiles/audio/media.c
|
||||
@@ -1281,7 +1281,7 @@ static bool stop(void *user_data)
|
||||
return media_player_send(mp, "Stop");
|
||||
}
|
||||
|
||||
-static bool pause(void *user_data)
|
||||
+static bool pause_play(void *user_data)
|
||||
{
|
||||
struct media_player *mp = user_data;
|
||||
|
||||
@@ -1331,7 +1331,7 @@ static struct avrcp_player_cb player_cb = {
|
||||
.set_volume = set_volume,
|
||||
.play = play,
|
||||
.stop = stop,
|
||||
- .pause = pause,
|
||||
+ .pause = pause_play,
|
||||
.next = next,
|
||||
.previous = previous,
|
||||
};
|
16
bluez.spec
16
bluez.spec
@ -5,7 +5,7 @@
|
||||
%endif
|
||||
|
||||
Name: bluez
|
||||
Version: 5.61
|
||||
Version: 5.62
|
||||
Release: 1%{?dist}
|
||||
Summary: Bluetooth utilities
|
||||
License: GPLv2+
|
||||
@ -17,13 +17,12 @@ Source1: bluez.gitignore
|
||||
# https://github.com/hadess/bluez/commits/obex-5.46
|
||||
Patch1: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
# https://github.com/hadess/bluez/commits/systemd-hardening
|
||||
Patch10: 0001-build-Always-define-confdir-and-statedir.patch
|
||||
Patch11: 0002-systemd-Add-PrivateTmp-and-NoNewPrivileges-options.patch
|
||||
Patch12: 0003-systemd-Add-more-filesystem-lockdown.patch
|
||||
Patch13: 0004-systemd-More-lockdown.patch
|
||||
Patch14: 0005-media-rename-local-function-conflicting-with-pause-2.patch
|
||||
Patch2: 0001-build-Always-define-confdir-and-statedir.patch
|
||||
Patch3: 0002-systemd-Add-PrivateTmp-and-NoNewPrivileges-options.patch
|
||||
Patch4: 0003-systemd-Add-more-filesystem-lockdown.patch
|
||||
Patch5: 0004-systemd-More-lockdown.patch
|
||||
# Fix FTBFS with newer glib versions
|
||||
Patch16: 0002-Use-g_memdup2-everywhere.patch
|
||||
Patch6: 0002-Use-g_memdup2-everywhere.patch
|
||||
|
||||
BuildRequires: dbus-devel >= 1.6
|
||||
BuildRequires: glib2-devel
|
||||
@ -321,6 +320,9 @@ install emulator/btvirt ${RPM_BUILD_ROOT}/%{_libexecdir}/bluetooth/
|
||||
%{_userunitdir}/obex.service
|
||||
|
||||
%changelog
|
||||
* Wed Oct 13 2021 Peter Robinson <pbrobinson@fedoraproject.org> - 5.62-1
|
||||
- Update to 5.62
|
||||
|
||||
* Sun Aug 22 2021 Peter Robinson <pbrobinson@fedoraproject.org> - 5.61-1
|
||||
- Update to 5.61
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bluez-5.61.tar.xz) = a2318637258f9db0bf05fecbfbea2c3ca5e21867378e28ab4c77f658fe42f10c8c607939f2b437ec40d1ceb00b99f7916c0275faaedd9edd247f7dc91329937a
|
||||
SHA512 (bluez-5.62.tar.xz) = 8fb0b81e1d929d3eee3d70f457ce75dbcff4c2a8a728247fc950bbe11e84d83582345bfd433d2e2df7b5588eb0e42f286658a83c7332be84819d9df49a5707e8
|
||||
|
Loading…
Reference in New Issue
Block a user