v5.31
This commit is contained in:
parent
becc94c25d
commit
e21b8f7794
@ -1,36 +0,0 @@
|
||||
From 546ec13c0df3ecbd60e66213f4aef49f8f39dfeb Mon Sep 17 00:00:00 2001
|
||||
From: Szymon Janc <szymon.janc@tieto.com>
|
||||
Date: Thu, 9 Apr 2015 14:11:29 +0200
|
||||
Subject: [PATCH] profiles/network: Fix not being able to initiate connection
|
||||
|
||||
This was due to incorrect use of bt_uuid_to_uuid128 where source
|
||||
and destination parameters were reversed.
|
||||
---
|
||||
profiles/network/connection.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/profiles/network/connection.c b/profiles/network/connection.c
|
||||
index 2b07771..77e0a34 100644
|
||||
--- a/profiles/network/connection.c
|
||||
+++ b/profiles/network/connection.c
|
||||
@@ -293,7 +293,7 @@ static DBusMessage *local_connect(DBusConnection *conn,
|
||||
|
||||
id = get_pan_srv_id(svc);
|
||||
bt_uuid16_create(&uuid16, id);
|
||||
- bt_uuid_to_uuid128(&uuid128, &uuid16);
|
||||
+ bt_uuid_to_uuid128(&uuid16, &uuid128);
|
||||
|
||||
if (bt_uuid_to_string(&uuid128, uuid_str, MAX_LEN_UUID_STR) < 0)
|
||||
return btd_error_invalid_args(msg);
|
||||
@@ -447,7 +447,7 @@ static gboolean network_property_get_uuid(const GDBusPropertyTable *property,
|
||||
return FALSE;
|
||||
|
||||
bt_uuid16_create(&uuid16, nc->id);
|
||||
- bt_uuid_to_uuid128(&uuid128, &uuid16);
|
||||
+ bt_uuid_to_uuid128(&uuid16, &uuid128);
|
||||
bt_uuid_to_string(&uuid128, uuid_str, MAX_LEN_UUID_STR);
|
||||
|
||||
dbus_message_iter_append_basic(iter, DBUS_TYPE_STRING, &uuid_str);
|
||||
--
|
||||
2.4.2
|
||||
|
10
bluez.spec
10
bluez.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Bluetooth utilities
|
||||
Name: bluez
|
||||
Version: 5.30
|
||||
Release: 3%{?dist}
|
||||
Version: 5.31
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://www.bluez.org/
|
||||
@ -18,8 +18,6 @@ Patch2: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
||||
Patch3: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
Patch4: 0002-autopair-Don-t-handle-the-iCade.patch
|
||||
Patch5: 0004-agent-Assert-possible-infinite-loop.patch
|
||||
# Upstream
|
||||
Patch6: 0001-profiles-network-Fix-not-being-able-to-initiate-conn.patch
|
||||
|
||||
BuildRequires: git
|
||||
BuildRequires: dbus-devel >= 1.6
|
||||
@ -135,6 +133,7 @@ git am -p1 %{patches} < /dev/null
|
||||
--enable-sixaxis \
|
||||
--with-systemdsystemunitdir=%{_unitdir} \
|
||||
--with-systemduserunitdir=%{_userunitdir}
|
||||
|
||||
make %{?_smp_mflags} V=1
|
||||
|
||||
%install
|
||||
@ -240,6 +239,9 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
||||
/lib/udev/rules.d/97-hid2hci.rules
|
||||
|
||||
%changelog
|
||||
* Mon Jun 22 2015 Peter Robinson <pbrobinson@fedoraproject.org> 5.31-1
|
||||
- Update to 5.31
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.30-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user