Fix sixaxis patch

This commit is contained in:
Bastien Nocera 2010-03-26 10:47:21 +00:00
parent bf530b13c5
commit dac328c959

View File

@ -1,7 +1,7 @@
From 79c0b458e8dbb8784df4f7d2a3d7a4e154d58c65 Mon Sep 17 00:00:00 2001
From d2bd581a4b02d789dd2d28cbe4c58143beeb4f83 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH 1/2] Add sixaxis cable-pairing plugin
Subject: [PATCH] Add sixaxis cable-pairing plugin
Implement the old "sixpair" using libudev and libusb-1.0.
@ -17,7 +17,7 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index f8b1c11..a781a2c 100644
index 013f847..9511de6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -167,6 +167,11 @@ builtin_modules += service
@ -51,7 +51,7 @@ index f8b1c11..a781a2c 100644
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
diff --git a/acinclude.m4 b/acinclude.m4
index 2e4444d..6af5a21 100644
index f7bb047..25005c0 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -146,6 +146,24 @@ AC_DEFUN([AC_PATH_USB], [
@ -121,15 +121,15 @@ index 2e4444d..6af5a21 100644
+
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes")
@@ -339,4 +376,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
@@ -340,4 +377,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(DFUTOOL, test "${dfutool_enable}" = "yes" && test "${usb_found}" = "yes")
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index bbe29ea..87f146c 100644
index 055adb9..1116d5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,7 +40,10 @@ AC_PATH_GLIB
@ -535,5 +535,5 @@ index 0000000..3159ba4
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
--
1.6.6
1.7.0.1