Update patches

This commit is contained in:
Bastien Nocera 2011-08-01 23:38:07 +01:00
parent 2095cdf765
commit d9ce3927f6
2 changed files with 24 additions and 24 deletions

View File

@ -1,7 +1,7 @@
From 6c73cb253c7a3bdf9376b32c0f2d6d9e01b89653 Mon Sep 17 00:00:00 2001
From 3c2e6dab927acfa3dfbeb7b9bc910d6a9780b095 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin
Subject: [PATCH 1/2] Add sixaxis cable-pairing plugin
Implement the old "sixpair" using libudev and libusb-1.0.
@ -19,11 +19,11 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index fab05eb..a21bd7d 100644
index 7eadf82..aecc8f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -208,6 +208,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
health/hdp_util.h health/hdp_util.c
@@ -223,6 +223,11 @@ builtin_sources += thermometer/main.c \
thermometer/thermometer.h thermometer/thermometer.c
endif
+if CABLE
@ -34,7 +34,7 @@ index fab05eb..a21bd7d 100644
builtin_modules += hciops mgmtops
builtin_sources += plugins/hciops.c plugins/mgmtops.c
@@ -262,7 +267,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
@@ -282,7 +287,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/event.h src/event.c \
src/oob.h src/oob.c src/eir.h src/eir.c
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
@ -43,7 +43,7 @@ index fab05eb..a21bd7d 100644
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
@@ -377,7 +382,7 @@ EXTRA_DIST += doc/manager-api.txt \
@@ -397,7 +402,7 @@ EXTRA_DIST += doc/manager-api.txt \
AM_YFLAGS = -d
@ -53,7 +53,7 @@ index fab05eb..a21bd7d 100644
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
diff --git a/acinclude.m4 b/acinclude.m4
index af97cce..9d38789 100644
index 3cb9459..c23368b 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -155,6 +155,12 @@ AC_DEFUN([AC_PATH_UDEV], [
@ -77,7 +77,7 @@ index af97cce..9d38789 100644
alsa_enable=${alsa_found}
gstreamer_enable=${gstreamer_found}
audio_enable=yes
@@ -279,6 +286,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -286,6 +293,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
usb_enable=${enableval}
])
@ -88,7 +88,7 @@ index af97cce..9d38789 100644
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
tracer_enable=${enableval}
])
@@ -370,6 +381,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -385,6 +396,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
fi
@ -99,14 +99,14 @@ index af97cce..9d38789 100644
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
@@ -403,4 +418,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(DATAFILES, test "${datafiles_enable}" = "yes")
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
@@ -421,4 +436,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(DBUSOOBPLUGIN, test "${dbusoob_enable}" = "yes")
AM_CONDITIONAL(WIIMOTEPLUGIN, test "${wiimote_enable}" = "yes")
AM_CONDITIONAL(THERMOMETERPLUGIN, test "${thermometer_enable}" = "yes")
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index 8f54f60..6b0b024 100644
index 908ad55..bc2658c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,7 @@ AC_PATH_GSTREAMER
@ -506,10 +506,10 @@ index 0000000..e8cff76
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
diff --git a/src/adapter.c b/src/adapter.c
index 0909a22..8e63ee4 100644
index 4c88a0e..09d8392 100644
--- a/src/adapter.c
+++ b/src/adapter.c
@@ -1091,6 +1091,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
@@ -1092,6 +1092,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
return device;
}
@ -536,7 +536,7 @@ index 0909a22..8e63ee4 100644
struct btd_device *device,
gboolean remove_storage)
diff --git a/src/adapter.h b/src/adapter.h
index 38ea3ca..55c77aa 100644
index 687275a..7f7cb55 100644
--- a/src/adapter.h
+++ b/src/adapter.h
@@ -116,6 +116,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter, bdaddr_t *bdaddr,
@ -550,5 +550,5 @@ index 38ea3ca..55c77aa 100644
int adapter_update_local_name(struct btd_adapter *adapter, const char *name);
void adapter_service_insert(struct btd_adapter *adapter, void *rec);
--
1.7.5.4
1.7.6

View File

@ -1,4 +1,4 @@
From 65e42b8b83337533d2ef1d9651d614a5b927982a Mon Sep 17 00:00:00 2001
From 0080ce8a37152b0ee7750799e01de3bf810f8caf Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Wed, 21 Jul 2010 19:20:44 +0200
Subject: [PATCH] systemd: install systemd unit files
@ -18,10 +18,10 @@ that bluetoothd is not started twice at the same time.
create mode 100644 scripts/org.bluez.service
diff --git a/Makefile.am b/Makefile.am
index a21bd7d..e1c5c80 100644
index aecc8f2..6e18003 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -367,10 +367,25 @@ endif
@@ -387,10 +387,25 @@ endif
rules_DATA = $(foreach file,$(udev_files), scripts/97-$(notdir $(file)))
endif
@ -48,7 +48,7 @@ index a21bd7d..e1c5c80 100644
EXTRA_DIST += doc/manager-api.txt \
doc/adapter-api.txt doc/device-api.txt \
@@ -397,9 +412,9 @@ pkgconfigdir = $(libdir)/pkgconfig
@@ -417,9 +432,9 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = bluez.pc
@ -61,7 +61,7 @@ index a21bd7d..e1c5c80 100644
MAINTAINERCLEANFILES = Makefile.in \
aclocal.m4 configure config.h.in config.sub config.guess \
diff --git a/configure.ac b/configure.ac
index 6b0b024..861e1bc 100644
index bc2658c..b4502ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,5 +71,14 @@ if (test -n "${path_systemdunit}"); then
@ -117,5 +117,5 @@ index 0000000..dd7ae8f
+User=root
+SystemdService=dbus-org.bluez.service
--
1.7.5.4
1.7.6