Update to 5.12
- Sixaxis PS3 joypad support is now upstream
This commit is contained in:
parent
2a3b1dd3d1
commit
d707091ec7
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/bluez-5.9.tar.xz
|
/bluez-5.9.tar.xz
|
||||||
/bluez-5.10.tar.xz
|
/bluez-5.10.tar.xz
|
||||||
/bluez-5.11.tar.xz
|
/bluez-5.11.tar.xz
|
||||||
|
/bluez-5.12.tar.xz
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From 1da26fd3ce47728f423e290e3928257ead9baf76 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
|
||||||
Date: Sat, 7 Dec 2013 15:51:47 +0100
|
|
||||||
Subject: [PATCH] input: Fix crash when SDP record isn't available
|
|
||||||
|
|
||||||
On startup, if the SDP cache has been removed but the pairing
|
|
||||||
information is still present, we'd crash trying to access inside a
|
|
||||||
NULL record struct.
|
|
||||||
---
|
|
||||||
profiles/input/device.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/profiles/input/device.c b/profiles/input/device.c
|
|
||||||
index 6523161..8a28b0d 100644
|
|
||||||
--- a/profiles/input/device.c
|
|
||||||
+++ b/profiles/input/device.c
|
|
||||||
@@ -811,6 +811,9 @@ static struct input_device *input_device_new(struct btd_service *service)
|
|
||||||
struct input_device *idev;
|
|
||||||
char name[HCI_MAX_NAME_LENGTH + 1];
|
|
||||||
|
|
||||||
+ if (!rec)
|
|
||||||
+ return NULL;
|
|
||||||
+
|
|
||||||
idev = g_new0(struct input_device, 1);
|
|
||||||
bacpy(&idev->src, adapter_get_address(adapter));
|
|
||||||
bacpy(&idev->dst, device_get_address(device));
|
|
||||||
--
|
|
||||||
1.8.4.2
|
|
||||||
|
|
@ -1,56 +0,0 @@
|
|||||||
From 28419bdc2fd093bcbc68b629b9c7b8c295260c57 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Szymon Janc <szymon.janc@gmail.com>
|
|
||||||
Date: Mon, 9 Dec 2013 20:20:55 +0100
|
|
||||||
Subject: [PATCH 5/5] core: Fix crash due to agent callback freeing the agent
|
|
||||||
|
|
||||||
Similar fix was provided for simple_agent_reply in a2f5d438 but missed
|
|
||||||
pincode_reply case.
|
|
||||||
|
|
||||||
Fix following:
|
|
||||||
|
|
||||||
src/agent.c:agent_disconnect() Agent :1.48 disconnected
|
|
||||||
src/agent.c:set_default_agent() Default agent cleared
|
|
||||||
src/agent.c:agent_destroy() agent :1.48
|
|
||||||
src/agent.c:agent_unref() 0x4701c68: ref=1
|
|
||||||
Agent /org/bluez/agent replied with an error:
|
|
||||||
org.freedesktop.DBus.Error.NoReply, Message did not receive a reply
|
|
||||||
(timeout by message bus)
|
|
||||||
src/adapter.c:btd_adapter_pincode_reply() hci0 addr 6C:0E:0D:DB:D1:16
|
|
||||||
pinlen 0
|
|
||||||
src/agent.c:agent_unref() 0x4701c68: ref=0
|
|
||||||
src/adapter.c:btd_adapter_pincode_reply() hci0 addr 6C:0E:0D:DB:D1:16
|
|
||||||
pinlen 0
|
|
||||||
src/agent.c:agent_unref() 0x4701c68: ref=-1
|
|
||||||
src/adapter.c:btd_adapter_pincode_reply() hci0 addr 6C:0E:0D:DB:D1:16
|
|
||||||
pinlen 0
|
|
||||||
src/agent.c:agent_unref() 0x4701c68: ref=-2
|
|
||||||
...
|
|
||||||
---
|
|
||||||
src/agent.c | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/agent.c b/src/agent.c
|
|
||||||
index b292881..2ec3183 100644
|
|
||||||
--- a/src/agent.c
|
|
||||||
+++ b/src/agent.c
|
|
||||||
@@ -428,6 +428,9 @@ static void pincode_reply(DBusPendingCall *call, void *user_data)
|
|
||||||
* is only called after a reply has been received */
|
|
||||||
message = dbus_pending_call_steal_reply(call);
|
|
||||||
|
|
||||||
+ /* Protect from the callback freeing the agent */
|
|
||||||
+ agent_ref(agent);
|
|
||||||
+
|
|
||||||
dbus_error_init(&err);
|
|
||||||
if (dbus_set_error_from_message(&err, message)) {
|
|
||||||
error("Agent %s replied with an error: %s, %s",
|
|
||||||
@@ -467,6 +470,7 @@ done:
|
|
||||||
dbus_pending_call_cancel(req->call);
|
|
||||||
agent->request = NULL;
|
|
||||||
agent_request_free(req, TRUE);
|
|
||||||
+ agent_unref(agent);
|
|
||||||
}
|
|
||||||
|
|
||||||
static int pincode_request_new(struct agent_request *req, const char *device_path,
|
|
||||||
--
|
|
||||||
1.8.4.2
|
|
||||||
|
|
12
bluez.spec
12
bluez.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 5.11
|
Version: 5.12
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.bluez.org/
|
URL: http://www.bluez.org/
|
||||||
@ -11,17 +11,13 @@ URL: http://www.bluez.org/
|
|||||||
Source0: http://www.kernel.org/pub/linux/bluetooth/bluez-%{version}.tar.xz
|
Source0: http://www.kernel.org/pub/linux/bluetooth/bluez-%{version}.tar.xz
|
||||||
Source1: bluez.gitignore
|
Source1: bluez.gitignore
|
||||||
|
|
||||||
## https://bugzilla.redhat.com/show_bug.cgi?id=874015#c0
|
|
||||||
Patch1: playstation-peripheral-pugin-v5.x.patch
|
|
||||||
## Ubuntu patches
|
## Ubuntu patches
|
||||||
Patch2: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
Patch2: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
||||||
# Non-upstream
|
# Non-upstream
|
||||||
Patch3: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
Patch3: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
||||||
Patch4: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
Patch4: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||||
Patch5: 0002-autopair-Don-t-handle-the-iCade.patch
|
Patch5: 0002-autopair-Don-t-handle-the-iCade.patch
|
||||||
Patch6: 0003-input-Fix-crash-when-SDP-record-isn-t-available.patch
|
|
||||||
Patch7: 0004-agent-Assert-possible-infinite-loop.patch
|
Patch7: 0004-agent-Assert-possible-infinite-loop.patch
|
||||||
Patch8: 0005-core-Fix-crash-due-to-agent-callback-freeing-the-age.patch
|
|
||||||
|
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
BuildRequires: dbus-devel >= 0.90
|
BuildRequires: dbus-devel >= 0.90
|
||||||
@ -233,6 +229,10 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
|||||||
/lib/udev/rules.d/97-hid2hci.rules
|
/lib/udev/rules.d/97-hid2hci.rules
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 11 2013 Bastien Nocera <bnocera@redhat.com> 5.12-1
|
||||||
|
- Update to 5.12
|
||||||
|
- Sixaxis PS3 joypad support is now upstream
|
||||||
|
|
||||||
* Tue Dec 10 2013 Bastien Nocera <bnocera@redhat.com> 5.11-2
|
* Tue Dec 10 2013 Bastien Nocera <bnocera@redhat.com> 5.11-2
|
||||||
- Add crasher fixes (rhbz #1027365)
|
- Add crasher fixes (rhbz #1027365)
|
||||||
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user