Update to 5.13
- Enable sixaxis plugin by default
This commit is contained in:
parent
1a7d8be866
commit
ce5d6cdda8
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/bluez-5.10.tar.xz
|
||||
/bluez-5.11.tar.xz
|
||||
/bluez-5.12.tar.xz
|
||||
/bluez-5.13.tar.xz
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 7416e015c0995e0ab24e9a42edde33151e22b315 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 12 Dec 2013 17:14:31 +0100
|
||||
Subject: [PATCH] sixaxis: Fix device detection
|
||||
|
||||
After searching past the end of the structure, the loop sometimes
|
||||
found matches in the daemon's address space...
|
||||
|
||||
This fixes the loop to end after the elements have been exhausted.
|
||||
---
|
||||
plugins/sixaxis.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/plugins/sixaxis.c b/plugins/sixaxis.c
|
||||
index 45fa170..1154c15 100644
|
||||
--- a/plugins/sixaxis.c
|
||||
+++ b/plugins/sixaxis.c
|
||||
@@ -301,7 +301,7 @@ static int get_supported_device(struct udev_device *udevice, uint16_t *bus)
|
||||
struct udev_device *hid_parent;
|
||||
uint16_t vid, pid;
|
||||
const char *hid_id;
|
||||
- int i;
|
||||
+ guint i;
|
||||
|
||||
hid_parent = udev_device_get_parent_with_subsystem_devtype(udevice,
|
||||
"hid", NULL);
|
||||
@@ -313,7 +313,7 @@ static int get_supported_device(struct udev_device *udevice, uint16_t *bus)
|
||||
if (sscanf(hid_id, "%hx:%hx:%hx", bus, &vid, &pid) != 3)
|
||||
return -1;
|
||||
|
||||
- for (i = 0; G_N_ELEMENTS(devices); i++) {
|
||||
+ for (i = 0; i < G_N_ELEMENTS(devices); i++) {
|
||||
if (devices[i].vid == vid && devices[i].pid == pid)
|
||||
return i;
|
||||
}
|
||||
--
|
||||
1.8.4.2
|
||||
|
10
bluez.spec
10
bluez.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Bluetooth utilities
|
||||
Name: bluez
|
||||
Version: 5.12
|
||||
Release: 2%{?dist}
|
||||
Version: 5.13
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://www.bluez.org/
|
||||
@ -18,7 +18,6 @@ Patch3: 0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch
|
||||
Patch4: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
Patch5: 0002-autopair-Don-t-handle-the-iCade.patch
|
||||
Patch7: 0004-agent-Assert-possible-infinite-loop.patch
|
||||
Patch8: 0001-sixaxis-Fix-device-detection.patch
|
||||
|
||||
BuildRequires: git
|
||||
BuildRequires: dbus-devel >= 0.90
|
||||
@ -135,6 +134,7 @@ git am -p1 %{patches} < /dev/null
|
||||
libtoolize -f -c
|
||||
autoreconf -f -i
|
||||
%configure --enable-cups --enable-tools --enable-library \
|
||||
--enable-sixaxis \
|
||||
--with-systemdsystemunitdir=%{_unitdir} \
|
||||
--with-systemduserunitdir=%{_userunitdir}
|
||||
make %{?_smp_mflags} V=1
|
||||
@ -230,6 +230,10 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
||||
/lib/udev/rules.d/97-hid2hci.rules
|
||||
|
||||
%changelog
|
||||
* Mon Jan 06 2014 Bastien Nocera <bnocera@redhat.com> 5.13-1
|
||||
- Update to 5.13
|
||||
- Enable sixaxis plugin by default
|
||||
|
||||
* Thu Dec 12 2013 Bastien Nocera <bnocera@redhat.com> 5.12-2
|
||||
- This update fixes Sixaxis PS3 joypad detection
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user