- Update to 4.55

- Add libcap-ng support to drop capabilities (#517660)
This commit is contained in:
Bastien Nocera 2009-10-05 10:01:03 +00:00
parent 91c9dbf4b6
commit c7a736cb45
4 changed files with 19 additions and 14 deletions

View File

@ -1 +1 @@
bluez-4.54.tar.gz
bluez-4.55.tar.gz

View File

@ -1,4 +1,4 @@
From 0cb2225079979cc3c85c02a981ebad7742c1ff72 Mon Sep 17 00:00:00 2001
From df50f89ea8967fa0ba0d21aac0ce905801d31c70 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin
@ -18,7 +18,7 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index 09eb7ec..ad6fe25 100644
index c8337d6..0bdf694 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -162,6 +162,15 @@ builtin_modules += service
@ -38,7 +38,7 @@ index 09eb7ec..ad6fe25 100644
builtin_sources += plugins/hciops.c
diff --git a/acinclude.m4 b/acinclude.m4
index 44f7c72..465fb67 100644
index e7d1c32..3feddf8 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -142,6 +142,12 @@ AC_DEFUN([AC_PATH_USB], [
@ -54,7 +54,7 @@ index 44f7c72..465fb67 100644
AC_DEFUN([AC_PATH_NETLINK], [
PKG_CHECK_MODULES(NETLINK, libnl-1, netlink_found=yes, netlink_found=no)
AC_SUBST(NETLINK_CFLAGS)
@@ -163,6 +169,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -170,6 +176,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
netlink_enable=no
hal_enable=${hal_found}
usb_enable=${usb_found}
@ -62,7 +62,7 @@ index 44f7c72..465fb67 100644
alsa_enable=${alsa_found}
gstreamer_enable=${gstreamer_found}
audio_enable=yes
@@ -228,6 +235,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -239,6 +246,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
usb_enable=${enableval}
])
@ -73,8 +73,8 @@ index 44f7c72..465fb67 100644
AC_ARG_ENABLE(netlink, AC_HELP_STRING([--enable-netlink], [enable NETLINK support]), [
netlink_enable=${enableval}
])
@@ -311,6 +322,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
@@ -326,6 +337,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AC_DEFINE(HAVE_CAPNG, 1, [Define to 1 if you have capabilities library.])
fi
+ if (test "${cable_enable}" = "yes" && test "${cable_found}" = "yes"); then
@ -84,14 +84,14 @@ index 44f7c72..465fb67 100644
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
AM_CONDITIONAL(NETLINK, test "${netlink_enable}" = "yes" && test "${netlink_found}" = "yes")
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
@@ -335,4 +350,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
@@ -350,4 +365,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(DFUTOOL, test "${dfutool_enable}" = "yes" && test "${usb_found}" = "yes")
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index 9e5279d..8b17659 100644
index b93cca0..5df134f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,7 @@ AC_PATH_GLIB
@ -101,7 +101,7 @@ index 9e5279d..8b17659 100644
+AC_PATH_CABLE
AC_PATH_NETLINK
AC_PATH_SNDFILE
AC_PATH_CAPNG
diff --git a/plugins/cable.c b/plugins/cable.c
new file mode 100644
index 0000000..6e81ba0
@ -471,5 +471,5 @@ index 0000000..6e81ba0
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
--
1.6.2.5
1.6.4.4

View File

@ -1,6 +1,6 @@
Summary: Bluetooth utilities
Name: bluez
Version: 4.54
Version: 4.55
Release: 1%{?dist}
License: GPLv2+
Group: Applications/System
@ -32,6 +32,7 @@ BuildRequires: dbus-devel >= 0.90
BuildRequires: libusb-devel, glib2-devel, alsa-lib-devel
BuildRequires: gstreamer-plugins-base-devel, gstreamer-devel
BuildRequires: libsndfile-devel
BuildRequires: libcap-ng-devel
# For cable pairing
BuildRequires: libgudev-devel
%ifnarch s390 s390x
@ -271,6 +272,10 @@ fi
%config(noreplace) %{_sysconfdir}/sysconfig/pand
%changelog
* Mon Oct 05 2009 Bastien Nocera <bnocera@redhat.com> 4.55-1
- Update to 4.55
- Add libcap-ng support to drop capabilities (#517660)
* Thu Sep 24 2009 Bastien Nocera <bnocera@redhat.com> 4.54-1
- Update to 4.54

View File

@ -1 +1 @@
a2d5a88fb1058f2b0422bfcce335b3a2 bluez-4.54.tar.gz
febbbbb512eb5ed9c28aa8008ae952a7 bluez-4.55.tar.gz