Update to 4.94
This commit is contained in:
parent
c7f3f6579d
commit
c0dc6a5c02
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@ bluez-4.70.tar.gz
|
|||||||
/bluez-4.89.tar.gz
|
/bluez-4.89.tar.gz
|
||||||
/bluez-4.90.tar.gz
|
/bluez-4.90.tar.gz
|
||||||
/bluez-4.93.tar.gz
|
/bluez-4.93.tar.gz
|
||||||
|
/bluez-4.94.tar.gz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From cdf56c93397ebd284b7f7d369af389d5b82919f5 Mon Sep 17 00:00:00 2001
|
From 61443ce94d503c359a99e7885fe489cfcff380fa Mon Sep 17 00:00:00 2001
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
From: Bastien Nocera <hadess@hadess.net>
|
||||||
Date: Tue, 1 Sep 2009 17:32:48 +0100
|
Date: Tue, 1 Sep 2009 17:32:48 +0100
|
||||||
Subject: [PATCH 1/3] Add sixaxis cable-pairing plugin
|
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
||||||
|
|
||||||
Implement the old "sixpair" using libudev and libusb-1.0.
|
Implement the old "sixpair" using libudev and libusb-1.0.
|
||||||
|
|
||||||
@ -21,10 +21,10 @@ address, and added to the database of the current default adapter.
|
|||||||
create mode 100644 plugins/cable.c
|
create mode 100644 plugins/cable.c
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
index 5f96975..6044082 100644
|
index 2f3051c..145b26d 100644
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -197,6 +197,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
|
@@ -202,6 +202,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
|
||||||
health/hdp_util.h health/hdp_util.c
|
health/hdp_util.h health/hdp_util.c
|
||||||
endif
|
endif
|
||||||
|
|
||||||
@ -36,16 +36,16 @@ index 5f96975..6044082 100644
|
|||||||
builtin_modules += hciops mgmtops
|
builtin_modules += hciops mgmtops
|
||||||
builtin_sources += plugins/hciops.c plugins/mgmtops.c
|
builtin_sources += plugins/hciops.c plugins/mgmtops.c
|
||||||
|
|
||||||
@@ -242,7 +247,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
@@ -256,7 +261,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||||
src/dbus-common.c src/dbus-common.h \
|
src/event.h src/event.c \
|
||||||
src/event.h src/event.c
|
src/oob.h src/oob.c src/eir.h src/eir.c
|
||||||
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
||||||
- @CAPNG_LIBS@ -ldl -lrt
|
- @CAPNG_LIBS@ -ldl -lrt
|
||||||
+ @CAPNG_LIBS@ @CABLE_LIBS@ -ldl -lrt
|
+ @CAPNG_LIBS@ @CABLE_LIBS@ -ldl -lrt
|
||||||
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
||||||
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
|
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
|
||||||
|
|
||||||
@@ -358,7 +363,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
@@ -373,7 +378,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||||
|
|
||||||
AM_YFLAGS = -d
|
AM_YFLAGS = -d
|
||||||
|
|
||||||
@ -55,11 +55,11 @@ index 5f96975..6044082 100644
|
|||||||
|
|
||||||
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
||||||
diff --git a/acinclude.m4 b/acinclude.m4
|
diff --git a/acinclude.m4 b/acinclude.m4
|
||||||
index 287f07d..aab0c15 100644
|
index d77937b..7e6422e 100644
|
||||||
--- a/acinclude.m4
|
--- a/acinclude.m4
|
||||||
+++ b/acinclude.m4
|
+++ b/acinclude.m4
|
||||||
@@ -146,6 +146,12 @@ AC_DEFUN([AC_PATH_USB], [
|
@@ -152,6 +152,12 @@ AC_DEFUN([AC_PATH_UDEV], [
|
||||||
[Define to 1 if you need the usb_interrupt_read() function.]))
|
AC_SUBST(UDEV_LIBS)
|
||||||
])
|
])
|
||||||
|
|
||||||
+AC_DEFUN([AC_PATH_CABLE], [
|
+AC_DEFUN([AC_PATH_CABLE], [
|
||||||
@ -71,7 +71,7 @@ index 287f07d..aab0c15 100644
|
|||||||
AC_DEFUN([AC_PATH_SNDFILE], [
|
AC_DEFUN([AC_PATH_SNDFILE], [
|
||||||
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
|
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
|
||||||
AC_SUBST(SNDFILE_CFLAGS)
|
AC_SUBST(SNDFILE_CFLAGS)
|
||||||
@@ -168,6 +174,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -183,6 +189,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
sndfile_enable=${sndfile_found}
|
sndfile_enable=${sndfile_found}
|
||||||
hal_enable=no
|
hal_enable=no
|
||||||
usb_enable=${usb_found}
|
usb_enable=${usb_found}
|
||||||
@ -79,7 +79,7 @@ index 287f07d..aab0c15 100644
|
|||||||
alsa_enable=${alsa_found}
|
alsa_enable=${alsa_found}
|
||||||
gstreamer_enable=${gstreamer_found}
|
gstreamer_enable=${gstreamer_found}
|
||||||
audio_enable=yes
|
audio_enable=yes
|
||||||
@@ -250,6 +257,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -277,6 +284,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
usb_enable=${enableval}
|
usb_enable=${enableval}
|
||||||
])
|
])
|
||||||
|
|
||||||
@ -90,7 +90,7 @@ index 287f07d..aab0c15 100644
|
|||||||
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
|
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
|
||||||
tracer_enable=${enableval}
|
tracer_enable=${enableval}
|
||||||
])
|
])
|
||||||
@@ -341,6 +352,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -372,6 +383,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -101,23 +101,23 @@ index 287f07d..aab0c15 100644
|
|||||||
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
||||||
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
||||||
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
||||||
@@ -372,4 +387,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -406,4 +421,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
|
|
||||||
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
||||||
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
|
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
|
||||||
|
AM_CONDITIONAL(DBUSOOBPLUGIN, test "${dbusoob_enable}" = "yes")
|
||||||
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
||||||
])
|
])
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
index 1ec2dfd..b4c2482 100644
|
index 987b7e1..aece18b 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -40,6 +40,7 @@ AC_PATH_GLIB
|
@@ -46,6 +46,7 @@ AC_PATH_GSTREAMER
|
||||||
AC_PATH_ALSA
|
|
||||||
AC_PATH_GSTREAMER
|
|
||||||
AC_PATH_USB
|
AC_PATH_USB
|
||||||
+AC_PATH_CABLE
|
AC_PATH_UDEV
|
||||||
AC_PATH_SNDFILE
|
AC_PATH_SNDFILE
|
||||||
|
+AC_PATH_CABLE
|
||||||
AC_PATH_OUI
|
AC_PATH_OUI
|
||||||
|
AC_PATH_READLINE
|
||||||
|
|
||||||
diff --git a/plugins/cable.c b/plugins/cable.c
|
diff --git a/plugins/cable.c b/plugins/cable.c
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
@ -508,10 +508,10 @@ index 0000000..e8cff76
|
|||||||
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
|
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
|
||||||
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
|
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
|
||||||
diff --git a/src/adapter.c b/src/adapter.c
|
diff --git a/src/adapter.c b/src/adapter.c
|
||||||
index 87a8beb..6851b23 100644
|
index 5598d17..86dfccc 100644
|
||||||
--- a/src/adapter.c
|
--- a/src/adapter.c
|
||||||
+++ b/src/adapter.c
|
+++ b/src/adapter.c
|
||||||
@@ -1072,6 +1072,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
|
@@ -1081,6 +1081,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
|
||||||
return device;
|
return device;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -538,10 +538,10 @@ index 87a8beb..6851b23 100644
|
|||||||
struct btd_device *device,
|
struct btd_device *device,
|
||||||
gboolean remove_storage)
|
gboolean remove_storage)
|
||||||
diff --git a/src/adapter.h b/src/adapter.h
|
diff --git a/src/adapter.h b/src/adapter.h
|
||||||
index 250c65e..32725eb 100644
|
index 13971bf..c85fa66 100644
|
||||||
--- a/src/adapter.h
|
--- a/src/adapter.h
|
||||||
+++ b/src/adapter.h
|
+++ b/src/adapter.h
|
||||||
@@ -145,6 +145,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter, bdaddr_t *bdaddr,
|
@@ -114,6 +114,9 @@ void adapter_update_found_devices(struct btd_adapter *adapter, bdaddr_t *bdaddr,
|
||||||
int adapter_remove_found_device(struct btd_adapter *adapter, bdaddr_t *bdaddr);
|
int adapter_remove_found_device(struct btd_adapter *adapter, bdaddr_t *bdaddr);
|
||||||
void adapter_emit_device_found(struct btd_adapter *adapter,
|
void adapter_emit_device_found(struct btd_adapter *adapter,
|
||||||
struct remote_dev_info *dev);
|
struct remote_dev_info *dev);
|
||||||
@ -549,10 +549,10 @@ index 250c65e..32725eb 100644
|
|||||||
+ struct btd_adapter *adapter,
|
+ struct btd_adapter *adapter,
|
||||||
+ struct btd_device *device);
|
+ struct btd_device *device);
|
||||||
void adapter_mode_changed(struct btd_adapter *adapter, uint8_t scan_mode);
|
void adapter_mode_changed(struct btd_adapter *adapter, uint8_t scan_mode);
|
||||||
void adapter_update_local_name(struct btd_adapter *adapter, const char *name);
|
int adapter_update_local_name(struct btd_adapter *adapter, const char *name);
|
||||||
void adapter_service_insert(struct btd_adapter *adapter, void *rec);
|
void adapter_service_insert(struct btd_adapter *adapter, void *rec);
|
||||||
diff --git a/src/manager.c b/src/manager.c
|
diff --git a/src/manager.c b/src/manager.c
|
||||||
index e805e0c..254ace4 100644
|
index dedec8b..d18d588 100644
|
||||||
--- a/src/manager.c
|
--- a/src/manager.c
|
||||||
+++ b/src/manager.c
|
+++ b/src/manager.c
|
||||||
@@ -262,6 +262,11 @@ static void manager_set_default_adapter(int id)
|
@@ -262,6 +262,11 @@ static void manager_set_default_adapter(int id)
|
||||||
@ -568,7 +568,7 @@ index e805e0c..254ace4 100644
|
|||||||
{
|
{
|
||||||
uint16_t dev_id = adapter_get_dev_id(adapter);
|
uint16_t dev_id = adapter_get_dev_id(adapter);
|
||||||
diff --git a/src/manager.h b/src/manager.h
|
diff --git a/src/manager.h b/src/manager.h
|
||||||
index 05c38b3..4f92d2f 100644
|
index 90d3690..f5f9757 100644
|
||||||
--- a/src/manager.h
|
--- a/src/manager.h
|
||||||
+++ b/src/manager.h
|
+++ b/src/manager.h
|
||||||
@@ -35,6 +35,7 @@ void manager_cleanup(DBusConnection *conn, const char *path);
|
@@ -35,6 +35,7 @@ void manager_cleanup(DBusConnection *conn, const char *path);
|
||||||
@ -580,5 +580,5 @@ index 05c38b3..4f92d2f 100644
|
|||||||
GSList *manager_get_adapters(void);
|
GSList *manager_get_adapters(void);
|
||||||
struct btd_adapter *btd_manager_register_adapter(int id);
|
struct btd_adapter *btd_manager_register_adapter(int id);
|
||||||
--
|
--
|
||||||
1.7.3.2
|
1.7.5.1
|
||||||
|
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
From 1dea0eac302036bd165f9e3e386c40da25512005 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
|
||||||
Date: Mon, 8 Nov 2010 16:43:42 +0000
|
|
||||||
Subject: [PATCH 3/3] Handle ISO8859-1 device names
|
|
||||||
|
|
||||||
http://thread.gmane.org/gmane.linux.bluez.kernel/1687
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=450081
|
|
||||||
---
|
|
||||||
src/event.c | 13 ++++++++++---
|
|
||||||
1 files changed, 10 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/event.c b/src/event.c
|
|
||||||
index 5d0bf6d..dc58dbd 100644
|
|
||||||
--- a/src/event.c
|
|
||||||
+++ b/src/event.c
|
|
||||||
@@ -652,9 +652,16 @@ void btd_event_remote_name(bdaddr_t *local, bdaddr_t *peer, uint8_t status,
|
|
||||||
|
|
||||||
/* It's ok to cast end between const and non-const since
|
|
||||||
* we know it points to inside of name which is non-const */
|
|
||||||
- if (!g_utf8_validate(name, -1, (const char **) &end))
|
|
||||||
- *end = '\0';
|
|
||||||
-
|
|
||||||
+ if (!g_utf8_validate(name, -1, (const char **) &end)) {
|
|
||||||
+ char *utf8_name;
|
|
||||||
+
|
|
||||||
+ utf8_name = g_convert(name, -1, "UTF-8", "ISO-8859-1", NULL, NULL, NULL);
|
|
||||||
+ if (utf8_name) {
|
|
||||||
+ memcpy(name, utf8_name, 248);
|
|
||||||
+ g_free(utf8_name);
|
|
||||||
+ } else
|
|
||||||
+ *end = '\0';
|
|
||||||
+ }
|
|
||||||
write_device_name(local, peer, name);
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.3.2
|
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 4.93
|
Version: 4.94
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -12,6 +12,8 @@ Source6: pand.conf
|
|||||||
Source7: rfcomm.init
|
Source7: rfcomm.init
|
||||||
Source8: bluez-uinput.modules
|
Source8: bluez-uinput.modules
|
||||||
|
|
||||||
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/13255
|
||||||
|
Patch1: 0001-adaptername-Move-adapter-naming-into-a-plugin.patch
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=498756
|
# https://bugzilla.redhat.com/show_bug.cgi?id=498756
|
||||||
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
||||||
@ -126,6 +128,7 @@ This includes hidd, dund and pand.
|
|||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .adaptername
|
||||||
%patch4 -p1 -b .socket-mobile
|
%patch4 -p1 -b .socket-mobile
|
||||||
%patch5 -p1 -b .cable-pairing
|
%patch5 -p1 -b .cable-pairing
|
||||||
%patch6 -p1 -b .systemd
|
%patch6 -p1 -b .systemd
|
||||||
@ -292,6 +295,9 @@ fi
|
|||||||
%{_mandir}/man1/pand.1.gz
|
%{_mandir}/man1/pand.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 01 2011 Bastien Nocera <bnocera@redhat.com> 4.94-1
|
||||||
|
- Update to 4.94
|
||||||
|
|
||||||
* Wed May 25 2011 Bastien Nocera <bnocera@redhat.com> 4.93-1
|
* Wed May 25 2011 Bastien Nocera <bnocera@redhat.com> 4.93-1
|
||||||
- Update to 4.93
|
- Update to 4.93
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user