- Update to 4.5
- Fix initscript to actually start bluetoothd by hand - Add chkconfig information to the initscript
This commit is contained in:
parent
1e336b23d9
commit
bf94f3eced
@ -1 +1 @@
|
||||
bluez-4.4.tar.gz
|
||||
bluez-4.5.tar.gz
|
||||
|
@ -1,5 +1,9 @@
|
||||
#!/bin/sh
|
||||
|
||||
#
|
||||
# chkconfig: 345 50 83
|
||||
# description: Bluetooth services for service discovery, authentication, \
|
||||
# Human Interface Devices, etc.
|
||||
#
|
||||
### BEGIN INIT INFO
|
||||
# Required-Start: $syslog messagebus
|
||||
# Short-Description: Bluetooth services
|
||||
@ -15,6 +19,9 @@
|
||||
start()
|
||||
{
|
||||
echo -n $"Starting Bluetooth services:"
|
||||
daemon /usr/sbin/bluetoothd
|
||||
RETVAL=$?
|
||||
[ $RETVAL = 0 ] && touch /var/lock/subsys/bluetoothd
|
||||
[ "$HID2HCI_ENABLE" = "true" ] && hid2hci --tohci > /dev/null 2>&1 || :
|
||||
touch /var/lock/subsys/bluetooth
|
||||
echo ""
|
||||
@ -25,7 +32,10 @@ stop()
|
||||
{
|
||||
echo -n "Stopping Bluetooth services:"
|
||||
[ "$HID2HCI_UNDO" = "true" ] && hid2hci --tohid > /dev/null 2>&1 || :
|
||||
killproc bluetoothd
|
||||
RETVAL=$?
|
||||
rm -f /var/lock/subsys/bluetooth
|
||||
rm -f /var/lock/subsys/bluetoothd
|
||||
echo ""
|
||||
return $RETVAL
|
||||
}
|
||||
@ -45,7 +55,7 @@ case "$1" in
|
||||
[ -e /var/lock/subsys/bluetooth ] && (stop; start)
|
||||
;;
|
||||
status)
|
||||
status hcid
|
||||
status bluetoothd
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
|
@ -1,35 +0,0 @@
|
||||
commit af3684270a0fe4a753e5199dfa58acd7f9b2038c
|
||||
Author: Marcel Holtmann <marcel@holtmann.org>
|
||||
Date: Wed Sep 10 00:19:00 2008 +0200
|
||||
|
||||
The input connect method takes no parameters
|
||||
|
||||
diff --git a/input/device.c b/input/device.c
|
||||
index 0283918..d079831 100644
|
||||
--- a/input/device.c
|
||||
+++ b/input/device.c
|
||||
@@ -912,14 +912,9 @@ static DBusMessage *device_connect(DBusConnection *conn,
|
||||
struct input_device *idev = data;
|
||||
struct input_conn *iconn;
|
||||
struct fake_input *fake;
|
||||
- const char *svc;
|
||||
int err;
|
||||
|
||||
- if (dbus_message_get_args(msg, NULL, DBUS_TYPE_STRING, &svc,
|
||||
- DBUS_TYPE_INVALID) == FALSE)
|
||||
- return NULL;
|
||||
-
|
||||
- iconn = find_connection(idev->connections, svc);
|
||||
+ iconn = find_connection(idev->connections, "HID");
|
||||
if (!iconn)
|
||||
return not_supported(msg);
|
||||
|
||||
@@ -1012,7 +1007,7 @@ static void device_unregister(void *data)
|
||||
}
|
||||
|
||||
static GDBusMethodTable device_methods[] = {
|
||||
- { "Connect", "s", "", device_connect,
|
||||
+ { "Connect", "", "", device_connect,
|
||||
G_DBUS_METHOD_FLAG_ASYNC },
|
||||
{ "Disconnect", "", "", device_disconnect },
|
||||
{ "IsConnected", "", "b", device_is_connected },
|
11
bluez.spec
11
bluez.spec
@ -1,14 +1,13 @@
|
||||
Summary: Bluetooth libraries and utilities
|
||||
Name: bluez
|
||||
Version: 4.4
|
||||
Release: 2%{?dist}
|
||||
Version: 4.5
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
|
||||
Source1: bluetooth.init
|
||||
Source2: bluetooth.conf
|
||||
Patch1: bluez-utils-oui-usage.patch
|
||||
Patch2: bluez-4.4-input.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
URL: http://www.bluez.org/
|
||||
@ -94,7 +93,6 @@ Bluetooth utilities (bluez-utils):
|
||||
|
||||
%setup -q
|
||||
%patch1 -p0 -b .oui
|
||||
%patch2 -p1 -b .input
|
||||
|
||||
%build
|
||||
%configure --enable-cups --enable-hid2hci --enable-dfutool --enable-tools --enable-bccmd --enable-gstreamer --enable-hidd --enable-pand --enable-dund
|
||||
@ -189,6 +187,11 @@ fi
|
||||
%{_libdir}/alsa-lib/*.so
|
||||
|
||||
%changelog
|
||||
* Fri Sep 12 2008 - Bastien Nocera <bnocera@redhat.com> - 4.5-1
|
||||
- Update to 4.5
|
||||
- Fix initscript to actually start bluetoothd by hand
|
||||
- Add chkconfig information to the initscript
|
||||
|
||||
* Tue Sep 09 2008 - David Woodhouse <David.Woodhouse@intel.com> - 4.4-2
|
||||
- Fix rpmlint problems
|
||||
- Fix input device handling
|
||||
|
@ -1 +0,0 @@
|
||||
bluez-4_4-2_fc10:HEAD:bluez-4.4-2.fc10.src.rpm:1221099001
|
Loading…
Reference in New Issue
Block a user