Update patches

This commit is contained in:
Bastien Nocera 2011-07-05 10:04:25 +01:00
parent bb70014fed
commit bd38d2b1e8
2 changed files with 34 additions and 38 deletions

View File

@ -1,4 +1,4 @@
From b9fd541d4ed3320ea9d1796166956a9d03d15e10 Mon Sep 17 00:00:00 2001 From 6c73cb253c7a3bdf9376b32c0f2d6d9e01b89653 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net> From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100 Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin Subject: [PATCH] Add sixaxis cable-pairing plugin
@ -19,10 +19,10 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am diff --git a/Makefile.am b/Makefile.am
index ba9a89d..b5851e0 100644 index fab05eb..a21bd7d 100644
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -202,6 +202,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \ @@ -208,6 +208,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
health/hdp_util.h health/hdp_util.c health/hdp_util.h health/hdp_util.c
endif endif
@ -34,7 +34,7 @@ index ba9a89d..b5851e0 100644
builtin_modules += hciops mgmtops builtin_modules += hciops mgmtops
builtin_sources += plugins/hciops.c plugins/mgmtops.c builtin_sources += plugins/hciops.c plugins/mgmtops.c
@@ -256,7 +261,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \ @@ -262,7 +267,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/event.h src/event.c \ src/event.h src/event.c \
src/oob.h src/oob.c src/eir.h src/eir.c src/oob.h src/oob.c src/eir.h src/eir.c
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \ src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
@ -43,7 +43,7 @@ index ba9a89d..b5851e0 100644
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \ src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=$(srcdir)/src/bluetooth.ver -Wl,--version-script=$(srcdir)/src/bluetooth.ver
@@ -388,7 +393,7 @@ EXTRA_DIST += doc/manager-api.txt \ @@ -377,7 +382,7 @@ EXTRA_DIST += doc/manager-api.txt \
AM_YFLAGS = -d AM_YFLAGS = -d
@ -53,10 +53,10 @@ index ba9a89d..b5851e0 100644
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \ INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
diff --git a/acinclude.m4 b/acinclude.m4 diff --git a/acinclude.m4 b/acinclude.m4
index d77937b..7e6422e 100644 index af97cce..9d38789 100644
--- a/acinclude.m4 --- a/acinclude.m4
+++ b/acinclude.m4 +++ b/acinclude.m4
@@ -152,6 +152,12 @@ AC_DEFUN([AC_PATH_UDEV], [ @@ -155,6 +155,12 @@ AC_DEFUN([AC_PATH_UDEV], [
AC_SUBST(UDEV_LIBS) AC_SUBST(UDEV_LIBS)
]) ])
@ -69,7 +69,7 @@ index d77937b..7e6422e 100644
AC_DEFUN([AC_PATH_SNDFILE], [ AC_DEFUN([AC_PATH_SNDFILE], [
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no) PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
AC_SUBST(SNDFILE_CFLAGS) AC_SUBST(SNDFILE_CFLAGS)
@@ -183,6 +189,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [ @@ -186,6 +192,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
sndfile_enable=${sndfile_found} sndfile_enable=${sndfile_found}
hal_enable=no hal_enable=no
usb_enable=${usb_found} usb_enable=${usb_found}
@ -77,7 +77,7 @@ index d77937b..7e6422e 100644
alsa_enable=${alsa_found} alsa_enable=${alsa_found}
gstreamer_enable=${gstreamer_found} gstreamer_enable=${gstreamer_found}
audio_enable=yes audio_enable=yes
@@ -277,6 +284,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [ @@ -279,6 +286,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
usb_enable=${enableval} usb_enable=${enableval}
]) ])
@ -88,7 +88,7 @@ index d77937b..7e6422e 100644
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [ AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
tracer_enable=${enableval} tracer_enable=${enableval}
]) ])
@@ -372,6 +383,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [ @@ -370,6 +381,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.]) AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
fi fi
@ -99,14 +99,14 @@ index d77937b..7e6422e 100644
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes") AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes") AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" || AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
@@ -406,4 +421,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [ @@ -403,4 +418,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes") AM_CONDITIONAL(DATAFILES, test "${datafiles_enable}" = "yes")
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes") AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
AM_CONDITIONAL(DBUSOOBPLUGIN, test "${dbusoob_enable}" = "yes") AM_CONDITIONAL(DBUSOOBPLUGIN, test "${dbusoob_enable}" = "yes")
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes") + AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
]) ])
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index 084ece5..0ef0225 100644 index 8f54f60..6b0b024 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -46,6 +46,7 @@ AC_PATH_GSTREAMER @@ -46,6 +46,7 @@ AC_PATH_GSTREAMER
@ -506,10 +506,10 @@ index 0000000..e8cff76
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION, +BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit) + BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
diff --git a/src/adapter.c b/src/adapter.c diff --git a/src/adapter.c b/src/adapter.c
index 156d534..51e3b4c 100644 index 0909a22..8e63ee4 100644
--- a/src/adapter.c --- a/src/adapter.c
+++ b/src/adapter.c +++ b/src/adapter.c
@@ -1088,6 +1088,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn, @@ -1091,6 +1091,25 @@ static struct btd_device *adapter_create_device(DBusConnection *conn,
return device; return device;
} }

View File

@ -1,4 +1,4 @@
From c4b7096f8643d23111f91c60cbd2a62883d419ba Mon Sep 17 00:00:00 2001 From 65e42b8b83337533d2ef1d9651d614a5b927982a Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net> From: Lennart Poettering <lennart@poettering.net>
Date: Wed, 21 Jul 2010 19:20:44 +0200 Date: Wed, 21 Jul 2010 19:20:44 +0200
Subject: [PATCH] systemd: install systemd unit files Subject: [PATCH] systemd: install systemd unit files
@ -18,21 +18,11 @@ that bluetoothd is not started twice at the same time.
create mode 100644 scripts/org.bluez.service create mode 100644 scripts/org.bluez.service
diff --git a/Makefile.am b/Makefile.am diff --git a/Makefile.am b/Makefile.am
index 4659c80..c2a6976 100644 index a21bd7d..e1c5c80 100644
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -352,7 +352,8 @@ endif @@ -367,10 +367,25 @@ endif
CLEANFILES += $(rules_DATA) rules_DATA = $(foreach file,$(udev_files), scripts/97-$(notdir $(file)))
EXTRA_DIST += scripts/bluetooth.rules \
- scripts/bluetooth-hid2hci.rules scripts/bluetooth-serial.rules
+ scripts/bluetooth-hid2hci.rules scripts/bluetooth-serial.rules \
+ scripts/bluetooth.service.in scripts/org.bluez.service
if PCMCIA
udevdir = @UDEV_DIR@
@@ -360,6 +361,20 @@ udevdir = @UDEV_DIR@
dist_udev_SCRIPTS = scripts/bluetooth_serial
endif endif
+if HAVE_SYSTEMD +if HAVE_SYSTEMD
@ -49,15 +39,21 @@ index 4659c80..c2a6976 100644
+ +
+endif +endif
+ +
CLEANFILES += $(rules_DATA)
EXTRA_DIST += scripts/bluetooth.rules \
- scripts/bluetooth-hid2hci.rules scripts/bluetooth-serial.rules
+ scripts/bluetooth-hid2hci.rules scripts/bluetooth-serial.rules \
+ scripts/bluetooth.service.in scripts/org.bluez.service
EXTRA_DIST += doc/manager-api.txt \ EXTRA_DIST += doc/manager-api.txt \
doc/adapter-api.txt doc/device-api.txt \ doc/adapter-api.txt doc/device-api.txt \
doc/service-api.txt doc/agent-api.txt doc/attribute-api.txt \ @@ -397,9 +412,9 @@ pkgconfigdir = $(libdir)/pkgconfig
@@ -385,9 +400,9 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = bluez.pc pkgconfig_DATA = bluez.pc
-DISTCHECK_CONFIGURE_FLAGS = --disable-udevrules -DISTCHECK_CONFIGURE_FLAGS = --disable-datafiles
+DISTCHECK_CONFIGURE_FLAGS = --disable-udevrules --with-systemdsystemunitdir= +DISTCHECK_CONFIGURE_FLAGS = --disable-datafiles --with-systemdsystemunitdir=
-DISTCLEANFILES = $(pkgconfig_DATA) -DISTCLEANFILES = $(pkgconfig_DATA)
+DISTCLEANFILES = $(pkgconfig_DATA) scripts/bluetooth.service +DISTCLEANFILES = $(pkgconfig_DATA) scripts/bluetooth.service
@ -65,12 +61,12 @@ index 4659c80..c2a6976 100644
MAINTAINERCLEANFILES = Makefile.in \ MAINTAINERCLEANFILES = Makefile.in \
aclocal.m4 configure config.h.in config.sub config.guess \ aclocal.m4 configure config.h.in config.sub config.guess \
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index 2ce4acf..07b9e55 100644 index 6b0b024..861e1bc 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -57,5 +57,14 @@ if (test "${enable_capng}" = "yes"); then @@ -71,5 +71,14 @@ if (test -n "${path_systemdunit}"); then
AC_DEFINE(HAVE_CAPNG, 1, [Define to 1 if you have capabilities library.])
fi fi
AM_CONDITIONAL(SYSTEMD, test -n "${path_systemdunit}")
+# systemd +# systemd
+ +
@ -82,7 +78,7 @@ index 2ce4acf..07b9e55 100644
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"]) +AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+ +
AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml
src/bluetoothd.8 bluez.pc) src/bluetoothd.8 src/bluetooth.service bluez.pc)
diff --git a/scripts/.gitignore b/scripts/.gitignore diff --git a/scripts/.gitignore b/scripts/.gitignore
new file mode 100644 new file mode 100644
index 0000000..4b9f765 index 0000000..4b9f765
@ -121,5 +117,5 @@ index 0000000..dd7ae8f
+User=root +User=root
+SystemdService=dbus-org.bluez.service +SystemdService=dbus-org.bluez.service
-- --
1.7.5.1 1.7.5.4