Fix cable plugin build

This commit is contained in:
Bastien Nocera 2010-12-01 15:35:13 +00:00
parent eb77479fb3
commit bbc2a4aa7c
3 changed files with 19 additions and 19 deletions

View File

@ -1,4 +1,4 @@
From e6f125f38cd7e8b69c39ebe3e8d15b417717a254 Mon Sep 17 00:00:00 2001
From 450e51afd466497f7d2c981a61bf56c5fb7883a8 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin
@ -17,10 +17,10 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index 79b13a5..4732707 100644
index 5f96975..6044082 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -195,6 +195,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
@@ -197,6 +197,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
health/hdp_util.h health/hdp_util.c
endif
@ -32,7 +32,7 @@ index 79b13a5..4732707 100644
builtin_modules += hciops mgmtops
builtin_sources += plugins/hciops.c plugins/mgmtops.c
@@ -240,7 +245,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
@@ -242,7 +247,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/dbus-common.c src/dbus-common.h \
src/event.h src/event.c
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
@ -41,7 +41,7 @@ index 79b13a5..4732707 100644
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
@@ -356,7 +361,7 @@ EXTRA_DIST += doc/manager-api.txt \
@@ -358,7 +363,7 @@ EXTRA_DIST += doc/manager-api.txt \
AM_YFLAGS = -d
@ -104,7 +104,7 @@ index 287f07d..aab0c15 100644
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index ace1d5f..b3c8d30 100644
index 50617fd..3348ee8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,7 @@ AC_PATH_GLIB
@ -117,7 +117,7 @@ index ace1d5f..b3c8d30 100644
diff --git a/plugins/cable.c b/plugins/cable.c
new file mode 100644
index 0000000..d74c771
index 0000000..21f7257
--- /dev/null
+++ b/plugins/cable.c
@@ -0,0 +1,385 @@
@ -187,7 +187,7 @@ index 0000000..d74c771
+
+ device = adapter_find_device(adapter, address);
+ if (device == NULL)
+ device = adapter_create_device(conn, adapter, address);
+ device = adapter_create_device(conn, adapter, address, FALSE);
+ if (device != NULL) {
+ device_set_temporary(device, FALSE);
+ device_set_name(device, name);

View File

@ -1,4 +1,4 @@
From 29efb2e97955c2e236410930fa8b913bf243d72b Mon Sep 17 00:00:00 2001
From a4d043bc4c36b9dfff664d36ff724927d5817774 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 8 Nov 2010 16:43:42 +0000
Subject: [PATCH] Handle ISO8859-1 device names
@ -10,10 +10,10 @@ https://bugzilla.redhat.com/show_bug.cgi?id=450081
1 files changed, 10 insertions(+), 3 deletions(-)
diff --git a/src/event.c b/src/event.c
index e943c63..530004d 100644
index 47b50c4..1dbcad3 100644
--- a/src/event.c
+++ b/src/event.c
@@ -488,9 +488,16 @@ void btd_event_remote_name(bdaddr_t *local, bdaddr_t *peer, uint8_t status,
@@ -478,9 +478,16 @@ void btd_event_remote_name(bdaddr_t *local, bdaddr_t *peer, uint8_t status,
/* It's ok to cast end between const and non-const since
* we know it points to inside of name which is non-const */

View File

@ -1,7 +1,7 @@
From b3483ab0b821d29bbeb6aa5630b36bc126a89441 Mon Sep 17 00:00:00 2001
From d3cf8827053a239009d35995c0e06744d2bd331a Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Wed, 21 Jul 2010 19:20:44 +0200
Subject: [PATCH 3/3] systemd: install systemd unit files
Subject: [PATCH] systemd: install systemd unit files
This also enables bus activation for bluetoothd, but only if systemd is
running. Only if that's the case we can make sure in a race-free fashion
@ -18,10 +18,10 @@ that bluetoothd is not started twice at the same time.
create mode 100644 scripts/org.bluez.service
diff --git a/Makefile.am b/Makefile.am
index e855713..1edd6a2 100644
index 6044082..3ed5bcc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -344,7 +344,8 @@ endif
@@ -346,7 +346,8 @@ endif
CLEANFILES += $(rules_DATA)
EXTRA_DIST += scripts/bluetooth.rules \
@ -31,7 +31,7 @@ index e855713..1edd6a2 100644
if PCMCIA
udevdir = $(libexecdir)/udev
@@ -352,6 +353,20 @@ udevdir = $(libexecdir)/udev
@@ -354,6 +355,20 @@ udevdir = $(libexecdir)/udev
dist_udev_SCRIPTS = scripts/bluetooth_serial
endif
@ -52,7 +52,7 @@ index e855713..1edd6a2 100644
EXTRA_DIST += doc/manager-api.txt \
doc/adapter-api.txt doc/device-api.txt \
doc/service-api.txt doc/agent-api.txt doc/attribute-api.txt \
@@ -376,9 +391,9 @@ pkgconfigdir = $(libdir)/pkgconfig
@@ -378,9 +393,9 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = bluez.pc
@ -65,7 +65,7 @@ index e855713..1edd6a2 100644
MAINTAINERCLEANFILES = Makefile.in \
aclocal.m4 configure config.h.in config.sub config.guess \
diff --git a/configure.ac b/configure.ac
index d375ac9..6619a42 100644
index 3348ee8..5244f73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,5 +56,14 @@ if (test "${enable_capng}" = "yes"); then
@ -120,5 +120,5 @@ index 0000000..2a3b057
+User=root
+SystemdService=bluetooth.service
--
1.7.3.1
1.7.3.2