Update cable pairing patch
This commit is contained in:
parent
ab24799ed7
commit
b36fd19ca9
@ -1,4 +1,4 @@
|
||||
From 67d999b78a919408b50ac3eb7e2e38f628c241fb Mon Sep 17 00:00:00 2001
|
||||
From 930d4ff4c8ce7344cd8c69c149bb695d82fa9548 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Tue, 1 Sep 2009 17:32:48 +0100
|
||||
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
||||
@ -17,10 +17,10 @@ address, and added to the database of the current default adapter.
|
||||
create mode 100644 plugins/cable.c
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 9a78780..3fb948f 100644
|
||||
index 7895be2..8bf6c88 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -191,6 +191,11 @@ builtin_sources += attrib/main.c \
|
||||
@@ -192,6 +192,11 @@ builtin_sources += attrib/main.c \
|
||||
attrib/example.h attrib/example.c
|
||||
endif
|
||||
|
||||
@ -32,7 +32,7 @@ index 9a78780..3fb948f 100644
|
||||
builtin_modules += hciops
|
||||
builtin_sources += plugins/hciops.c
|
||||
|
||||
@@ -236,7 +241,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||
@@ -237,7 +242,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||
src/dbus-common.c src/dbus-common.h \
|
||||
src/dbus-hci.h src/dbus-hci.c
|
||||
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
||||
@ -41,7 +41,7 @@ index 9a78780..3fb948f 100644
|
||||
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
||||
-Wl,--version-script=src/bluetooth.ver
|
||||
src_bluetoothd_DEPENDENCIES = src/bluetooth.ver lib/libbluetooth.la
|
||||
@@ -351,7 +356,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||
@@ -352,7 +357,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||
|
||||
AM_YFLAGS = -d
|
||||
|
||||
@ -51,7 +51,7 @@ index 9a78780..3fb948f 100644
|
||||
|
||||
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
||||
diff --git a/acinclude.m4 b/acinclude.m4
|
||||
index b34f08d..64b2a86 100644
|
||||
index a4e5e2f..eb0936a 100644
|
||||
--- a/acinclude.m4
|
||||
+++ b/acinclude.m4
|
||||
@@ -146,6 +146,12 @@ AC_DEFUN([AC_PATH_USB], [
|
||||
@ -67,7 +67,7 @@ index b34f08d..64b2a86 100644
|
||||
AC_DEFUN([AC_PATH_SNDFILE], [
|
||||
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
|
||||
AC_SUBST(SNDFILE_CFLAGS)
|
||||
@@ -160,6 +166,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
@@ -168,6 +174,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
sndfile_enable=${sndfile_found}
|
||||
hal_enable=no
|
||||
usb_enable=${usb_found}
|
||||
@ -75,7 +75,7 @@ index b34f08d..64b2a86 100644
|
||||
alsa_enable=${alsa_found}
|
||||
gstreamer_enable=${gstreamer_found}
|
||||
audio_enable=yes
|
||||
@@ -242,6 +249,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
@@ -250,6 +257,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
usb_enable=${enableval}
|
||||
])
|
||||
|
||||
@ -86,7 +86,7 @@ index b34f08d..64b2a86 100644
|
||||
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
|
||||
tracer_enable=${enableval}
|
||||
])
|
||||
@@ -333,6 +344,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
@@ -341,6 +352,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
||||
fi
|
||||
|
||||
@ -97,14 +97,14 @@ index b34f08d..64b2a86 100644
|
||||
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
||||
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
||||
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
||||
@@ -363,4 +378,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
@@ -371,4 +386,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
|
||||
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
||||
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
|
||||
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
||||
])
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index e8abfe9..dbc8550 100644
|
||||
index 6fda7fe..0ef9d4c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -40,6 +40,7 @@ AC_PATH_GLIB
|
||||
@ -113,8 +113,8 @@ index e8abfe9..dbc8550 100644
|
||||
AC_PATH_USB
|
||||
+AC_PATH_CABLE
|
||||
AC_PATH_SNDFILE
|
||||
AC_PATH_OUI
|
||||
|
||||
AC_ARG_BLUEZ
|
||||
diff --git a/plugins/cable.c b/plugins/cable.c
|
||||
new file mode 100644
|
||||
index 0000000..d74c771
|
||||
@ -507,5 +507,5 @@ index 0000000..d74c771
|
||||
+BLUETOOTH_PLUGIN_DEFINE(cable, VERSION,
|
||||
+ BLUETOOTH_PLUGIN_PRIORITY_DEFAULT, cable_init, cable_exit)
|
||||
--
|
||||
1.7.0.1
|
||||
1.7.2.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user