- More upstream CUPS fixes
This commit is contained in:
parent
385d00dc07
commit
aeba10d0f0
31
0001-Allow-lp-CUPS-to-talk-to-bluetoothd.patch
Normal file
31
0001-Allow-lp-CUPS-to-talk-to-bluetoothd.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From b2d24735492e6a71f3441720940ac55c33fa0838 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Till Kamppeter <till.kamppeter@gmail.com>
|
||||||
|
Date: Tue, 11 Aug 2009 14:04:05 +0100
|
||||||
|
Subject: [PATCH 1/2] Allow lp (CUPS) to talk to bluetoothd
|
||||||
|
|
||||||
|
CUPS runs its backend helpers as the "lp" user, so we should
|
||||||
|
allow CUPS to talk to bluetoothd to enumerate printers.
|
||||||
|
---
|
||||||
|
src/bluetooth.conf | 6 ++++++
|
||||||
|
1 files changed, 6 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/bluetooth.conf b/src/bluetooth.conf
|
||||||
|
index c047623..315009c 100644
|
||||||
|
--- a/src/bluetooth.conf
|
||||||
|
+++ b/src/bluetooth.conf
|
||||||
|
@@ -17,6 +17,12 @@
|
||||||
|
<allow send_destination="org.bluez"/>
|
||||||
|
</policy>
|
||||||
|
|
||||||
|
+ <!-- allow users of lp group (printing subsystem) to
|
||||||
|
+ communicate with bluetoothd -->
|
||||||
|
+ <policy group="lp">
|
||||||
|
+ <allow send_destination="org.bluez"/>
|
||||||
|
+ </policy>
|
||||||
|
+
|
||||||
|
<policy context="default">
|
||||||
|
<deny send_destination="org.bluez"/>
|
||||||
|
</policy>
|
||||||
|
--
|
||||||
|
1.6.2.5
|
||||||
|
|
27
0002-Mark-Bluetooth-printers-as-being-local.patch
Normal file
27
0002-Mark-Bluetooth-printers-as-being-local.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From d96004d65132a7934308ded8010c5f819013157a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Till Kamppeter <till.kamppeter@gmail.com>
|
||||||
|
Date: Tue, 11 Aug 2009 14:06:59 +0100
|
||||||
|
Subject: [PATCH 2/2] Mark Bluetooth printers as being local
|
||||||
|
|
||||||
|
For discovery purposes. Also add a better label for the printer,
|
||||||
|
and append "(Bluetooth") to the "unique" name.
|
||||||
|
---
|
||||||
|
cups/main.c | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/cups/main.c b/cups/main.c
|
||||||
|
index ba9864f..bb15c9c 100644
|
||||||
|
--- a/cups/main.c
|
||||||
|
+++ b/cups/main.c
|
||||||
|
@@ -226,7 +226,7 @@ static void print_printer_details(const char *name, const char *bdaddr, const ch
|
||||||
|
bdaddr[9], bdaddr[10],
|
||||||
|
bdaddr[12], bdaddr[13],
|
||||||
|
bdaddr[15], bdaddr[16]);
|
||||||
|
- printf("network %s \"Unknown\" \"%s (Bluetooth)\"", uri, escaped);
|
||||||
|
+ printf("direct %s \"%s\" \"%s (Bluetooth)\"", uri, escaped, escaped);
|
||||||
|
if (id != NULL)
|
||||||
|
printf(" \"%s\"\n", id);
|
||||||
|
else
|
||||||
|
--
|
||||||
|
1.6.2.5
|
||||||
|
|
11
bluez.spec
11
bluez.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 4.47
|
Version: 4.47
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.bz2
|
Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.bz2
|
||||||
@ -23,8 +23,12 @@ Patch3: bluez-activate-wacom-mode2.patch
|
|||||||
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
Patch4: bluez-socket-mobile-cf-connection-kit.patch
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396
|
||||||
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
Patch5: 0001-Add-sixaxis-cable-pairing-plugin.patch
|
||||||
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/3108
|
||||||
Patch6: 0001-Don-t-abort-cups-backend-on-property-change.patch
|
Patch6: 0001-Don-t-abort-cups-backend-on-property-change.patch
|
||||||
Patch7: 0002-Actually-read-the-CreateDevice-reply.patch
|
Patch7: 0002-Actually-read-the-CreateDevice-reply.patch
|
||||||
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/3106/focus=3114
|
||||||
|
Patch8: 0001-Allow-lp-CUPS-to-talk-to-bluetoothd.patch
|
||||||
|
Patch9: 0002-Mark-Bluetooth-printers-as-being-local.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
URL: http://www.bluez.org/
|
URL: http://www.bluez.org/
|
||||||
@ -133,6 +137,8 @@ This includes hidd, dund and pand.
|
|||||||
%patch5 -p1 -b .cable-pairing
|
%patch5 -p1 -b .cable-pairing
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
|
%patch8 -p1
|
||||||
|
%patch9 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize -f -c
|
libtoolize -f -c
|
||||||
@ -272,6 +278,9 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/sysconfig/pand
|
%config(noreplace) %{_sysconfdir}/sysconfig/pand
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 11 2009 Bastien Nocera <bnocera@redhat.com> 4.47-5
|
||||||
|
- More upstream CUPS fixes
|
||||||
|
|
||||||
* Tue Aug 11 2009 Bastien Nocera <bnocera@redhat.com> 4.47-4
|
* Tue Aug 11 2009 Bastien Nocera <bnocera@redhat.com> 4.47-4
|
||||||
- Fix cups discovery the first time we discover a device
|
- Fix cups discovery the first time we discover a device
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user