Fix problem unsetting discoverable
This commit is contained in:
parent
135a67b68d
commit
adf5662e24
@ -0,0 +1,29 @@
|
|||||||
|
From 12494337e4ce67ce927bd2d8c86e9c176ec3e36f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Johan Hedberg <johan.hedberg@intel.com>
|
||||||
|
Date: Fri, 20 Sep 2013 11:17:34 -0500
|
||||||
|
Subject: [PATCH] core: Fix passing timeout when disabling discoverable mode
|
||||||
|
|
||||||
|
We should only pass a timeout value when enabling discoverable mode.
|
||||||
|
When disabling passing something non-zero would yield a "invalid
|
||||||
|
parameters" error.
|
||||||
|
---
|
||||||
|
src/adapter.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/adapter.c b/src/adapter.c
|
||||||
|
index 17f5508..5434a07 100644
|
||||||
|
--- a/src/adapter.c
|
||||||
|
+++ b/src/adapter.c
|
||||||
|
@@ -1890,7 +1890,8 @@ static void property_set_mode(struct btd_adapter *adapter, uint32_t setting,
|
||||||
|
case MGMT_SETTING_DISCOVERABLE:
|
||||||
|
memset(&cp, 0, sizeof(cp));
|
||||||
|
cp.val = mode;
|
||||||
|
- cp.timeout = htobs(adapter->discoverable_timeout);
|
||||||
|
+ if (cp.val)
|
||||||
|
+ cp.timeout = htobs(adapter->discoverable_timeout);
|
||||||
|
|
||||||
|
opcode = MGMT_OP_SET_DISCOVERABLE;
|
||||||
|
param = &cp;
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
10
bluez.spec
10
bluez.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 5.9
|
Version: 5.9
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.bluez.org/
|
URL: http://www.bluez.org/
|
||||||
@ -15,6 +15,8 @@ Source1: bluez.gitignore
|
|||||||
Patch1: playstation-peripheral-pugin-v5.x.patch
|
Patch1: playstation-peripheral-pugin-v5.x.patch
|
||||||
## Ubuntu patches
|
## Ubuntu patches
|
||||||
Patch2: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
Patch2: 0001-work-around-Logitech-diNovo-Edge-keyboard-firmware-i.patch
|
||||||
|
# https://git.kernel.org/cgit/bluetooth/bluez.git/commit/?id=12494337e4ce67ce927bd2d8c86e9c176ec3e36f
|
||||||
|
Patch3: 0001-core-Fix-passing-timeout-when-disabling-discoverable.patch
|
||||||
|
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
@ -224,6 +226,12 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
|
|||||||
/lib/udev/rules.d/97-hid2hci.rules
|
/lib/udev/rules.d/97-hid2hci.rules
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 20 2013 Bastien Nocera <bnocera@redhat.com> 5.9-2
|
||||||
|
- Fix problem unsetting discoverable
|
||||||
|
|
||||||
|
* Fri Sep 20 2013 Bastien Nocera <bnocera@redhat.com> 5.9-1
|
||||||
|
- Update to 5.9
|
||||||
|
|
||||||
* Fri Aug 16 2013 Kalev Lember <kalevlember@gmail.com> - 5.8-2
|
* Fri Aug 16 2013 Kalev Lember <kalevlember@gmail.com> - 5.8-2
|
||||||
- Don't pull in -libs for the other subpackages
|
- Don't pull in -libs for the other subpackages
|
||||||
- Remove a stray .la file
|
- Remove a stray .la file
|
||||||
|
Loading…
Reference in New Issue
Block a user