- Update to 4.71
This commit is contained in:
parent
acc78559e7
commit
ab24799ed7
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
bluez-4.69.tar.gz
|
bluez-4.69.tar.gz
|
||||||
bluez-4.70.tar.gz
|
bluez-4.70.tar.gz
|
||||||
|
/bluez-4.71.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From bdc307d37c30f103ceac4268553e6dcec497606b Mon Sep 17 00:00:00 2001
|
From 67d999b78a919408b50ac3eb7e2e38f628c241fb Mon Sep 17 00:00:00 2001
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
From: Bastien Nocera <hadess@hadess.net>
|
||||||
Date: Tue, 1 Sep 2009 17:32:48 +0100
|
Date: Tue, 1 Sep 2009 17:32:48 +0100
|
||||||
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
Subject: [PATCH] Add sixaxis cable-pairing plugin
|
||||||
@ -10,17 +10,17 @@ the device is selected, poked around to set the default Bluetooth
|
|||||||
address, and added to the database of the current default adapter.
|
address, and added to the database of the current default adapter.
|
||||||
---
|
---
|
||||||
Makefile.am | 9 +-
|
Makefile.am | 9 +-
|
||||||
acinclude.m4 | 38 ++++++
|
acinclude.m4 | 16 +++
|
||||||
configure.ac | 3 +
|
configure.ac | 1 +
|
||||||
plugins/cable.c | 385 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
|
plugins/cable.c | 385 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
|
||||||
4 files changed, 433 insertions(+), 2 deletions(-)
|
4 files changed, 409 insertions(+), 2 deletions(-)
|
||||||
create mode 100644 plugins/cable.c
|
create mode 100644 plugins/cable.c
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
index 47478c2..105d8c0 100644
|
index 9a78780..3fb948f 100644
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -185,6 +185,11 @@ builtin_sources += attrib/main.c \
|
@@ -191,6 +191,11 @@ builtin_sources += attrib/main.c \
|
||||||
attrib/example.h attrib/example.c
|
attrib/example.h attrib/example.c
|
||||||
endif
|
endif
|
||||||
|
|
||||||
@ -32,7 +32,7 @@ index 47478c2..105d8c0 100644
|
|||||||
builtin_modules += hciops
|
builtin_modules += hciops
|
||||||
builtin_sources += plugins/hciops.c
|
builtin_sources += plugins/hciops.c
|
||||||
|
|
||||||
@@ -222,7 +227,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
@@ -236,7 +241,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
|
||||||
src/dbus-common.c src/dbus-common.h \
|
src/dbus-common.c src/dbus-common.h \
|
||||||
src/dbus-hci.h src/dbus-hci.c
|
src/dbus-hci.h src/dbus-hci.c
|
||||||
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
|
||||||
@ -41,7 +41,7 @@ index 47478c2..105d8c0 100644
|
|||||||
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
|
||||||
-Wl,--version-script=src/bluetooth.ver
|
-Wl,--version-script=src/bluetooth.ver
|
||||||
src_bluetoothd_DEPENDENCIES = src/bluetooth.ver lib/libbluetooth.la
|
src_bluetoothd_DEPENDENCIES = src/bluetooth.ver lib/libbluetooth.la
|
||||||
@@ -337,7 +342,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
@@ -351,7 +356,7 @@ EXTRA_DIST += doc/manager-api.txt \
|
||||||
|
|
||||||
AM_YFLAGS = -d
|
AM_YFLAGS = -d
|
||||||
|
|
||||||
@ -51,10 +51,10 @@ index 47478c2..105d8c0 100644
|
|||||||
|
|
||||||
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
|
||||||
diff --git a/acinclude.m4 b/acinclude.m4
|
diff --git a/acinclude.m4 b/acinclude.m4
|
||||||
index 22c2e2c..e5d852e 100644
|
index b34f08d..64b2a86 100644
|
||||||
--- a/acinclude.m4
|
--- a/acinclude.m4
|
||||||
+++ b/acinclude.m4
|
+++ b/acinclude.m4
|
||||||
@@ -146,6 +146,24 @@ AC_DEFUN([AC_PATH_USB], [
|
@@ -146,6 +146,12 @@ AC_DEFUN([AC_PATH_USB], [
|
||||||
[Define to 1 if you need the usb_interrupt_read() function.]))
|
[Define to 1 if you need the usb_interrupt_read() function.]))
|
||||||
])
|
])
|
||||||
|
|
||||||
@ -63,58 +63,33 @@ index 22c2e2c..e5d852e 100644
|
|||||||
+ AC_SUBST(CABLE_CFLAGS)
|
+ AC_SUBST(CABLE_CFLAGS)
|
||||||
+ AC_SUBST(CABLE_LIBS)
|
+ AC_SUBST(CABLE_LIBS)
|
||||||
+])
|
+])
|
||||||
+
|
|
||||||
+AC_DEFUN([AC_PATH_NETLINK], [
|
|
||||||
+ PKG_CHECK_MODULES(NETLINK, libnl-1, netlink_found=yes, netlink_found=no)
|
|
||||||
+ AC_SUBST(NETLINK_CFLAGS)
|
|
||||||
+ AC_SUBST(NETLINK_LIBS)
|
|
||||||
+])
|
|
||||||
+
|
|
||||||
+AC_DEFUN([AC_PATH_CAPNG], [
|
|
||||||
+ PKG_CHECK_MODULES(CAPNG, libcap-ng, capng_found=yes, capng_found=no)
|
|
||||||
+ AC_SUBST(CAPNG_CFLAGS)
|
|
||||||
+ AC_SUBST(CAPNG_LIBS)
|
|
||||||
+])
|
|
||||||
+
|
+
|
||||||
AC_DEFUN([AC_PATH_SNDFILE], [
|
AC_DEFUN([AC_PATH_SNDFILE], [
|
||||||
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
|
PKG_CHECK_MODULES(SNDFILE, sndfile, sndfile_found=yes, sndfile_found=no)
|
||||||
AC_SUBST(SNDFILE_CFLAGS)
|
AC_SUBST(SNDFILE_CFLAGS)
|
||||||
@@ -157,9 +175,12 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -160,6 +166,7 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
optimization_enable=yes
|
|
||||||
fortify_enable=yes
|
|
||||||
pie_enable=yes
|
|
||||||
+ capng_enable=${capng_found}
|
|
||||||
sndfile_enable=${sndfile_found}
|
sndfile_enable=${sndfile_found}
|
||||||
+ netlink_enable=no
|
hal_enable=no
|
||||||
hal_enable=${hal_found}
|
|
||||||
usb_enable=${usb_found}
|
usb_enable=${usb_found}
|
||||||
+ cable_enable=${cable_found}
|
+ cable_enable=${cable_found}
|
||||||
alsa_enable=${alsa_found}
|
alsa_enable=${alsa_found}
|
||||||
gstreamer_enable=${gstreamer_found}
|
gstreamer_enable=${gstreamer_found}
|
||||||
audio_enable=yes
|
audio_enable=yes
|
||||||
@@ -237,6 +258,14 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -242,6 +249,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
usb_enable=${enableval}
|
usb_enable=${enableval}
|
||||||
])
|
])
|
||||||
|
|
||||||
+ AC_ARG_ENABLE(cable, AC_HELP_STRING([--enable-cable], [enable DeviceKit support]), [
|
+ AC_ARG_ENABLE(cable, AC_HELP_STRING([--enable-cable], [enable DeviceKit support]), [
|
||||||
+ cable_enable=${enableval}
|
+ cable_enable=${enableval}
|
||||||
+ ])
|
+ ])
|
||||||
+
|
|
||||||
+ AC_ARG_ENABLE(netlink, AC_HELP_STRING([--enable-netlink], [enable NETLINK support]), [
|
|
||||||
+ netlink_enable=${enableval}
|
|
||||||
+ ])
|
|
||||||
+
|
+
|
||||||
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
|
AC_ARG_ENABLE(tracer, AC_HELP_STRING([--enable-tracer], [install Tracing daemon]), [
|
||||||
tracer_enable=${enableval}
|
tracer_enable=${enableval}
|
||||||
])
|
])
|
||||||
@@ -324,6 +353,14 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -333,6 +344,10 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
AC_DEFINE(HAVE_LIBUSB, 1, [Define to 1 if you have USB library.])
|
||||||
fi
|
fi
|
||||||
|
|
||||||
+ if (test "${capng_enable}" = "yes" && test "${capng_found}" = "yes"); then
|
|
||||||
+ AC_DEFINE(HAVE_CAPNG, 1, [Define to 1 if you have capabilities library.])
|
|
||||||
+ fi
|
|
||||||
+
|
|
||||||
+ if (test "${cable_enable}" = "yes" && test "${cable_found}" = "yes"); then
|
+ if (test "${cable_enable}" = "yes" && test "${cable_found}" = "yes"); then
|
||||||
+ AC_DEFINE(HAVE_CABLE, 1, [Define to 1 if you have libcable.])
|
+ AC_DEFINE(HAVE_CABLE, 1, [Define to 1 if you have libcable.])
|
||||||
+ fi
|
+ fi
|
||||||
@ -122,27 +97,24 @@ index 22c2e2c..e5d852e 100644
|
|||||||
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
|
||||||
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
AM_CONDITIONAL(USB, test "${usb_enable}" = "yes" && test "${usb_found}" = "yes")
|
||||||
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
AM_CONDITIONAL(SBC, test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes" ||
|
||||||
@@ -352,4 +389,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
@@ -363,4 +378,5 @@ AC_DEFUN([AC_ARG_BLUEZ], [
|
||||||
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
|
AM_CONDITIONAL(UDEVRULES, test "${udevrules_enable}" = "yes")
|
||||||
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
AM_CONDITIONAL(CONFIGFILES, test "${configfiles_enable}" = "yes")
|
||||||
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
|
AM_CONDITIONAL(MAEMO6PLUGIN, test "${maemo6_enable}" = "yes")
|
||||||
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
|
||||||
])
|
])
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
index e8abfe9..c1a3725 100644
|
index e8abfe9..dbc8550 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -40,7 +40,10 @@ AC_PATH_GLIB
|
@@ -40,6 +40,7 @@ AC_PATH_GLIB
|
||||||
AC_PATH_ALSA
|
AC_PATH_ALSA
|
||||||
AC_PATH_GSTREAMER
|
AC_PATH_GSTREAMER
|
||||||
AC_PATH_USB
|
AC_PATH_USB
|
||||||
+AC_PATH_CABLE
|
+AC_PATH_CABLE
|
||||||
+AC_PATH_NETLINK
|
|
||||||
AC_PATH_SNDFILE
|
AC_PATH_SNDFILE
|
||||||
+AC_PATH_CAPNG
|
|
||||||
|
|
||||||
AC_ARG_BLUEZ
|
AC_ARG_BLUEZ
|
||||||
|
|
||||||
diff --git a/plugins/cable.c b/plugins/cable.c
|
diff --git a/plugins/cable.c b/plugins/cable.c
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..d74c771
|
index 0000000..d74c771
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
Index: src/oui.c
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/bluez/utils/common/oui.c,v
|
|
||||||
retrieving revision 1.2
|
|
||||||
diff -u -p -r1.2 oui.c
|
|
||||||
--- src/oui.c 13 Jan 2007 17:48:12 -0000 1.2
|
|
||||||
+++ src/oui.c 25 Jan 2008 12:16:58 -0000
|
|
||||||
@@ -38,7 +38,7 @@
|
|
||||||
|
|
||||||
/* http://standards.ieee.org/regauth/oui/oui.txt */
|
|
||||||
|
|
||||||
-#define OUIFILE "/var/lib/misc/oui.txt"
|
|
||||||
+#define OUIFILE "/usr/share/hwdata/oui.txt"
|
|
||||||
|
|
||||||
char *ouitocomp(const char *oui)
|
|
||||||
{
|
|
||||||
@@ -46,14 +46,9 @@ char *ouitocomp(const char *oui)
|
|
||||||
char *str, *map, *off, *end;
|
|
||||||
int fd;
|
|
||||||
|
|
||||||
- fd = open("oui.txt", O_RDONLY);
|
|
||||||
+ fd = open(OUIFILE, O_RDONLY);
|
|
||||||
if (fd < 0) {
|
|
||||||
- fd = open(OUIFILE, O_RDONLY);
|
|
||||||
- if (fd < 0) {
|
|
||||||
- fd = open("/usr/share/misc/oui.txt", O_RDONLY);
|
|
||||||
- if (fd < 0)
|
|
||||||
- return NULL;
|
|
||||||
- }
|
|
||||||
+ return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
if (fstat(fd, &st) < 0) {
|
|
15
bluez.spec
15
bluez.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: Bluetooth utilities
|
Summary: Bluetooth utilities
|
||||||
Name: bluez
|
Name: bluez
|
||||||
Version: 4.70
|
Version: 4.71
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -13,7 +13,6 @@ Source6: pand.conf
|
|||||||
Source7: rfcomm.init
|
Source7: rfcomm.init
|
||||||
Source8: bluez-uinput.modules
|
Source8: bluez-uinput.modules
|
||||||
|
|
||||||
Patch1: bluez-utils-oui-usage.patch
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=450081
|
# https://bugzilla.redhat.com/show_bug.cgi?id=450081
|
||||||
# http://thread.gmane.org/gmane.linux.bluez.kernel/1687
|
# http://thread.gmane.org/gmane.linux.bluez.kernel/1687
|
||||||
Patch2: bluez-try-utf8-harder.patch
|
Patch2: bluez-try-utf8-harder.patch
|
||||||
@ -32,7 +31,7 @@ BuildRequires: gstreamer-plugins-base-devel, gstreamer-devel
|
|||||||
BuildRequires: libsndfile-devel
|
BuildRequires: libsndfile-devel
|
||||||
BuildRequires: libcap-ng-devel
|
BuildRequires: libcap-ng-devel
|
||||||
# For cable pairing
|
# For cable pairing
|
||||||
BuildRequires: libudev-devel
|
BuildRequires: libudev-devel
|
||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
BuildRequires: libusb1-devel
|
BuildRequires: libusb1-devel
|
||||||
%endif
|
%endif
|
||||||
@ -129,7 +128,6 @@ This includes hidd, dund and pand.
|
|||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p0 -b .oui
|
|
||||||
%patch2 -p1 -b .non-utf8-name
|
%patch2 -p1 -b .non-utf8-name
|
||||||
%patch4 -p1 -b .socket-mobile
|
%patch4 -p1 -b .socket-mobile
|
||||||
%patch5 -p1 -b .cable-pairing
|
%patch5 -p1 -b .cable-pairing
|
||||||
@ -137,12 +135,12 @@ This includes hidd, dund and pand.
|
|||||||
%build
|
%build
|
||||||
libtoolize -f -c
|
libtoolize -f -c
|
||||||
autoreconf
|
autoreconf
|
||||||
%configure --enable-cups --enable-dfutool --enable-tools --enable-bccmd --enable-gstreamer --enable-hidd --enable-pand --enable-dund --enable-configfiles
|
%configure --enable-cups --enable-dfutool --enable-tools --enable-bccmd --enable-gstreamer --enable-hidd --enable-pand --enable-dund --enable-configfiles --with-ouifile=/usr/share/hwdata/oui.txt
|
||||||
make
|
make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
|
/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
|
||||||
# Remove autocrap and libtool droppings
|
# Remove autocrap and libtool droppings
|
||||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la \
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la \
|
||||||
@ -150,7 +148,7 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la \
|
|||||||
$RPM_BUILD_ROOT/%{_libdir}/bluetooth/plugins/*.la \
|
$RPM_BUILD_ROOT/%{_libdir}/bluetooth/plugins/*.la \
|
||||||
$RPM_BUILD_ROOT/%{_libdir}/gstreamer-0.10/*.la
|
$RPM_BUILD_ROOT/%{_libdir}/gstreamer-0.10/*.la
|
||||||
|
|
||||||
for a in bluetooth dund pand rfcomm ; do
|
for a in bluetooth dund pand rfcomm ; do
|
||||||
install -D -m0755 $RPM_SOURCE_DIR/$a.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/$a
|
install -D -m0755 $RPM_SOURCE_DIR/$a.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/$a
|
||||||
if [ -e $RPM_SOURCE_DIR/$a.conf ] ; then
|
if [ -e $RPM_SOURCE_DIR/$a.conf ] ; then
|
||||||
install -D -m0644 $RPM_SOURCE_DIR/$a.conf $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/$a
|
install -D -m0644 $RPM_SOURCE_DIR/$a.conf $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/$a
|
||||||
@ -280,6 +278,9 @@ fi
|
|||||||
%{_mandir}/man1/pand.1.gz
|
%{_mandir}/man1/pand.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 09 2010 Bastien Nocera <bnocera@redhat.com> 4.71-1
|
||||||
|
- Update to 4.71
|
||||||
|
|
||||||
* Thu Aug 26 2010 Bastien Nocera <bnocera@redhat.com> 4.70-1
|
* Thu Aug 26 2010 Bastien Nocera <bnocera@redhat.com> 4.70-1
|
||||||
- Update to 4.70
|
- Update to 4.70
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user