Fix cable patch

This commit is contained in:
Bastien Nocera 2010-05-24 11:22:48 +00:00
parent 392b9e6ec4
commit a9198657d7

View File

@ -1,4 +1,4 @@
From d2bd581a4b02d789dd2d28cbe4c58143beeb4f83 Mon Sep 17 00:00:00 2001
From 09ef06047b1b180e68853786cd9efb9a1c5b2379 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH] Add sixaxis cable-pairing plugin
@ -17,10 +17,10 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index 013f847..9511de6 100644
index 36ffde3..1e3ff96 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -167,6 +167,11 @@ builtin_modules += service
@@ -168,6 +168,11 @@ builtin_modules += service
builtin_sources += plugins/service.c
endif
@ -32,7 +32,7 @@ index 013f847..9511de6 100644
builtin_modules += hciops
builtin_sources += plugins/hciops.c
@@ -197,7 +202,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
@@ -198,7 +203,7 @@ src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/dbus-common.c src/dbus-common.h \
src/dbus-hci.h src/dbus-hci.c
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
@ -41,7 +41,7 @@ index 013f847..9511de6 100644
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=src/bluetooth.ver
src_bluetoothd_DEPENDENCIES = src/bluetooth.ver lib/libbluetooth.la
@@ -310,7 +315,7 @@ EXTRA_DIST += doc/manager-api.txt \
@@ -312,7 +317,7 @@ EXTRA_DIST += doc/manager-api.txt \
AM_YFLAGS = -d
@ -129,7 +129,7 @@ index f7bb047..25005c0 100644
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index 055adb9..1116d5b 100644
index ec090aa..0c6fd97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,7 +40,10 @@ AC_PATH_GLIB
@ -145,7 +145,7 @@ index 055adb9..1116d5b 100644
diff --git a/plugins/cable.c b/plugins/cable.c
new file mode 100644
index 0000000..3159ba4
index 0000000..698d5e6
--- /dev/null
+++ b/plugins/cable.c
@@ -0,0 +1,385 @@
@ -185,7 +185,7 @@ index 0000000..3159ba4
+#include <libusb.h>
+
+#include "plugin.h"
+#include "logging.h"
+#include "log.h"
+
+#include "manager.h"
+#include "adapter.h"