Fix ALSA plugin suffix

This commit is contained in:
Bastien Nocera 2012-06-14 15:00:58 +01:00
parent 948c1b25ee
commit a7a3a89638
2 changed files with 31 additions and 3 deletions

View File

@ -0,0 +1,27 @@
From bbfd894bd8f220d2af1e6f88e365a83d626ae280 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Thu, 14 Jun 2012 14:56:17 +0100
Subject: [PATCH] Fix ALSA plugin having full soname
This is a plugin, so spell -avoid-version correctly so
it doesn't have a full soname.
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 012409a..c70ff24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -358,7 +358,7 @@ audio_libasound_module_pcm_bluetooth_la_CFLAGS = $(AM_CFLAGS) @ALSA_CFLAGS@
audio_libasound_module_ctl_bluetooth_la_SOURCES = audio/ctl_bluetooth.c \
audio/rtp.h audio/ipc.h audio/ipc.c
audio_libasound_module_ctl_bluetooth_la_LDFLAGS = $(AM_LDFLAGS) -module \
- -avoid-versionv
+ -avoid-version
audio_libasound_module_ctl_bluetooth_la_LIBADD = \
lib/libbluetooth-private.la @ALSA_LIBS@
audio_libasound_module_ctl_bluetooth_la_CFLAGS = $(AM_CFLAGS) @ALSA_CFLAGS@
--
1.7.10.2

View File

@ -16,6 +16,8 @@ Source8: bluez-uinput.modules
# File missing from the tarball # File missing from the tarball
Patch1: 0001-Add-missing-org.bluez.service-file.patch Patch1: 0001-Add-missing-org.bluez.service-file.patch
# Typo
Patch2: 0001-Fix-ALSA-plugin-having-full-soname.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=498756 # https://bugzilla.redhat.com/show_bug.cgi?id=498756
Patch4: bluez-socket-mobile-cf-connection-kit.patch Patch4: bluez-socket-mobile-cf-connection-kit.patch
# http://thread.gmane.org/gmane.linux.bluez.kernel/2396 # http://thread.gmane.org/gmane.linux.bluez.kernel/2396
@ -142,6 +144,7 @@ and mouse.
%setup -q %setup -q
%patch1 -p1 -b .missing-file %patch1 -p1 -b .missing-file
%patch2 -p1 -b .typo
%patch4 -p1 -b .socket-mobile %patch4 -p1 -b .socket-mobile
%patch5 -p1 -b .cable-pairing %patch5 -p1 -b .cable-pairing
@ -256,11 +259,9 @@ fi
%{_libdir}/bluetooth/ %{_libdir}/bluetooth/
/lib/udev/bluetooth_serial /lib/udev/bluetooth_serial
/lib/udev/rules.d/97-bluetooth-serial.rules /lib/udev/rules.d/97-bluetooth-serial.rules
/usr/lib/udev/rules.d/97-bluetooth.rules
%{_localstatedir}/lib/bluetooth %{_localstatedir}/lib/bluetooth
%{_datadir}/dbus-1/system-services/org.bluez.service %{_datadir}/dbus-1/system-services/org.bluez.service
/lib/systemd/system/bluetooth.service /usr/lib/systemd/system/bluetooth.service
%exclude /usr/lib/systemd/system/bluetooth.service
%files libs %files libs
%defattr(-,root,root,-) %defattr(-,root,root,-)