+ bluez-5.50-1
Update to 5.50
This commit is contained in:
parent
05297de3f5
commit
929931974e
@ -1,38 +0,0 @@
|
||||
From cba55944f76ad0f01bb7c8976fd6699f058c68cd Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Wed, 20 Sep 2017 14:42:14 +0200
|
||||
Subject: [PATCH] hostname: Fix "BlueZ 5.XX" adapter name on startup
|
||||
|
||||
The hostname plugin listens to property changes from systemd-hostnamed
|
||||
but doesn't fetch initial values. This means that unless the
|
||||
PrettyHostname or StaticHostname changes, the default adapter will be
|
||||
called "BlueZ 5.XX" matching the version number.
|
||||
|
||||
This is the case since the hostname plugin replaced the adaptername
|
||||
plugin in 2012.
|
||||
|
||||
Fetch the initial values for PrettyHostname, StaticHostname and
|
||||
Chassis when the plugin is initiated, so as to make the values
|
||||
available for adapter setup.
|
||||
---
|
||||
plugins/hostname.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/plugins/hostname.c b/plugins/hostname.c
|
||||
index f876d0afb..db9187378 100644
|
||||
--- a/plugins/hostname.c
|
||||
+++ b/plugins/hostname.c
|
||||
@@ -307,6 +307,10 @@ static int hostname_init(void)
|
||||
hostname_proxy = NULL;
|
||||
g_dbus_client_unref(hostname_client);
|
||||
hostname_client = NULL;
|
||||
+ } else {
|
||||
+ g_dbus_proxy_refresh_property(hostname_proxy, "PrettyHostname");
|
||||
+ g_dbus_proxy_refresh_property(hostname_proxy, "StaticHostname");
|
||||
+ g_dbus_proxy_refresh_property(hostname_proxy, "Chassis");
|
||||
}
|
||||
|
||||
return err;
|
||||
--
|
||||
2.14.1
|
||||
|
15
bluez.spec
15
bluez.spec
@ -1,7 +1,7 @@
|
||||
Name: bluez
|
||||
Summary: Bluetooth utilities
|
||||
Version: 5.49
|
||||
Release: 3%{?dist}
|
||||
Version: 5.50
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
URL: http://www.bluez.org/
|
||||
|
||||
@ -21,23 +21,18 @@ Patch2: 0003-tools-csr_usb-Fix-compilation-failure.patch
|
||||
# https://github.com/hadess/bluez/commits/obex-5.46
|
||||
Patch3: 0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
|
||||
|
||||
# https://github.com/hadess/bluez/commits/hostname-plugin-5.47
|
||||
Patch4: 0001-hostname-Fix-BlueZ-5.XX-adapter-name-on-startup.patch
|
||||
|
||||
# https://github.com/hadess/bluez/commits/systemd-hardening
|
||||
Patch20: 0001-build-Always-define-confdir-and-statedir.patch
|
||||
Patch21: 0002-systemd-Add-PrivateTmp-and-NoNewPrivileges-options.patch
|
||||
Patch22: 0003-systemd-Add-more-filesystem-lockdown.patch
|
||||
Patch23: 0004-systemd-More-lockdown.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1567622
|
||||
Patch24: 0001-adapter-Don-t-refresh-adv_manager-for-non-LE-devices.patch
|
||||
|
||||
BuildRequires: git-core
|
||||
BuildRequires: dbus-devel >= 1.6
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libical-devel
|
||||
BuildRequires: readline-devel
|
||||
BuildRequires: libell-devel
|
||||
# For bluetooth mesh
|
||||
BuildRequires: json-c-devel
|
||||
# For cable pairing
|
||||
@ -267,6 +262,10 @@ make check
|
||||
%{_userunitdir}/obex.service
|
||||
|
||||
%changelog
|
||||
* Mon Jun 04 2018 Bastien Nocera <bnocera@redhat.com> - 5.50-1
|
||||
+ bluez-5.50-1
|
||||
- Update to 5.50
|
||||
|
||||
* Fri Apr 20 2018 Bastien Nocera <bnocera@redhat.com> - 5.49-3
|
||||
+ bluez-5.49-3
|
||||
- Fix crash on non-LE adapters (#1567622)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bluez-5.49.tar.xz) = bc2988649420232b92e2c6836857027369f05ace005972f575ed0601c02cc97a07a3b7a0707a8bad72be73df7e8096c8bf023530443556e87c2ccb667981b37d
|
||||
SHA512 (bluez-5.50.tar.xz) = 64a680e4b3c270bc2439610c91ad2aef36131d84401e4bbdf6c2b7ec8708a19dfc942b31b9189c38a97ca072c761c669ae1aace5f4ff5d06de3ccbf33184be45
|
||||
|
Loading…
Reference in New Issue
Block a user